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CHAPTER 2: GENERAL LEDGER 
Objectives 

The objectives are: 

• Explain the use of the Chart of Accounts in Microsoft Dynamics™ 
NAV 5.0.  

• Explain the elements of the G/L Account Card.  
• Explain the elements of the Chart of Accounts window.  
• Explain the Budgets feature in Microsoft Dynamics NAV 5.0.  
• Explain the elements of the Budgets window.  
• Demonstrate the process of setting up budgets manually and explain 

additional budget processes, such as deleting budget entries.  
• Explain the process of creating budgets using the Copy Budget 

function.  
• Explain the process of creating budgets using the Export Budget and 

Import Budget functions. 

Introduction 
General Ledger is the central application area of Microsoft Dynamics NAV 5.0. 
General Ledger is where financial information is: 

• Posted  
• Summarized  
• Reported  

In this section, two main components of the General Ledger application area are 
covered: Chart of Accounts and Budgets. 

The Chart of Accounts provides quick access to G/L accounts and account 
balances, and the Budgets feature provides a comparison between actual amounts 
and budgeted amounts, using a combination of: 

• G/L accounts  
• Periods  
• Global dimensions  
• Budget dimensions  
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Chart of Accounts Overview 
The core of a company is its Chart of Accounts, a list of the G/L accounts where 
all G/L entries are posted. Use the Chart of Accounts window to enter and view: 

• G/L accounts  
• Account balances  

G/L Accounts can be created: 

• Directly in the Chart of Accounts window for quick data entry.  
• In the G/L Account Card window to access all fields without 

showing hidden fields on the Chart of Accounts window.  

The following sections explain the fields and buttons on the G/L Account Card 
and the Chart of Accounts window. 

G/L Account Card Overview 
In the Chart of Accounts window, all G/L accounts are available and can be 
viewed at one time. However, there is also a G/L Account Card for each account, 
accessible from the Chart of Accounts window. 

To open an account card, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Chart of Accounts.  

2. Select an account to view.  
3. Click Account > Card.  

 
FIGURE 2.1 G/L ACCOUNT CARD 

In this section, the fields on the General and Posting tabs are explained and the 
functions on the menu buttons are described. 
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NOTE: The fields on the Consolidation tab are explained in the Multicompany 
Operations - Consolidations section, and the field on the Reporting tab is 
explained in the Multicurrency section, both within the Finance content. 

General Tab 

The following fields appear on the General tab: 

Field Description 

No. The number of the G/L Account. Note that No. Series are not 
used for G/L Accounts so this number is entered manually. 

Name A short description of the G/L Account. 

Income/Balance Indicates whether the account is an income or balance sheet 
account. This field is important in determining what accounts 
are closed at the fiscal year end. 

Debit/Credit Indicates the type of entries that will normally be posted to 
this account. The selection made does not restrict the type of 
transactions posted to the account, it only enhances the 
reporting capabilities. 

Account Type This field identifies the purpose of the account. The options 
are: 
• Posting: Used to accumulate transactions.  
• Heading: Used for descriptive purposes only.  
• Total: Used to total a range of accounts, as specified in 

the Totaling field. This option is useful for totaling 
groups of accounts that are not in the same classification, 
such as Gross Income.  

• Begin-Total / End-Total: The Begin-Total account marks 
the beginning of an account range. The End-Total account 
marks the end of the range. Each End-Total account has 
an account range in the Totaling field. The range can be 
calculated or entered manually.  

Totaling Determines which accounts go into a Total or an End-Total 
account type. 

No. of Blank 
Lines 

Determine the number of blank lines before the account is 
displayed in a report. 

New Page Determine if a new report page is printed after the account is 
displayed in the report. 

Search Name Used to search for a particular account when the account 
number cannot be recalled. 
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Field Description 

Balance Displays the current balance of the account. Click the 
AssistButton in this field to access the General Ledger 
Entries window. 

Reconciliation 
Account 

Determines whether the G/L account is included in the 
Reconciliation window in the general journals. The 
Reconciliation window is used prior to posting to review the 
effect of posting the accounts in the journal. 

Automatic 
Ext. Texts 

If selected, extended text set up on the account is 
automatically added to sales and purchase documents in the 
Description field. If not selected, extended text can still be set 
up on the account and added to documents manually. To 
create the extended text, click Account > Extended Texts. 

Direct Posting Indicate whether posting is allowed directly into this account 
from a journal line. Note that this field is automatically 
checked when new accounts are created. 

Blocked If selected, prevents entries from posting to this account. 
Accounts can be blocked and reopened as needed. 

Last Date 
Modified 

System generated field, displays the date when the G/L 
account was last modified. 

Posting Tab 

The Posting tab contains the fields that determine how the G/L and VAT 
transactions are recorded, including: 

Field Description 

Gen. Posting Type Defines whether the account is used only in 
connection with a Sale or Purchase transaction or with 
both types of transactions. This field is: 
• Used with the VAT Bus. Posting Group and 

VAT Prod. Posting Group fields to find the 
account the program posts VAT.  

• Filled in only for revenue and expense accounts 
where VAT is involved.  

Gen. Bus. Posting 
Group 

Identifies the default General Business Posting Group 
for the account. This field: 
• Indicates whom you sell-to or buy-from.  
• Is used with the Gen. Prod. Posting Group and 

Gen. Posting Type fields to find the G/L accounts 
to post to for sales, purchases, discount amounts, 
COGS, and inventory adjustments.  
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Gen Prod. Posting 
Group 

Identifies the default General Product Posting Group 
for the account. This field: 
• Indicates the type of item sold or purchased.  
• Is used with the Gen. Bus. Posting Group and 

Gen. Posting Type fields to find the G/L accounts 
to post to for sales, purchases, discount amounts, 
COGS, and inventory adjustments.  

VAT Bus. Posting 
Group 

Identifies the default VAT Business Posting Group for 
the account. This field is used with the VAT Prod. 
Posting Group and Gen. Posting Type fields to: 
• Determine VAT % and VAT calculation type.  
• Find the G/L accounts where the program posts 

VAT.  

VAT Prod. Posting 
Group 

Identifies the default VAT Product Posting Group for 
the account. This field is used with the VAT Bus. 
Posting Group and Gen. Posting Type fields to: 
• Determine VAT % and VAT calculation type.  
• Find the G/L accounts where the program posts 

VAT.  

Default IC Partner 
G/L Acc. No. 

Identifies the default IC G/L account number for this 
G/L account. When entering this G/L account in the 
intercompany general journal, the IC G/L account 
specified in this field is used as the default balancing 
account number. 

After the posting types and the posting group codes are assigned to a G/L 
account, these code are automatically inserted in a journal, sales, or purchase line 
when the G/L account is selected. 

NOTE: If the general posting groups are set up with default VAT posting 
groups, the VAT posting group fields are automatically populated with the 
default values when the general posting group(s) is selected. 

Account Button 

The Account button on the G/L Account Card contains the following option: 

Option Description 

List Displays a list of all accounts. However, this is not the same 
as the Chart of Accounts window because it does not 
include balance or amount information. 

Ledger Entries Displays all ledger entries for the account. 

Comments Used to display or enter comments relating to the account. 
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Option Description 

Dimensions Used to display or enter default dimensions for the account. 

Extended Texts Used to display or enter extended text for the account. 

Receivables-
Payables 

Provides a summary of: 
• Expected net operational cash flow from customers and 

vendors over time.  
• Open customer and vendor ledger entries sorted by their 

Due Date instead of Posting Date. 
 

This summary can be viewed by the:Period, such as daily, 
monthly, or quarterly.  
• Expected cash flow movement for a period by clicking 

the Net Change option.  
• Expected net balance of outstanding customer and 

vendor balances at any date by clicking the Balance at 
Date option.  

Where-Used List Displays a list of tables where this G/L account is used. 

Balance Button 

Use the Balance button to display information about the balances and transaction 
amounts for the account. Each window accessed from this button contains filters 
to assist in viewing the information more specifically. The Balance button 
contains the following options: 

Option Description 

G/L Account Balance Displays the balance or net change for the G/L 
account over time. 

G/L Balance Displays the balance or net change for all G/L 
accounts for a specific time period. 

G/L Balance by Dimensions Displays balance or net change information for 
all accounts. The information displayed in 
columns and lines can be set to one of the 
following views: 
• G/L account  
• Period  
• Global Dimensions 1 and 2  

These functions are described in more detail in the Financial Reporting section of 
the Business Intelligence content. 
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Functions Button 

The Functions button accesses the Apply Template function. This function is 
available when Master Templates are set up during the Rapid Implementation 
Methodology (RIM) process. 

Master Templates for G/L Accounts provide the ability to: 

• Create multiple default G/L Account set ups for accounts that are 
often created, such as expenses.  

• Use these templates as a basis when creating accounts of this type.  
• Eliminate the need for repetitive data entry for similar account 

creation.  

For more information about RIM and Master Templates, refer to the Application 
Setup content. 

After accounts are created in the G/L Account Card window, the Indent Chart 
of Accounts function must be run. This function is explained in the Chart of 
Accounts Window section of this content. 

Create an Account in the G/L Account Card 

To create an account in the G/L Account Card window, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Chart of Accounts.  

2. Click Account > Card.  
3. Press F3.  
4. In the No. field, enter the account number.  
5. In the Name field, enter a description.  
6. In the Income/Balance field, click the AssistButton and select the 

relevant option.  
7. In the Account Type, field, click the AssistButton and select the 

relevant option.  
8. If necessary, enter the range in the Totaling field.  
9. If necessary, enter a value in the No. of Blank Lines field.  
10. Place check marks in the check boxes as needed.  
11. Click the Posting tab.  
12. In the Gen. Posting Type field, click the AssistButton and select the 

relevant option.  
13. In the Gen. Bus. Posting Group field, click the AssistButton and 

select the relevant option.  
14. In the Gen. Prod. Posting Group field, click the AssistButton and 

select the relevant option.  
15. Enter information on the Consolidation and Reporting tabs as 

necessary.  
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To assign a dimension to the G/L account, follow these steps: 

1. Click Account > Dimensions.  
2. In the Dimension Code field, click the AssistButton and select the 

relevant dimension from the list.  
3. In the Dimension Value Code field, click the AssistButton and 

select the relevant dimension value from the list.  
4. If there are dimension posting requirements, in the Value Posting 

field, click the AssistButton and select the appropriate option.  
5. Close the Default Dimension and the G/L Account Card windows.  

To indent the new G/L account, follow these steps: 

1. In the Chart of Accounts window, locate and select the new account.  
2. Click Functions > Indent Chart of Accounts.  
3. Click Yes to run the indent function.  
4. Close the Chart of Accounts window.  
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Lab 2.1 - Create a Revenue Account 
Scenario 

A new revenue account needs to be created for miscellaneous sales. Since you 
are the accounting manager at CRONUS International Ltd., it is your 
responsibility to set up the new account using the G/L Account Card: 

• Miscellaneous Sales, account number 6140, is an income statement 
account used to accumulate transactions.  

• Direct posting is allowed.  
• The posting groups are:  

Field Value 

Gen Posting Type Sale 

Gen. Bus. Posting Group NATIONAL 

Gen. Prod. Posting Group MISC 

VAT Bus. Posting Group NATIONAL 

VAT Prod. Posting Group VAT25 

Ensure that the Account Types are formatted and the hierarchy is established. 

Challenge Yourself 
1. Create the revenue account using the information provided in the 

scenario.  
2. Run the function to align the account display.  

Need a Little Help? 
1. Open the G/L Account Card and insert a new line.  
2. Complete the General tab using the information provided in the 

scenario.  
3. Complete the Posting tab using the information provided in the 

scenario.  
4. Run the Indent Chart of Accounts function.  

Step by Step Solution 
1. On the Navigation Pane, click Financial Management > General 

Ledger > Chart of Accounts.  
2. Click Account > Card.  
3. Press F3.  
4. In the No. field, enter 6140.  
5. In the Name field, enter Sales, Miscellaneous.  
6. Ensure that the Income/Balance field displays Income Statement.  
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7. Ensure that the Account Type field displays Posting.  
8. Ensure that a check mark is in the Direct Posting field.  
9. Click the Posting tab.  
10. In the Gen. Posting Type field, click the AssistButton and select 

Sale.  
11. In the Gen. Bus. Posting Group field, click the AssistButton and 

select NATIONAL.  
12. In the Gen. Prod. Posting Group field, click the AssistButton and 

select MISC.  
13. Press ENTER or TAB. The VAT posting group fields are 

automatically populated based on the general posting group 
selections.  

14. Close the G/L Account Card.  
15. On the Chart of Accounts window, click Functions > Indent 

Chart of Accounts.  
16. Click Yes to run the indent function.  
17. Review the new account, notice that it is indented with the other 

sales accounts in the same range.  
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Chart of Accounts Window Overview 
The Chart of Accounts window contains the same fields on the G/L Account 
Card in a table format. In addition to the information on the individual account 
cards, the Chart of Accounts window displays the current Net Change and 
Balance information for the accounts. 

 
FIGURE 2.2 CHART OF ACCOUNTS WINDOW 

If the account numbers are numeric only, they are sorted differently depending 
on whether Microsoft Dynamics NAV Server or the Microsoft® SQL Server® is 
used: 

• With the Microsoft Dynamics NAV Server, account numbers are 
sorted in ascending numerical order.  

• With the Microsoft SQL Server, account numbers are sorted in 
ascending alphabetical order.  

As a result, care should be taken when setting up a numeric account number 
structure to ensure the correct ordering of accounts in the chart of accounts. 

The Chart of Accounts window contains buttons similar to the G/L Account 
Card window: 

• Account  
• Balance  
• Functions  

To use the buttons for an account in this window, select the line and then select 
the function. 

In this section, the functions on the menu buttons are described. 
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Account Button 

The Account button contains the following options: 

Options Description 

Card Displays the account card for the 
selected account on the line. 

Dimensions - Single The same function as the Dimensions 
function on the account card. 

Dimensions - Multiple Used to assign the same default 
dimensions to multiple accounts. 
 
Since the Chart of Accounts window 
is a list of accounts, it is possible to 
assign the same default dimensions to 
several accounts by selecting the 
relevant account lines; thus reducing 
the entry time needed for setting up 
default dimensions. 

Ledger Entries, Comments, Extended 
Texts, Receivables-Payables, Where-
Used List 

Same functions as described in the 
G/L Account Card section. 

Balance Button 

The Balance button contains the following options: 

Options Description 

G/L Account Balance, G/L Balance, 
G/L Balance by Dimension 

Same functions as described in the 
G/L Account Card section. 

G/L Account Balance/Budget Displays the actual and budgeted 
balance or net change for the G/L 
account over time. 

G/L Balance/Budget Displays the actual and budgeted 
balances or net change for all G/L 
accounts for a specific time period. 

Chart of Accounts Overview Displays the Chart of Accounts with 
different levels of detail. Use the 
Expand and Collapse feature to view 
only header and footer accounts or all 
of the accounts in between as well. 

These functions are described in more detail in the Financial Reporting section of 
the Business Intelligence content. 
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Functions Button 

The Functions button contains a different function: the Indent Chart of 
Accounts function. This function is used to: 

• Indent accounts according to the defined hierarchy.  

The hierarchy is established using the account types Begin-Total and End-Total. 
Account numbers within this range are included in the End-Total range in the 
Totaling field. 

Create an Account in the Chart of Accounts Window 

Although the G/L Account Card is typically used to create G/L accounts, the 
Chart of Accounts window provides a quick data entry point. This option is 
most useful for accounts that require minimal set up. 

To create an account in the Chart of Accounts window, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Chart of Accounts.  

2. Press F3.  
3. In the No. field, enter the account number.  
4. In the Name field, enter a description.  
5. In the Income/Balance field, click the AssistButton and select the 

relevant option.  
6. In the Account Type, field, click the AssistButton and select the 

relevant option.  
7. If necessary, enter the range in the Totaling field.  
8. In the Gen. Posting Type field, click the AssistButton and select the 

relevant option.  
9. In the Gen. Bus. Posting Group field, click the AssistButton and 

select the relevant option.  
10. In the Gen. Prod. Posting Group field, click the AssistButton and 

select the relevant option.  
11. Click Functions > Indent Chart of Accounts.  
12. Click Yes to run the indent function.  

Remember that other fields on the G/L Account Card can be displayed on the 
Chart of Accounts window using the Show Column feature. 

To assign a single dimension to a G/L account, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Chart of Accounts.  

2. Locate and select the G/L Account to assign a dimension to.  
3. Click Account > Dimensions - Single.  
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4. In the Dimension Code field, click the AssistButton and select the 
relevant dimension from the list.  

5. In the Dimension Value Code field, click the AssistButton and 
select the relevant dimension value from the list.  

6. If there are dimension posting requirements, in the Value Posting 
field, click the AssistButton and select the appropriate option.  

7. Close the Default Dimension window.  

Assign the Same Dimensions to Multiple G/L Accounts 

To assign the same dimensions to multiple G/L Accounts, follow these steps: 

1. In the Chart of Accounts window, select all the accounts to assign 
dimensions to.  

2. Click Account > Dimensions - Multiple.  
3. Fill in the Dimension Code, Dimension Value Code, and Value 

Posting fields.  
4. Close the Default Dimension-Multiple window.  
5. Verify that the dimension is assigned to multiple accounts by 

selecting an account and clicking Account > Dimensions - Single.  
6. Close the Default Dimension window and repeat step 5 for a 

different account.  
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Lab 2.2 - Create a VAT Account 
Scenario 

A new 30% purchase VAT has been introduced in the EU. As the accounting 
manager, it is your responsibility to set up the new account using the following 
criteria: 

• Purchase VAT 30 % EU, account number 5622.  
• A balance sheet account used to accumulate transactions.  
• Direct Posting is not allowed.  

It has also been decided to assign an Area dimension of 30, with a Code 
Mandatory value posting, to the following accounts: 

• 5620  
• 5621  
• 5622  

Ensure that the Account Types are formatted and the hierarchy is established. 

HINT: You will need to use the Show Column feature in this Lab. 

Challenge Yourself 
1. Enter the new account as specified in the scenario.  
2. Assign the dimension to the accounts as specified in the scenario.  
3. Run the function to align the account display.  

Need a Little Help? 
1. Open the Chart of Accounts window.  
2. Enter the new account as specified in the scenario.  
3. Show the Direct Posting check box.  
4. Assign the Area dimension to the VAT accounts as specified in the 

scenario.  
5. Run the Indent Chart of Accounts function.  

Step by Step Solution 
1. On the Navigation Pane, click Financial Management > General 

Ledger > Chart of Accounts.  
2. Press F3.  
3. In the No. field, enter 5622.  
4. In the Name field, enter Purchase VAT 30 % EU.  
5. Ensure that the Income/Balance field is set to Balance Account.  
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6. Ensure that the Account Type field is set to Posting.  
7. On the View menu, click Show Column.  
8. Click Direct Posting and click OK.  
9. In the Direct Posting check box, click to remove the check mark.  
10. If necessary, enter the range in the Totaling field.  
11. Click to highlight the lines for accounts 5620, 5621, 5622.  
12. Click Account > Dimensions > Dimensions-Multiple.  
13. In the Dimension Code field, click the AssistButton and select 

Area.  
14. Click OK.  
15. In the Dimension Value Code field, enter 30.  
16. In the Value Posting field, click the AssistButton and select Code 

Mandatory.  
17. Click OK to close the Default Dimension-Multiple window.  
18. Click Functions > Indent Chart of Accounts.  
19. Click Yes to run the indent function.  
20. Close the Chart of Accounts window.  
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General Ledger Budgets Overview 
In Microsoft Dynamics NAV 5.0, the budget feature provide the opportunity to: 

• Create multiple budgets for identical time periods using separate 
names.  

• Create simple or complex budgets by selecting a combination of G/L 
account, period, the two global dimensions, and four budget 
dimensions.  

• Copy budgets from previous periods and revise budget figures using 
an adjustment factor.  

• Export budgets to and import budgets from Microsoft® Excel®.  

In this section, Budgets are explained and the features listed above are 
demonstrated. 

Setting up G/L Budget Names 

Multiple budgets can be set up for identical time periods by creating budgets with 
separate names in the G/L Budget Names window. Global dimensions are 
available on all budgets, but four additional Budget dimensions can be specified 
on each budget. 

Budget dimensions can be used to: 

• Set filters on a budget  
• Add dimension information to budget entries  

To complete the G/L Budget Names window, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Budgets.  

2. In the Budget Name field, click the AssistButton. The G/L Budget 
Names window appears.  

3. In the Name field, enter a unique identifier for this budget.  
4. In the Description field, enter a short description.  
5. In the Budget Dimension 1 Code field, click the AssistButton and 

select the relevant dimension, as needed.  
6. In the Budget Dimension 2 Code field, click the AssistButton and 

select the relevant dimension, as needed.  
7. In the Budget Dimension 3 Code field, click the AssistButton and 

select the relevant dimension, as needed.  
8. In the Budget Dimension 4 Code field, click the AssistButton and 

select the relevant dimension, as needed.  
9. Click OK.  
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Budget Window Overview 
As a matrix-type window, the Budget window displays budgeted amounts in a 
variety of views, including: 

• G/L accounts in different time periods.  
• Dimensions in different time periods.  
• Dimensions and G/L accounts.  
• Dimensions and Dimensions.  

To access the Budget window, on the Navigation Pane, click Financial 
Management > General Ledger > Budgets. 

 
FIGURE 2.3 BUDGET WINDOW 

The window contains four areas: 

• Header  
• Lines  
• Trendscape  
• Menu buttons  

The header provides the: 

• Lines and columns display options  
• Filtering and rounding options  

In the lines, enter and view the budgeted amounts. Use the trendscape to adjust 
the period, such as days, months, years, and accounting periods. 
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The menu buttons are used to access alternative views of the budgets and to 
perform budget-related functions, such as: 

• Reversing column and line displays  
• Copying and deleting budgets.  
• Importing from and exporting to Excel.  

This section provides an overview of the Budget window. 

General Tab 

On the General tab of the header, the following fields appear: 

Field Definitions 

Budget Name Identifies the name of the budget in use. 

Show as Lines Determines how the lines are displayed. The options 
are:Global Dimension 1 and 2  
• G/L Account  
• Period  
• Budget dimensions, if specified for the selected 

budget  

Show as Columns Determines how the columns are displayed. The options 
are the same as in the Show as Lines field. 

Filters Tab 

The Filters tab contains fields used to determine how the information in the 
Budget window is displayed, including: 

Field Definitions 

Date Filter Used to filter amount fields by date. If this field contains 
starting and ending dates for a time period, the values in the: 
• Net Change and Budgeted Amount fields will display 

the net change on an account during that period.  
• Balance at Date and Budget at Date fields will show 

the balance from the starting to the ending dates of the 
filter.  

G/L Account 
Filter 

Used to set a filter for G/L accounts, so that the values in the 
following fields are based only on the G/L accounts included 
in the filter: 
• Balance 
• Budget at Date 
• Budgeted Amount 
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Field Definitions 
Two Global 
Dimension 
Filters 

Used to set a filter for a dimension, so that the values in the 
following fields are based only on the dimension values 
included in the filter: 
• Net Change 
• Balance at Date 
• Balance 
• Budget at Date 
• Budgeted Amount 

Four Budget 
Dimension 
Filters 

Used to set a filter for a budget dimension, so that the 
amounts in the budget fields are based only on entries with 
the dimension values included in the filter. 

 

NOTE: The more filters used in the G/L Budget, the more detail is included in 
management reporting. It is recommended to enter and filter budget 
information the same as when recording G/L entries. 

Options Tab 

The Options tab, contains two fields: 

Field Definitions 

Rounding Factor Determines how the amounts in the columns are 
rounded. 

Show Column Name If selected, the descriptive names given to dimension 
values and G/L accounts are displayed instead of the 
corresponding codes. 

Budget Lines 

The budget lines are separated into two sections: 

• The left pane define the lines as selected in the Show as Lines field 
in the header.  

• The right pane define the columns as selected in the Show as 
Columns field in the header.  
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The fields for the lines are static regardless of the selection in the Show as Lines 
field: 

Field Definitions 

Code, Name Displays the code and name of the G/L Account, 
Dimension, or Period. 

Budgeted Amount Displays the total budget of the selected G/L account, 
Dimension, or Period. This field is automatically 
calculated and updated; the underlying entries can be 
accessed by clicking the AssistButton in this field. 

The column fields are dynamic and determined by the selection the Show as 
Columns field. 

Balance Button 

The Balance button contains two options: 

Option Description 

G/L Account Balance/Budget 
Window 

Displays a summary of the following for 
the account selected on the Budget 
window: 
• Debit and credit balances  
• Budgeted amounts for different time 

periods  

G/L Balance/Budget Window Displays a scrollable summary, for the time 
period selected, of the following for each 
account in the chart of accounts: 
• Debit and credit balances  
• Budgeted amounts  

These windows are examined further in the Financial Reporting section of the 
Business Intelligence content. 

Functions Button 

The Functions button contains the following options: 

Option Description 

Reverse Lines and Columns Used to reverse the axis of the lines and 
columns. 

Copy Budget Used to copy an existing budget to a new 
one.This function is explained in more detail in 
the Copy Budget section of this content. 
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Option Description 

Delete Budget Used to delete entries of the selected 
budget.This function is explained in more detail 
in the Delete Budget Entries section of this 
content. 

Export to Excel / Import from 
Excel 

Used to export a budget from Microsoft 
Dynamics NAV 5.0 to an Excel workbook and 
vice versa. 
 
These functions are explained in more detail in 
the Export and Import Budgets section in this 
content. 

Fill in the Blanks: Budget Name and Budget Windows 

Fill in the blanks to test your knowledge of this section. 

1. Use the ____________  to adjust the period, such as days, months, 
years, and accounting periods. 

2. The ____ as Columns and ____ as Lines fields determine how  
columns and lines are displayed in a budget. 

3. The column fields in the budget lines are ________. 
4. Multiple budgets can be set up for identical time periods by creating 

budgets with separate _____. 
5. Budget __________ can be used to set filters on a budget. 
6. The Reverse  Lines and Columns function is used to reverse the ____ 

of the lines and columns in the budget. 

Create Budgets Manually 
In Microsoft Dynamics NAV 5.0, budgets can be created in many ways, 
including: 

• Manually  
• Copying from an existing budget  
• Importing an exported budget or an Excel spreadsheet  

This section includes a demonstration of creating a budget manually and also 
provides additional budget set up information, such as: 

• Changing or Adding Dimensions  
• Budgeting with Begin-Totals and End-Totals  
• Deleting Budget Entries  
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Demonstration: Create a Budget 

Scenario: Sara, the CFO at CRONUS International Ltd., needs to set a January 
2009 sales budget, using Budget dimensions Business Group and Customer 
Group. 

The Budget window matrix is set to: 

• Lines: G/L Account  
• Columns: Customer Group  
• Monthly view  
• Date filter: January 2009  
• Department (Global Dimension 1) filter: Sales  
• Column Names are displayed  

The following entries need to be made for January 2009: 

G/L 
Account 

Intercompany Large 
Business 

Medium 
Business 

Private Small 
Business 

6110 -20000 -15000 -10000 -5000 -1000 

6120 -15000 -10000 -8000 -1000  

6130 -10000 -5000 -3000   

In this demonstration, the January 2009 budget is set up. 

Steps 

To enter the budget header, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Budgets.  

2. In the Budget Name field, click the AssistButton.  
3. In the Name field, enter 2009.  
4. In the Description field, enter 2009 budget.  
5. In the Budget Dimension 1 Code field, click the AssistButton and 

select Business Group.  
6. Click OK.  
7. In the Budget Dimension 2 Code field, click the AssistButton and 

select Customer Group.  
8. Click OK.  
9. Click OK to close the G/L Budget Names window.  
10. In the Show as Lines field, ensure that G/L Account is selected.  
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11. In the Show as Columns field, click the AssistButton and select 
Customer Group.  

12. Click OK.  
13. In the Trendscape, click 31.  
14. Click the Filters tab.  
15. In the Date Filter field, enter 010109..013109.  
16. In the Department Filter field, click the AssistButton and select 

Sales.  
17. Click OK.  
18. Click the Options tab.  
19. Place a check mark in the Show Column Name check box.  

To enter the budget lines, follow these steps: 

1. In the lines section, locate and select G/L Account 6110.  
2. In the column pane, enter the following for account 6110: 

a. In the Intercompany Customers field, enter -20000.  
b. In the Large Business field, enter -15000.  
c. In the Medium Business field, enter -10000.  
d. In the Private field, enter -5000.  
e. In the Small Business field, enter -1000.  

 
3. Locate and select G/L Account 6120.  
4. In the column pane, enter the following for account 6120:  

a. In the Intercompany Customers field, enter -15000.  
b. In the Large Business field, enter -10000.  
c. In the Medium Business field, enter -8000.  
d. In the Private field, enter -1000.  

 
5. Locate and select G/L Account 6130.  
6. In the column pane, enter the following for account 6130:  

a. In the Intercompany Customer field, enter -10000.  
b. In the Large Business field, enter -5000.  
c. In the Medium Business field, enter -3000.  

The budget amounts for each customer group are now entered. 

By entering amounts directly in the Budget window, budget entries are created in 
the G/L Budget Entries window. Adjustments made to the budget are stored in 
this window. 
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To review the entries in the G/L Budget Entries window, follow these steps: 

1. Click the line for either G/L account 6110, 6120, or 6130.  
2. In the Budgeted Amount field, click the AssistButton.  
3. Close the G/L Budget Entries window.  

Change or Add Dimensions to Budget Entries 

After budget entries are created: 

• Existing dimensions can be changed.  
• Dimensions not included in the Budget window can be added.  

To use all four dimensions when setting up a budget, budget entries can be 
entered with amounts for each budget row and column with each dimension 
combination. Setting up a budget with all four dimensions can be achieved using 
either of these methods: 

• Change the filter each time for each combination  
• Manual enter many budget entries with different dimension 

combinations.  

NOTE: When creating a large multi-dimension budget for the first time, it is 
recommended to export the budget structure to Excel to complete the data entry. 
The budget can then be imported into Microsoft Dynamics NAV 5.0 using the 
Import to Excel function. 

Budget with Begin-Totals and End-Totals 

A Begin Total account can be used for entering budget amounts for an account 
group. 

For example, using the Sales of Retail accounts that includes Begin Total account 
6105, Accounts 6110 - 6190, and End Total account 6195: 

• If an amount is entered for Account No. 6105, this value is used as a 
budget for the entire account group for 6110..6190.  

• If amounts are entered for the Begin Total account and for another 
account of this group, for example 6120, both amounts are added in 
the End Total account on 6195.  

The total amount entered in each instance is not split into partial amounts to the 
existing G/L accounts of this group. 

To compare budget entries with the G/L entries by individual account (and not on 
the basis of an account group), budget information must be entered account by 
account. 
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Delete Budget Entries 

In the Budget window, if a value in a column field is deleted, a negative budget 
entry is created in the G/L Budget Entry window to maintain the traceability of 
the budget changes. 

To delete a budget entry in the Budget window, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Budgets.  

2. Locate and select a budget with entries.  
3. In a column line with an entry, press F4 to delete the value.  
4. Click the AssistButton in the column field of the deleted value.  
5. Notice that a negative budget entry has been inserted.  

To remove the negative budget entry and original entry in the G/L Budget Entry 
window, follow these steps: 

1. Select the entries.  
2. Press F4.  
3. Click Yes to delete the selected lines.  
4. Close the G/L Budget Entry window.  

All budget entries can also be removed from a budget without deleting the budget 
from the Budget window. 

Using the Delete Budget function, all entries are removed from the G/L Budget 
Entries window, without creating a negative entry. 

To delete a budget entry using the Delete Budget function, follow these steps: 

1. Open a budget with entries that must be deleted.  
2. Click Functions > Delete Budget.  
3. Click Yes to delete the budget entries.  
4. Notice that all budget entries have been removed from the Budget 

window.  
5. In a column field that had a budget amount, click the AssistButton 

to review the budget entries.  
6. Notice that a line with minimal information, and no budget amounts, 

remain.  
7. Close the G/L Budget Entries and Budget windows.  
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Lab 2.3 - Create a Budget 
Scenario 

The CFO at CRONUS International Ltd. has asked you to set up a new January 
2009 G/L Account budget by areas for the sales of Medium-sized industrial 
customers. 

Name the budget Region09, for Sales by Region 2009 and use Budget 
Dimensions Business Group, Customer Group, and Area. The budgeted revenues 
are: 

Area G/L Account Budgeted Amount 

Europe North (EU) 6110 -400,000.00 

Europe North (EU) 6120 -100,000.00 

Europe North (Non EU) 6130 -80,000.00 

Europe South 6120 -120,000.00 

America North 6130 -90,000.00 

America South 6130 -50,000.00 

Challenge Yourself 
1. Set up the Budget Name using the criteria stated in the scenario.  
2. Set up the Budget header using the criteria stated in the scenario.  
3. Use a monthly view to enter the budget amounts for the sales 

accounts.  

HINT: It will help to view the description column names prior to entering the 
budget amounts. 

Need a Little Help? 
1. Open the Budget window, and access the G/L Budget Name 

window.  
2. Set up the Budget Name using the criteria stated in the scenario.  
3. In the Budget window, set the lines and columns to prepare to enter 

accounts and areas.  
4. Set the date and dimension filters, based on the information stated in 

the scenario.  
5. Choose to view the description column names.  
6. Using the monthly view, enter the budget amounts as stated in the 

scenario.  
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Step by Step Solution 
1. On the Navigation Pane, click Financial Management > General 

Ledger > Budgets.  
2. In the Budget Name field, click the AssistButton.  
3. In the Name field, enter Region09.  
4. In the Description field, enter Sales by Region 2009.  
5. In the Budget Dimension 1 Code field, click the AssistButton and 

select Business Group.  
6. In the Budget Dimension 2 Code field, click the AssistButton and 

select Customer Group.  
7. In the Budget Dimension 3 Code field, click the AssistButton and 

select Area.  
8. Click OK.  
9. In the Budget window, in the Show as Lines field, click the 

AssistButton and select G/L Account.  
10. In the Show as Columns field, click the AssistButton and select 

Area.  
11. Click the Filter tab.  
12. In the Date Filter field, enter 010109..013109.  
13. In the Department Filter field, click the AssistButton and select 

Sales.  
14. In the Businessgroup Filter field, click the AssistButton and select 

Industrial.  
15. In the Customergroup Filter field, click the AssistButton and 

select Medium.  
16. Click the Options tab.  
17. Ensure that there is no rounding set and click the Show Column 

Name check box.  
18. In the Trendscape, click 31.  
19. In the lines, locate G/L Account 6110.  
20. In the area Europe North (EU) field, enter -400000.  
21. For account 6120, in the area Europe North (EU) field, enter -

100000.  
22. For account 6120, in the area Europe South field, enter -120000.  
23. For account 6130, in the area Europe North (EU) field, enter -

80000.  
24. For account 6130, in the area America North field, enter -90000.  
25. For account 6130, in the area America South field, enter -50000.  
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Copy Budgets 
To avoid manually entering a new budget, use the Copy Budget function to copy 
from existing: 

• G/L Budget entries  
• G/L entries  

To access this function from the Budget window, click Functions > Copy 
Budget. 

 
FIGURE 2.4 COPY G/L BUDGET WINDOW 

 

NOTE: The Copy Budget function is also available from the G/L Account 
Balance/Budget window and the G/L Balance/Budget window, accessible from 
the Balance button on the Budget window. 

The Copy G/L Budget batch job contains three areas, used to specify: 

• The Copy from source  
• The Copy to destination  
• How to Apply the copied information  

In this section, each area is explained and an existing budget is copied to a new 
budget. 
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Copy Budget Batch Job Overview 

The Copy from area is used to determine where the copied budget entries are 
coming from. The fields within this area are specified based on the selection in 
the Source field: 

Option Definition 
G/L Entry The budget is based on actual G/L entries for a 

specified period. Specify: 
• An account range and/or date range in the G/L 

Account No. and Date fields to determine the 
information to be copied.  

• Whether to include Closing Entries.  

G/L Budget Entry The budget is based on G/L Budget entries of an 
existing budget. Specify an: 
• Existing Budget Name to copy from.  
• Account range and/or date range in the G/L 

Account No. and Date fields to filter the 
information copied.  

For both Source options, in the Dimensions field, click the AssistButton and: 

• Click to insert a check mark in the Selected check box for each 
dimension to be copied to the new budget entries.  

• Set additional filters for the copying process by defining Dimension 
Value Filters.  

The Copy to area, is used to specify where the copied budget information is to be 
sent. The following fields are included: 

Field Definition 

Budget Name Enter the name of the new budget, or click the 
AssistButton to select an existing Budget Name. 

G/L Account No. Enter the G/L account number if one or more ledger 
entries must be copied to one G/L account. 
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The Apply area includes several calculation options to use when copying 
budgets, including: 

Field Definition 

Adjustment Factor Enter an adjustment factor that the source entries are 
multiplied by during the copy process. 
 
For example, an adjustment of 1.1 increases amounts 
by 10% and an adjustment of .89 decreases amounts 
by 11%. 

Rounding Method Specify how the new budget entries are rounded. 

Date Change Formula Enter a formula that calculates the date for the new 
entries based on the entries being copied, for 
example 1M for the next month. 

Date Compression Compress the entries copied by a selected period to 
reduce the number of new entries created. 

For more information about the fields on this window, press F1 to access online 
help. 

Demonstration: Copying Budget Entries 

Scenario: Phyllis, the accounting manager at CRONUS International Ltd., has 
been asked to prepare a sales campaign budget for February 2008. A sales 
campaign budget already exists for January 2008; the only difference between 
the January and February budgets is that the February campaign budget is half 
the amount of January. 

To reduce the data entry time, Phyllis decides to copy the January budget entries 
for February, using the following criteria: 

• New budget entries can be added to the 2008 budget, rather than 
create a new budget.  

• Same dimensions as January, including:  
– Department  
– Project  
– Area  
– Sales Campaign  

 
• Decrease the January amounts in half.  

In this demonstration, the Copy Budget function is used. 
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Steps 

To create the new budget header, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Budgets.  

2. Click Functions > Copy Budget.  
3. In the Source field, click the AssistButton and select G/L Budget 

Entry.  
4. In the Budget Name field, click the AssistButton and select 2008 

budget.  
5. Click OK.  
6. In the Date field, enter 010108..013108.  
7. In the Dimensions field, click the AssistButton and click the 

Selected check boxes for Area, Department, Project, and Sales 
Campaigns.  

8. Click OK.  

To copy from the January 2008 budget, follow these steps: 

1. Under Copy to, in the Budget Name field, click the AssistButton 
and select 2008 budget.  

2. In the Adjustment Factor field, enter .5.  
3. In the Date Change Formula field, enter 1M.  
4. Click OK.  
5. Click Yes to start the copy process.  
6. Click OK.  
7. In the Budget window, in the Budget Name field, click the 

AssistButton and select 2008.  
8. Set the Lines to show G/L Account, the Columns to show Period, 

and the Trendscape to 31.  
9. Review the entries for February, noticing that the amounts have been 

decreased by 50%.  

NOTE: Instead of changing the lines and columns in the header, switch 
between periods using the Next Period button in the Trendscape or by changing 
the Date Filter. 
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Lab 2.4 - Copy a Budget 
Scenario 

A couple of weeks have past since you created the January 2009 sales budget. 
You are now asked to create new sales budget entries for February 2009: 

• Dimensions filtering is the same as January filters, including:  
– Departments  
– Business Groups  
– Customer Groups  
– Areas 

  
• February sales are budgeted to be 10% greater than January.  

You decide to use the Copy Budget function instead of manually entering the 
budget. Review the February entries after running the copy function. 

Challenge Yourself 
1. Access the Copy G/L Budget batch job.  
2. Use the January 2009 sales budget to copy from and to.  
3. Include closing entries and set dimensions as used in the January 

sales budget.  
4. Set adjustment factors and date changes.  
5. Open the February budget and review the entries.  

HINT: Do not change the defaults for Closing Entries (Include) and Date 
Compression (Day).Switch between periods using the Next Period button or by 
changing the date filters. 

Need a Little Help? 
1. Open the Budget window and open the Copy Budget function.  
2. Using budget entries, use the January 2009 sales budget to copy 

from.  
3. Set the January date filters.  
4. Set Dimensions as stated in the scenario.  
5. Use the January 2009 sales budget to copy to.  
6. Set the 10% adjustment for the new budget.  
7. Update the date formula for the new budget.  
8. Run the batch job.  
9. Open the 2009 sales budget.  
10. Access and review the February entries.  
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HINT: Do not change the defaults for Closing Entries (Include) and Date 
Compression (Day).Switch between periods using the Next Period button or by 
changing the date filters. 

Step by Step Solution 
1. On the Navigation Pane, click Financial Management > General 

Ledger > Budgets.  
2. Click Functions > Copy Budget.  
3. In the Source field, click the AssistButton and select G/L Budget 

Entry.  
4. In the Budget Name field, click the AssistButton and select 

REGION02.  
5. In the Date field, enter 010109..013109.  
6. In the Dimensions field, click the AssistButton and click the 

Selected check boxes for Area, Business Group, Customer Group, 
and Department.  

7. Click OK.  
8. Under Copy to, in the Budget Name field, click the AssistButton 

and select REGION02.  
9. In the Adjustment Factor field, enter 1.1.  
10. In the Date Change Formula field, enter 1M.  
11. Click OK.  
12. Click Yes to start the copy process.  
13. Click OK.  
14. In the Budget window, in the Budget Name field, click the 

AssistButton and select REGION09.  
15. In the Trendscape, click the Next Period button (the right arrow).  
16. Review the entries, noticing that the:  

• Filters are set  
• Amounts have been increased by 10%.  
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Export and Import Budgets 
Microsoft Dynamics NAV 5.0 provides the option of creating budgets using 
export and import functions. 

Budgets are exported to Excel using the Export Budget to Excel batch job. Once 
budgets are exported: 

• Use Excel to modify and add to the budget.  
• Create new budgets based on the exported budget figures.  

Budget are imported using the Import Budget from Excel batch job. Using this 
batch job, import budgets: 

• Exported from Microsoft Dynamics NAV.  
• Created in Excel.  
• Into existing or new budgets.  

NOTE: Before creating a budget in Excel, it is recommend to export a budget 
from Microsoft Dynamics NAV 5.0 to obtain the proper format. 

In this section, the batch jobs used to export and import budgets are explained 
and then a demonstration of the export and import budget process is provided. 

Export Budget to Excel Batch Job 

Before opening the Export Budget to Excel batch job, ensure that the proper 
budget is selected in the Budget Name field. 

NOTE: The settings in the Show as Lines and Show as Columns fields do not 
effect the budget export. The exported budget always displays the lines as G/L 
Accounts and the columns (displayed as dimensions and periods) are 
determined in the Export to Excel batch job. 

The Export Budget to Excel batch job is accessed from the Budget window by 
clicking Functions > Export Budget. 

This batch job contains two sections: 

• G/L Budget Entry  
• Options  

The G/L Budget Entry tab is automatically populated with the Budget Name 
and Global Dimension and Budget Dimension filters specified on the Filter tab. 
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These filters determine the entries exported to Excel and can be changed. 
However, only the budget dimensions contained on the selected budget can be 
used. 

CAUTION: If filters are set for dimensions on the G/L Budget Entry tab, the 
same dimensions must be specified in the Column Dimensions field on the 
Options tab. If the same dimensions are not used, dimension information is lost 
when the budget is imported into Microsoft Dynamics NAV 5.0 . 

The Options tab contains the following fields: 

Field Description 

Start Date Identifies the first date to be included in the 
exported budget. 

No. of Periods Identifies the number of accounting periods to 
be included in the exported budget. 
 
The total time that the budget will encompass is 
determined by the combination of this field and 
the Period Length field. 

Period Length Uses a formula to identify the length of the 
accounting periods to be included in the 
exported budget. For example, 1M for one 
month. 

Column Dimensions Determines which dimensions are shown as 
columns in the exported budget. These must 
include the dimensions set as filters on the 
G/L Budget Entry tab. 

Include Totaling Formulas If selected, sum formulas are created in Excel 
based on the Totaling fields used in the Chart 
of Accounts window. 
 
Using this function means that if budget figures 
are altered in Excel, the Excel cells used as 
totaling fields are simultaneously updated. 

The Start Date, No. of Periods, and Period Lengths must be specified to run 
the export batch job. 

Exported Budgets 

The Excel spreadsheet is generated using this base structure: 

• The Budget Name and Dimension filters appear in the top left.  
• The G/L Accounts appear in the rows.  
• The dimensions, if specified, and periods appear in the columns.  
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To import budgets into Microsoft Dynamics NAV 5.0, the base structure of the 
exported budget must not change. Therefore, it is recommended to create the 
budget structure in Microsoft Dynamics NAV 5.0 and then run the export 
process. 

Additional dimension columns and dimension value filters can be added after the 
export, but before importing the finalized budget amounts, as long as these 
changes are made to both the: 

• Excel spreadsheet.  
• Budget dimensions in Microsoft Dynamics NAV 5.0.  

When all changes are made, save the Excel spreadsheet. 

Import Budget from Excel Batch Job 

The Import Budget from Excel batch job is accessed from the Budget window 
by clicking Functions > Import Budget. This batch job contains two sections: 

• Import from  
• Import to  

The fields on the Option tab include: 

Field Description 

Workbook File Name Specifies the path to the saved Excel budget. 

Worksheet Name Identifies which worksheet from the Excel 
Workbook to be imported. 

Budget Name Specifies the budget in Microsoft Dynamics NAV 
5.0 that entries will be imported to. 

Option Identifies the method used to import budget entries. 
The options are: 
• Replace Entries: Imported entries replace 

existing entries with the same dimension, date, 
and G/L Account combination.  

• Add Entries: Imported entries are added to 
existing entries with the same dimension, date, 
and G/L Account combination. Use this option 
to create a single consolidated budget from a 
number of individual budgets created in separate 
Excel worksheets.  

Description Specifies a description that is assigned to the 
imported budget entries to help distinguish between 
other budget entries. 
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NOTE: Before importing the budget, close Excel. 

Demonstration: Export and Import a Budget 

Scenario: Cassie, the accountant at CRONUS International Ltd., has been asked 
to create November budget entries for the 2008 budget. 

Cassie prefers to work in Excel so she exports the 2008 budget from Microsoft 
Dynamics NAV 5.0 and enters the new budget entries in Excel. Once finished, 
she imports the new budget into Microsoft Dynamics NAV 5.0. 

The new entries for the 2008 sales campaign budget include: 

• Single month entry, on 11/01/08  
• Global dimension: Sales  
• Budget dimensions: Area and Sales Campaign  
• Entries:  

G/L Account Area Department Sales Campaign Amount 

6120 30 Sales Winter -4500 

6130 70 Sales Winter -1250 

7230 70  Winter 55000 

In this demonstration, a budget is exported to Excel, modified, and then imported 
into Microsoft Dynamics NAV 5.0. 

Steps 

To export the budget, follow these steps: 

1. On the Navigation Pane, click Financial Management > General 
Ledger > Budgets.  

2. In the Budget Name field, click the AssistButton and select 2008 
budget.  

3. Click OK.  
4. Click Functions > Export to Excel.  
5. Click the Options tab.  
6. In the Start Date field, enter 110108.  
7. In the No. of Periods field, enter 1.  
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8. In the Period Length field, enter 1M.  
9. In the Column Dimensions field, click the AssistButton.  
10. Click the Selected check box for Area, Department, and Sales 

Campaign.  
11. Click OK.  
12. Click OK to start the export process.  

To modify the budget in Excel, follow these steps: 

1. In Excel, locate G/L Account 6120.  
2. In the Area field, enter 30.  
3. In the Department field, enter Sales.  
4. In the Sales Campaign field, enter Winter.  
5. In the date field (11/01/08), enter -4500.  
6. Locate G/L Account 6130.  
7. In the Area field, enter 70.  
8. In the Department field, enter Sales.  
9. In the Sales Campaign field, enter Winter.  
10. In the date field, enter -1250.  
11. Locate G/L Account 7230.  
12. In the Area field, enter 70.  
13. In the Sales Campaign field, enter Winter.  
14. In the date field, enter 55000.  
15. Save the Excel spreadsheet to the desktop.  
16. Close Excel.  

To import the budget, follow these steps: 

1. In Microsoft Dynamics NAV 5.0, open the Budget window.  
2. Click Functions > Import from Excel.  
3. In the Workbook File Name field, click the AssistButton and locate 

the saved Excel file on the desktop.  
4. In the Worksheet Name field, click the AssistButton. The Budget 

option is selected.  
5. Click OK.  
6. In the Budget Name field, click the AssistButton and select 2008 

budget.  
7. Click OK.  
8. In the Option field, click the AssistButton and select Add Entries.  
9. Update the Description field as needed.  
10. Click OK.  
11. Click Yes to add entries for Budget Name 2008.  
12. Click OK.  
13. Review the entries for November 1, 2008.  
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Lab 2.5 - Export and Import a Budget 
Scenario 

As the accountant for CRONUS International Ltd., you have been asked to set up 
the December budget entries for the 2008 sales campaign budget. 

Since the dimensions are the same as previous months, you choose to export the 
budget into Excel to enter the December budget entries. The new entries for the 
2008 sales campaign budget include: 

• Bi-monthly entries, on 12/01/08 and 12/15/08  
• Global dimension: Sales  
• Budget dimensions: Area and Sales Campaign  
• Entries:  

G/L 
Account 

Area Department Sales 
Campaign 

Amount12/1/08 Amount12/15/08 

6120 30 Sales Winter -3750 -3750 

6130 70 Sales Winter -2000 -1200 

7230 70  Winter 50000 40000 

When you have finished entering the new information: 

• Import the budget entries into the 2008 budget.  
• Review the December entries.  

Challenge Yourself 
1. Export the 2008 budget to Excel.  
2. Add the new entries.  
3. Import the December 2008 entries into the 2008 budget.  
4. Review the December entries.  

HINT: Consider a two week period length to achieve the two dates in the 
exported budget. Remember that the Period Length works with the No. of 
Periods. 

Need a Little Help? 
1. Open the 2008 Budget window and the Export to Excel batch job.  
2. On the Options tab, set the date and the periods. See the Hint below.  
3. Set the column dimensions as stated in the scenario.  
4. Run the export batch job.  
5. In the exported budget, add the new entries as stated in the scenario.  
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6. Save the spreadsheet to a memorable location.  
7. In Microsoft Dynamics NAV 5.0, open the Import from Excel 

batch job.  
8. On the Options tab, set the Excel spreadsheet information and add 

the entries to the 2008 budget.  
9. Do not change the import description.  
10. Run the import batch job.  
11. Review the December entries, verifying that the entries were posted 

as stated in the scenario.  

HINT: Consider a two week period length to achieve the two dates in the 
exported budget, and remember that the Period Length works with the No. of 
Periods. 

Step by Step Solution 
1. On the Navigation Pane, click Financial Management > General 

Ledger > Budgets.  
2. In the Budget Name field, click the AssistButton and select 2008 

budget.  
3. Click OK.  
4. Click Functions > Export to Excel.  
5. Click the Options tab.  
6. In the Start Date field, enter 120108.  
7. In the No. of Periods field, enter 2.  
8. In the Period Length field, enter 2W.  
9. In the Column Dimensions field, click the AssistButton.  
10. Click the Selected check box for Area, Department, and Sales 

Campaign.  
11. Click OK.  
12. Click OK to start the export process.  
13. Locate G/L Account 6120.  
14. In the Area field, enter 30.  
15. In the Department field, enter Sales.  
16. In the Sales Campaign field, enter Winter.  
17. In the date field (12/01/08), enter -3750.  
18. In the date field (12/15/08), enter -3750.  
19. Locate G/L Account 6130.  
20. In the Area field, enter 70.  
21. In the Department field, enter Sales.  
22. In the Sales Campaign field, enter Winter.  
23. In the date field (12/01/08), enter -2000.  
24. In the date field (12/15/08), enter -1200.  
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25. Locate G/L Account 7230.  
26. In the Area field, enter 70.  
27. In the Sales Campaign field, enter Winter.  
28. In the date field (12/01/08), enter 50000.  
29. In the date field (12/15/08), enter 40000.  
30. Save the Excel spreadsheet to the desktop.  
31. Open the Budget window in Microsoft Dynamics NAV.  
32. Click Functions > Import from Excel.  
33. In the Workbook File Name field, click the AssistButton and locate 

the saved Excel file on the desktop.  
34. In the Worksheet Name field, click the AssistButton. The Budget 

option is selected.  
35. Click OK.  
36. In the Budget Name field, click the AssistButton and select 2008 

budget.  
37. Click OK.  
38. In the Option field, click the AssistButton and select Add Entries.  
39. Click OK.  
40. Click Yes to add entries for Budget Name 2008.  
41. Click OK.  
42. Review the entries for December 2008.  
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Summary 
This section introduced two main areas of the General Ledger in Microsoft 
Dynamics NAV 5.0: 

• Chart of Accounts  
• Budgets  

As the core component of a company, the Chart of Accounts sections covered the 
G/L Account Card and the Chart of Accounts windows, and the process for 
creating G/L accounts from both windows. 

The Budget sections explained the Budget window and setting up budgets. The 
various processes available when working with Budget entries were also 
explained, including: 

• Changing and adding dimensions  
• Deleting and copying budget entries  
• Exporting and importing budgets  

Understanding Chart of Accounts is critical when working in Microsoft 
Dynamics NAV 5.0, and while budgeting is not a required component of the 
program, this feature provides greater insight into a company's financial status. 
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Test Your Knowledge 
1. What function is used to create multiple default G/L Account set ups for 

accounts that are often created, such as expenses? 

( ) Assign Template 
( ) Enter Template 
( ) Import Template 
( ) Apply Template 

2. In the G/L Account Card, what field is used to determine what accounts are 
closed during the fiscal year end closing process? 

( ) Reconciliation Account 
( ) Debit/Credit 
( ) Account Type 
( ) Income/Balance 

3. During the Import from Excel process for budgets, what option is best suited 
to create a single consolidated budget from a number of individual budgets 
created in separate Excel Worksheets? 

( ) Append Entries 
( ) Add Entries 
( ) Replace Entries 
( ) Combine Entries 

4. What type of Dimensions are available when creating budgets? (Select all 
that apply.) 

( ) Company 
( ) Global 
( ) Shortcut 
( ) Budget 

5. In the Copy Budget function, what Adjustment Factor is used to increase the 
budgeted amounts by 15%? 

( ) .15 
( ) 1.5 
( ) 1.15 
( ) 15 

Microsoft Official Training Materials for Microsoft Dynamics ™ 
Your use of this content is subject to your current services agreement 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  



Chapter 2: General Ledger 

2-45 

6. What is the Chart of Accounts window mainly used for? (Select all that 
apply.) 

( ) Viewing G/L Accounts 
( ) Creating General Ledger entries 
( ) Printing G/L Account/Budget Comparisons 
( ) Viewing account amounts 

7. From where can the Copy Budget function be run? (Select all that apply.) 

( ) Budget window 
( ) G/L Account Balance/Budget window 
( ) Chart of Accounts Overview window 
( ) G/L Balance/Budget window 

8. What process is used to delete all budget entries from a budget without 
creating negative budget entries. (Select all that apply.) 

( ) In the column with an entry amount, press F4. 
( ) Run the Delete Budget Entries function. 
( ) Run the Delete Budget function. 
( ) In the G/L Budget Entries window, delete all entries. 
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Quick Interaction: Lessons Learned 
Take a moment and write down three Key Points you have learned from this 
chapter: 

1. 

 

 

 

 

2. 

 

 

 

 

3. 
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Solutions 
Budget Window Overview 

Fill in the Blanks: Budget Name and Budget Windows 

Fill in the blanks to test your knowledge of this section. 

1. Use the _Trendscape__ to adjust the period, such as days, months, 
years, and accounting periods.  

2. The _Show__ as Columns and ____ as Lines fields determine how 
columns and lines are displayed in a budget.  

3. The column fields in the budget lines are _dynamic__.  

4. Multiple budgets can be set up for identical time periods by creating 
budgets with separate _names_.  

5. Budget _dimensions__ can be used to set filters on a budget.  

6. The Reverse Lines and Columns function is used to reverse the 
_axis__ of the lines and columns in the budget.  

Test Your Knowledge 

1. What function is used to create multiple default G/L Account set ups for 
accounts that are often created, such as expenses? 

( ) Assign Template 
( ) Enter Template 
( ) Import Template 
(•) Apply Template 

2. In the G/L Account Card, what field is used to determine what accounts are 
closed during the fiscal year end closing process? 

( ) Reconciliation Account 
( ) Debit/Credit 
( ) Account Type 
(•) Income/Balance 
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3. During the Import from Excel process for budgets, what option is best suited 
to create a single consolidated budget from a number of individual budgets 
created in separate Excel Worksheets? 

( ) Append Entries 
(•) Add Entries 
( ) Replace Entries 
( ) Combine Entries 

4. What type of Dimensions are available when creating budgets? (Select all 
that apply.) 

( ) Company 
(√) Global 
( ) Shortcut 
(√) Budget 

5. In the Copy Budget function, what Adjustment Factor is used to increase the 
budgeted amounts by 15%? 

( ) .15 
( ) 1.5 
(•) 1.15 
( ) 15 

6. What is the Chart of Accounts window mainly used for? (Select all that 
apply.) 

(√) Viewing G/L Accounts 
( ) Creating General Ledger entries 
( ) Printing G/L Account/Budget Comparisons 
(√) Viewing account amounts 

7. From where can the Copy Budget function be run? (Select all that apply.) 

(√) Budget window 
(√) G/L Account Balance/Budget window 
( ) Chart of Accounts Overview window 
(√) G/L Balance/Budget window 

8. What process is used to delete all budget entries from a budget without 
creating negative budget entries. (Select all that apply.) 

( ) In the column with an entry amount, press F4. 
( ) Run the Delete Budget Entries function. 
(√) Run the Delete Budget function. 
(√) In the G/L Budget Entries window, delete all entries. 
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