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Use Vivado to build an Embedded System

Introduction

This lab guides you through the process of using Vivado to create a simple ARM Cortex-A9 based
processor design targeting the ZedBoard development board. You will use Vivado to create the hardware
system and SDK (Software Development Kit) to create an example application to verify the hardware
functionality.

Objectives

After completing this lab, you will be able to:
e Create a Vivado project for a Zynqg system

e Use the IP Integrator to create a hardware system
e Use SDK to create a standard memory test project
e Run the test application on the board
Procedure

This lab is separated into steps that consist of general overview statements that provide information on
the detailed instructions that follow. Follow these detailed instructions to progress through the lab.

This lab comprises 5 primary steps: You will create a top-level project using Vivado, create the processor
system using the Vivado IP Integrator, generate the top-level HDL and export the design to SDK, create a
Memory Test application in SDK, and finally, test in hardware.

Design Description

The purpose of the lab exercises is to walk you through a complete hardware and software processor
system design. Each lab will build upon the previous lab. The following diagram represents the completed
design (Figure 1).
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Figure 1 Completed Design

i

In this lab, you will use IP Integrator to create a processing system based design consisting of the
following (Figure 2):

e ARM Cortex A9 core (PS)

e UART for serial communication

e DDRS controller for external DDR3_SDRAM memory
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Figure 2 Processor Design of this Lab

General Flow for this Lab
Step 1: Step 2: Step 3: Step 4: Step 5:
Create a Create Generate Create a Verify

project using Processor Top-Level |:> Memory Functionality
Vivado System using HDL and TestApp in in Hardware
IP Integrator Export to SDK
SDK

ZedBoard 1-2

www.xilinx.com/university

© copyright 2013 Xilinx

xup@xilinx.com

& XILINX.



Lab Workbook Use Vivado to build an Embedded System

Create a Vivado Project Step 1

1-1.

1-1-1.

1-1-2.

1-1-3.

1-1-4.

Launch Vivado and create an empty project targeting the Zedboard (having
xc7z020clg484-1 device) and using the VHDL language.

Open Vivado by selecting Start > All Programs > Xilinx Design Tools > Vivado 2013.3 >
Vivado 2013.3

Click Create New Project to start the wizard. You will see the Create a New Vivado Project
dialog box. Click Next.

Click the Browse button of the Project Location field of the New Project form, browse to
c:\xup\embedded\labs, and click Select.

Enter lab1 in the Project Name field. Make sure that the Create Project Subdirectory box is
checked. Click Next.

gl“‘ Mews Project @

Project Name

Enter a name For vour project and specify a directary where the project data files will be stored ﬁ.-'
Project name:
Project I_ocatic:n:| Cifxupfembedded]labs |:|

Create project subdirectory

Project will be created at: C:fxupfembeddedlabs/labl

| < Back || Mest = | Finish Cancel

Figure 3 Project Name Entry

1-1-5. Select RTL Project in the Project Type form, and click Next.

1-1-6. Select VHDL as the Target language and Mixed as the Simulator language in the Add Sources

form, and click Next.
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ﬁ_:. MNewr Project @

Add Sources

Specify HOL and netlist Files, or directories containing HOL and netlist files, to add to wour project. Create a ‘\I'L
new source file on disk and add it to wour project, You can also add and create sources |ater,

Index Mame Library  HDL Source For Location

Add Files. .. ] [ Add Directories, .. ] ’ Create File,..

Scan and add RTL include files inko project
Copy sources inko projeck

Add sources from subdirectories

Target language: |WHDL = | Simulator language: | Mixed  «

[ <Back i Mext> i  Finish

Figure 4 Add sources to new project

1-1-7. Click Next two more times to skip Adding Existing IP and Add Constraints

1-1-8. In the Default Part form, select Boards, and select Zedboard Zynq Evaluation and
Development Kit. Click Next.

gk:{:. Mewr Project @

Default Part

Choose a default ¥ilinx part or board For your project, This can be changed later, “i’
Specify Filter
i Parts Board Yendor | All v
@ Eoards Library | All -
Marne | All -
Wersion | Lakest -
Search:
Board Bioard B_c-ard Board Bc-ar_d Part
Yendor Library Mame Wersion
@ MicroZed Board em.avnek,com zyng microzed = @ wc7z010 .
' ZedBoard Zyng Evaluation and Developrment Kit [em, avnet, com
B Artix-7 AC701 Evaluation Platform wiline, com arkix? ac?ol 1.0 & xc7a200
@ Kintex-7 KC705 Evaluation PlatForm xilire., comm kinkex7 ke705 1.1 @ wc7k3zs| =
@ Virtex-7 WiCFO7 Evaluation Platform ilinz, com wirkex? w707 1.1 @ wcTvxds
@ Virkex-7 WI709 Evaluation Platform wiline, com wirkex? we709 1.0 i =eTvrad
@ 2¥NQ-7 20702 Evaluation Board xilire.cam zyng zc70z 1.0 @ xc7z020 _
Bl 7vrn_T T T0E Fushiskinn Reoed wilimw Fara TR - TN 11 i wrTNdE

4 I I

[ < Back ][ ek = ] Finish

Figure 5 Boards and Parts Selection

1-1-9. Check the Project Summary and click Finish to create an empty Vivado project.
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Creating the System Using the IP Integrator Step 2

2-1.

2-1-1.

2-1-2.

2-1-3.

Use the IP Integrator to create a new Block Design, and generate the ARM
Cortex-A9 processor based hardware system, targeting the ZedBoard.

In the Flow Navigator, click Create Block Design under IP Integrator

Flows Navigator “

B
e M — |

4 Project Manager
{E Project Settings
Q‘EL" Add Sources
1} 1P Catalog
4 P Integrator
i Create Block Design
¥ Open Block Design

Generate Block Design
Figure 6 Create IP Integrator Block Diagram

Enter system for the design name and click OK

¢.. Create Block Design lﬁ

[0] Please specify name of block design

Design name: sg;stem|

oK ] l Cancel

Figure 7 Create New Block Diagram

IP from the catalog can be added in different ways. Click on Add IP in the message at the top of

the Diagram panel, or click the Add IP icon ﬁ in the block diagram side bar, press Ctrl + 1, or
right-click anywhere in the Diagram workspace and select Add IP
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Figure 8 Add IP to Block Diagram

2-1-4. Once the IP Catalog is open, type “z” into the Search bar, find and double click on ZYNQ7
Processing System entry, or click on the entry and hit the Enter key to add it to the design.

iagram ress Edibor ¢
= Di [ Add Edit
'>[|| i, system
oy I_Q. Designer Assistance available, Fun Block Automation
1 | Search: 2| (& matches)
& (=
1

I; Mame
v=u |1 EF Clacking Wizard
PE“ {F IL& {Integrated Logic Analyzer)

||| LF MicroBlaze

icroBlaze Debug Module

ik {F MicroBlaze Debug Module (MDM)
o {F MicroBlaze MCS

5| LF 2ADC Wizard

I {F Z¥MQ7 Processing System
o) {F Z¥MQ7 Processing Systemn BFM

Figure 9 Add Zynq block to the design

2-1-5. Notice the message at the top of the Diagram window that Designer Assistance available. Click
on Run Block Automation and select /processing_system7_1
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[ Designer Assistance available. Fun Elock Automation

iF  /processing_system7_0

Figure 10 Designer Assistance message

2-1-6. Click OK when prompted to run automation

4~ Run Block Automation ﬁ

#

. .‘:] Zynq7 block automation generates external connections for FIXED_IO and DDR interfaces.
Instance: (processing_system7_0

Make Interface External: FIXED_IC, DDR
Apply Board Preset:

oK || cancel

Figure 11 Run Block Automation

Once Block Automation has been complete, notice that ports have been automatically added for the DDR
and Fixed IO, and some additional ports are now visible. A default configuration for the Zynq has been
applied which will now be modified.

processing_system7_0

~ -

DDR < ||j====="> DDR
FIXED_104p || ™ FIXED_IO

= TTCO_CLKO_IN e s "

= TTCO_CLK1_IN e "

-
—TTCO_CLK2_IN ZYNO TTCO_WAVED_OUT =

TTCO_WAVEL_OUT =
—M_AXI_GPO_ACLK
B TTCO_WAVE2_OUT =
FCLK_CLKO =
FCLK_RESETO_N =

L8 2
ZYMQ7 Processing System
Figure 12 Zynqg Block with DDR and Fixed 10 ports

2-1-7. In the block diagram, double click on the Zynq block to open the Customization window for the
Zyng processing system.

2-1-8. A block diagram of the Zynq should now be open, showing various configurable blocks of the
Processing System.

At this stage, the designer can click on various configurable blocks (highlighted in green) and
change the system configuration.
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2-2.

Figure 13 Zyng System Configuration View

Configure I/0O Peripherals block to use UART 1 only

Only the UART is required for this lab, so all other peripherals will be deselected.

2-2-1. Click on one of the peripherals (in green) in the IOP Peripherals block, or select the MIO
Configuration tab on the left to open the configuration form

2-2-2. Expand I/O peripherals if necessary, and deselect all the 1/O peripherals except UART 1.

i.e. Remove:

ENET O

UsB 0
SDO

Expand GPIO to deselect GPIO MIO
Expand Memory Interfaces to deselect Quad SPI Flash
Expand Application Processor Unit to disable Timer O.
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Page Navigator
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Figure 14 Selecting only UART 1

2-2-3. Select the PS-PL Configuration tab on the left. Expand GP Master AXI interface and deselect
M AXI GPO interface. Expand General > Enable Clock Resets and deselect the
FCLK_RESETO_N option.

2-2-4. Select the Clock Configuration tab on the left. Expand the PL Fabric Clocks and deselect the
FCLK_CLKO option and click OK.
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processing_system7_0

DDRk ||=——"> DDR

NG Eep 104s ||—— ) FIXED_IO

ZYNQ7/ Processing System

Figure 15 Updated Zynq Block

Generate Top-Level and Export to SDK Step 3

3-1.

3-1-1.

3-1-2.

Generate IP Integrator Outputs, the top-level HDL, and start SDK by
exporting the hardware.

In the sources panel, right-click on system.bd, and select Generate Output Products ... and
click Generate to generate the Implementation, Simulation and Synthesis files for the design

Right-click again on system.bd, and select Create HDL Wrapper to generate the top-level VHDL
model. Leave Let Vivado manager wrapper and auto-update, and Click OK

The system_wrapper.vhd file will be created and added to the project. Double-click on the file to
see the content in the Auxiliary pane.

T
*

Sources ot ]
M A pag B B ([FE
aH et hE

—-z7 Design Sources (1

-4 system_wrapper - STRUCTURE | system wrapper.vhd) (1)

[=t#% system_| - system (system.bd) (1)}
[=-&h system - STRUCTURE (system.vhd) (1)
“4F processing_system7_1 - system_processing_system?7_1_0 (syster_processing system7 1 0.xci

[+ Constraints (1]
=+ Simulation Seurces (1

& sim_1 (1

_.Hierarc_l_'ly. IP Sources | Libraries | Compile Order

_éh Sources | E] Design Hierarchy '
Figure 16 The HDL Wrapper file generated and added to the project

3-1-3. Notice that the VHDL file is already Set As the Top module in the design, indicated by the icon sa

You should have the block design open before you export the design to SDK. If it is closed then
open the block design by clicking on the Open Block Design under the IP Integrator sub-menu of
the Flow Navigator pane.

3-1-4. Select File > Export > Export hardware for SDK...
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3-1-5. The Export Hardware for SDK GUI will be displayed. Select the Launch SDK box, and ensure
that Export Hardware is already selected, and click OK to export to, and launch SDK. (Save the

design if prompted.)

Note: Since we do not have any hardware in Programmable Logic (PL) and hence there is no
bitstream to generate, the Include bitstream option is not available.

-

PN

Export Hardware for SDK. &J

[0] Export hardware platform for SDK.

Options
Source: %, system.bd =
Exportto: | & <Local to Project> -
Workspace: | &0 <Local to Project> -

| BExport Hardware

Include bitstream (Mote: an implemented design m...

ok || cancel

Figure 17 Exporting to SDK

SDK should now be open. If only the Welcome panel is visible, close or minimize this panel to view the
Project Explorer and Preview panel. A Hardware platform project has been created, and the
hw_platform_0 folder should exist in the Project Explorer panel. The .xml file for the Hardware platform

should be open in the previe

w pane. Double click system.xml to open it if it is not.

Basic information about the hardware configuration of the project can be found in the .xml file, along with
the Address maps for the PS systems, and driver information.

75 Project Explarer 23

= O || g systernxrml &2

Sh-30 Ah hw_platform_0 Hardware Platform Specification
a E bne_platform_l
|&] psT_init.c Design Infor mation
[6 ps7_init.h -
@ psT_init.html Target FPGA Dewvice: Tz020
7] psT_init.tcl Created With: Vivado 2013.3

@ ps7_surmmanghtml

I systern.xml

Created On: 3at Oct 26 12:57:52 2013

Address Map for processor ps7_cortexa9 0

psT_afi_ 0 O=£2008000 0xf8008££f
psT_afi_1 O=£2009000 0xf8009££f
psT_afi_2 D=£800a000 0xf800afff
psT_afi_3 O=£800b000 0xf800bELE
psT_coresight_comp_l 0x£8800000 OxfB8££££1
ps7_ddr 0 0=00100000 Ox1ff£ffEfff
ps7_ddrc_0 D=f 8006000 0xf8006ELE
psT_dew cfg 0 Omf8007000 0xf80070£f
ps7_drma_ns 0mf8004000 Oxf8004££f
psT_drma_s 0=f8003000 0=xf8003f£f
psT_globaltimer 0 0xf8f 00200 0=xfBEO002£f
psT_gpw 0 Om£23900000 Oxfa89fffff

Figure 18 SDK C/C++ development view
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Generate Memory TestApp in SDK Step 4

4-1. Generate memory test application using one of the standard projects
template.

4-1-1. In SDK, select File > New > Application Project

4-1-2. Name the project mem_test, and in the Board Support Package section, leave Create New
selected and leave the default name mem_test_bsp and click Next

o =

Mewe Project = @

Application Project ~
Create a rnanaged rmake application project, i /

Project narme:  [QEi=s

IJse default location

ChauphernbeddediabstlabIiabl sdkASDENEDE_Exporthmerr Browse,.,

default
Target Hardware
Hardwrare Platfarm Ihw_platfarr‘n_[l v‘
Processar Ips?_cu:urtexag_ﬂ v‘
Target Software
0% Platform Istandalune v‘
Language @C I C++

Board Support Package @) Create Mew  rmermn_test_hsp

IJse existing

':?:' < Back Mext = ‘ [ Einish ] I Cancel

Figure 19 Create new SDK application project
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4-1-3. Select Memory Tests from the Available Templates window, and click Finish.

Mew Project
Templates
application project.

Suailable Templates:

Create one of the available templates to generate a fully-functioning

= |5l

Dhrystone
Empty Spplication
Hello ¥orld

Memary Tests
Peripheral Tests
Zyng FSBL

-

This application tests Memory Regions
present in the hardware,

Cancel

||

Mext = Einizh

Figure 20 Creating Memory Tests C Project

The mem_test project and the board support project mem_test_bps will be created and visible
in the Project Explorer window of SDK, and the two projects will be automatically built. You can
monitor the progress in the Console panel.

4-1-4.

Expand folders in the Project Explorer view, and observe that there are three projects -

hw_platform_0, mem_test_bsp, and mem_test. The mem_test project is the application that we
will use to verify the functionality of the design. The hw_platform includes the ps7_init function
which initializes the PS as part of the first stage bootloader, and mem_test_bsp is the board

support package.

L[ Project Explorer i3

=B
=1 A
4 E hu_platform_0l
|&] ps¥_init.c
5l psT_inith
@ psT_inithtml
= psT_inittcl
| systemaxml
4 bc merm_test
> ;ff Binaries
» [nit Includes
» (= Debug
4 (= src
i
>
(@
s
> g platform,c
) platfarm.h
E lscript.ld
4 @ mern_test_bsp
- 1 BSP Dacurnentation
s (= psT_cortexad_l
| libgenlog

rnernory_config_g.c
rnernony_config.h
rmernanytest.c
platfarm_config.h

=] libgen.options
Makefile
I system.umss

Figure 21 Projects View
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4-1-5. Open the memorytest.c file in the mem_test project (under src), and examine the contents. This
file calls the functions to test the memory.

Test in Hardware Step 5

5-1. Connect and power up the board. Establish the serial communication using
SDK’s Terminal tab.

5-1-1. Connect one micro-usb cable between the PC and the JTAG port of the board, another micro-usb
cable between the PC and the UART port of the board, and power up the ZedBoard.

5-1-2. Selectthe & Terminal {5 |f it is not visible then select Window > Show view > Terminal.

5-1-3. Clickon *' and select appropriate COM port (depends on your computer), and configure it with
the parameters as shown.

View Settings:

View Title: Terminal 1

Connection Type:

Parity: None - |
Flow Control: |None - |

Timeout (sec): 5

[ OK l l Cancel I

Figure 22 SDK Terminal Settings

5-2.  Run the mem_test application and verify the functionality.

5-2-1. In SDK, select the mem_test project in Project Explorer, right-click and select Run As > Launch
on Hardware to download the application, execute ps7_init, and execute mem_test.elf.
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ps¥_inittel
L systernaaml

4 '[D': rmerr_test
[
&
+ [l Includes

Binaries

+ = Debug
4 = st

o Lg] mermory_config_g.c
. [ memary_config.h

Showy in Rermote Systerms view

Corvert Tau,
Run A3
Debug &s
Profile s
Tearn

Cornpare With

+ g memarnetest.c

. ] platform_config.h
. g platform.c

3 Gin:s 1 Launch on Hardware (GOE)
b | [&] 2Llocal CAC++ Application
4 i: 3 Remote &RM Linuwx &pplication

Run Configurations...

Restore frorm Local History...

‘%“ Run C/C++ Code Snalysis

Figure 23 Launch Application

5-2-2. You should see the following output on the Terminal console.

——Starting Memory Test

NOTE: This application
be generated

Testing memory region:

Memory Controller:

Base Rddress:

Size:

32-bit test:

16-bit test:

8-bit test:

Testing memory region:

Memory Controller:

Base Rddress:

Size:

32-bit test:

16-bit test:

8-bit test:

Application—-
runs with D-Cache disabled.Zs a result,

psT _ddr 0
psT_ddr
0x00100000
0x1££f00000 bytes
PASSED!

PASSED!

PASSED!

ps7 ram 1
ps7_ram
Oxf££££0000
0x0000£fe00 bytes
PASSED!

PLSSED!

PLSSED!

——Memory Test Epplication Complete—-—
Figure 24 SDK Terminal Output

5-2-3. Close SDK and Vivado by selecting File > Exit in each program.

Conclusion

Vivado and the IP Integrator allow base embedded processor systems and applications to be generated
very quickly. After the system has been defined, the hardware can be exported and SDK can be invoked
from Vivado. Software development is done in SDK which provides several application templates
including memory tests. You verified the operation of the hardware by downloading a test application,
executing on the processor, and observing the output in the serial terminal window.
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