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Without syntax,
SPSS would be
just another

beautiful GUI
without a soul




What is scripting and automation?

1. Ascriptis a set of predefined instructions or commands that are
executed by the software to perform specific actions.

2. These commands can be saved in a syntax file and executed to
perform data manipulation, analysis, and graphical representation
tasks automatically.




What is scripting and automation?

It allows users to:

a) Apply the same set of commands to multiple data files.
b) Automate complex data transformations and analyses.
c) Schedule tasks to run at specific times.

d) Reduce the potential for human error in repeated steps.

e) Document the analysis process for replication or review.
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Scripting and motivation -
BITCOIN

a) the Bitcoin exchange rate in 155 %@ﬁﬁ%
2022 and

b) neural network model that
predicts the values of this
exchange rate very well

nax(Qup)
SRR RS RS e

FHLLE LR




Neural network si simple.

1 input neuron, 8 hidden
neurons, 1 hidden bias
and 1 "max" output
neuron. The inputs are
connected to all hidden
neurons. All hidden
neurons and "hidden
bias" are connected to

the output neuron "max".

input bias

Neural Network Graph Representation

hidden neuron 1

hidden neuron 2

‘ hidden neuron 6

sd.en neuron 7
\en B .

hidden bias
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{
for(i=8; i<nContTargets; i++)
{ delta = (maximum-minimum)/(NN,max_input[i]-NN,min_input[i]);

for(j=0; j<steps; j++)

input[i+j*nContTargets] = minimum - delta*NN,min_input[i]+ delta*input[i+j*nContTargets];

¥
}

void NN,UnscaleTargets(double* output, double minimum, double maximum, int size)
{
for(i=0; i<size; i++)
{
delta = (maximum-minimum)/(NN,max_target[i]-NN,min_target[i]);
output[i] = (output[i] - minimum + delta*NN,min_target[i])/delta;
}
}

void NN,ComputeFeedForwardSignals(double* MAT_INOUT,double* V_IN,double* V_OUT, double* V_BIAS,int sizel,int size2,int layer)
{
for(row=0;row < size2; row++)
{
V_OUT[row]=0.80;
for(col=e;col<sizel;col++)V_OUT[row]+=(*(MAT_INOUT+(row*sizel)+col)*V_IN[col]);
V_OUT[row]+=V_BIAS[row];
if(layer==0) V_OUT[row] = tanh(V_OUT[row]);

}

void NN,RunNeuralNet TS Reg ()

{
NN, ComputeFeedForwardSignals((double*)NN, input_hidden_weights,NN, input,NN,hidden,NN,hidden_bias,1, 2,0);
NN, ComputeFeedForwardSignals((double*)NN,hidden output wts,NN,hidden,NN,output,NN,output bias,2, 1,1);



Scripting and motivation -
BITCOIN

a) Forecasting the price of Bitcoin, like any
other cryptocurrency or financial asset, is
very complex and involves a number of
challenges and uncertainties, external
influences and unpredictable moments.

b) Inretrospect, | could model the
development of the course, but the
prediction is actually poorly modeled.
Well, because | don't have the other input
information.




Is SPSS a programming
language?

1. SPSS Syntax is a command language that is
unigue to SPSS Statistics.

4|||g

2. Effectively, it’s the SPSS operating system.

3. The language was developed in the 1960’s
and so pre-dates Windows/Mac versions
of SPSS by some margin




Why use syntax?

Automate your entire analytical process

Complete repetitive tasks more quickly
Change/fix something to update all your work

Share your data preparation and analysis with others

A S

A huge range of tasks in IBM SPSS Statistics can be completed using
SPSS Syntax

6. SPSS Syntax is a command language that is much easier to understand
than many analytical programming languages such as Python or R



What is Syntax?

1. SPSS syntax is a programming language that is unique to SPSS. It
allows you to write commands that run SPSS procedures, rather than
using the graphical user interface.

2. Syntax allows users to perform tasks that would be too tedious or
difficult to do using the drop-down menus. This is the case when you
are re-running the same analysis many times.

3. Note that the two methods of interacting with SPSS — drop-down
menus and syntax — are not mutually exclusive. You can use both
methods if you wish, or switch from one method to the other
depending on the actions you want to perform.




Basic Syntax Rules

FORMATTING
Statements in SPSS end with a period.

SPSS syntax is not case-sensitive. You can use all lower case, all upper
case, or a mixture of both when writing syntax.

COMMENTS

A comment is a line of text in a program that is not read by the
computer as a command. In SPSS syntax, placing an asterisk (*) or a
forward-slash followed by an asterisk (/*) at the start of a line



SPSS Syntax Color Coding

By default, SPSS uses color and bolding to indicate the roles of the
words in the syntax.

Dark blue/purpleProcedure names; execution statements
Green Statements associated with the given procedure
Dark red/orange Option keywords

Comments

Black Variable names; other text



When should | use syntax?

The biggest benefits of using SPSS syntax are reproducibility and
communication.

REPRODUCIBILITY

1. Itis far easier to "retrace your steps" with syntax if you need to
recall the modifications you've made to your dataset. It's also far
easier to find and correct mistakes in your analysis if you have the
syntax, as opposed to if you had used the menus.

2. Syntax can easily be modified and re-used on future projects,
saving you time and effort in the long run.



When should | use syntax? -
Communication

a) Itis much easier to communicate to others what actions you performed
in SPSS by showing someone your syntax than it is to describe how you
used the menus.

b) The content of the menus and dialog windows has changed over time
with each version of SPSS, while the syntax has remained relatively
unchanged.

c) In general, if you are working on a major project (like a thesis,
dissertation, or research for publication), or if you are collaborating with
others on data analysis, we strongly recommend using SPSS syntax.



DESCRIPTIVES VARIABLES=Points v100_m Long_jump Shot_put High_jump v400_m v110_m_hurdles
Discus_Throw Pole_vault Javelin v1500_m
/ISTATISTICS=MEAN SUM STDDEV RANGE MIN MAX SEMEAN.

NPAR TESTS
Sam p I € S PSS /K-S(NORMAL)=Points v100_m Long_jump Shot_put High_jump v400_m v110_m_hurdles Discus_Throw
1 I Pole_vault Javelin v1500_m
SCr pt fOr baSIC /MISSING ANALYSIS
calculations /KS_SIM CIN(99) SAMPLES(10000).

STATS CORRELATIONS VARIABLES=Points v100_m Long_jump Shot_put High_jump v400_m v110_m_hurdles
Discus_Throw Pole_vault Javelin v1500_m

/OPTIONS CONFLEVEL=95 METHOD=FISHER

MISSING EXCLUDE=YES PAIRWISE=YES.

T-TEST GROUPS=Finished(1 2)
/MISSING=ANALYSIS
NARIABLES=v100_m Long_jump

/CRITERIA=CI(.95)]




s Syntax Editor
Transform  Analyze Graphs Utilties Run Tools Extensions Window Help
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SPSS Support
HELP = e
2 ) GET DATA :'TYPE=XLSX SPSS Forums
3 /FILE="d:\magdeburg\Decathlon xlsx’ IBM SPSS Statistics Community
4 /ISHEET=name ‘Decathlon’ =
5 /CELLRANGE=full Documentation in PDF Format
b [READNAMES=0n
Command Syntax Reference
7 ) /ASSUMEDSTRWIDTH=32767. « d >
a EXECUTE. About. .
9 DATASET NAME DataSetExcel WINDOW= . .
10 Diagnostic Tool...

Give Feedback
Report an |ssue

Help > Command Syntax Reference. (This will open a PDF
containing the reference manual.)
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Print
in the Output Window

O O O O

ick Edit > Options.

ick the Viewer tab.

ick OK when finished.

neck the box for Display commands in log.

@ Untitled1 [DataSet( @ Options

File Edit View
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OPENING THE SYNTAX EDITOR

To open a new Syntax Editor window, click File > New > Syntax.

' *Syntax3 - IBM SPSS Statistics Syntax Editor

File Edit View

GET DATA
EXECUTE.
DATASET NAME

Transform  Analyze Graphs Utilities Run Tools Extensions Window

HeMe~ETH PO &

[
iy

y

() GET DATA /TYPE=XLSX
/FILE=d:\magdeburg\Decathlon xlsx
/SHEET=name 'Decathlon’
/CELLRANGE=Hull
/READNAMES=0n
(1 /ASSUMEDSTRWIDTH=32767.

EXECUTE.

DATASET NAME DataSetExcel WINDOW=/

»

= 0 00 ~ 3 M &= WK =

o




Files in SPSS

What are the 3 types of files in SPSS?

There are three types of SPSS files that we will use during this
class:

1. data files, which end in . sav;
2. syntax files, which end in . sps; and

3. output files, which end in . spv.



Importing data

How the data should look for import?

1. Inthe first row of column arelabels, o & F 6 = H
Points 100 m Long jump  Shot put High jump
2. from second row you have a data 5456 11,29 14,3
746 11,53
3056 11,05 7,05 12,84 1
5737 10,94 7,43 13,77 1
1631 11,05 6,86
2480 11,05 7,12 14,98
3936 10,79 7,04 13,32 1
6182 10,8 7,38 16,17
1668 10,77 14,45
8021 10,55 7,34 14,44 1
8067 11,14 6,99 14,91 1
8225 10,69 7,48 14,8 2
7404 11,36 6,68 14,92 1
8820 10,44 7,96 15,23 2
6543 11,28 7,2 13,04 1



Importing Data from an Excel File

GET DATA /TYPE:)(LS)( Note: If you are importing an *.xlIsx file, use
JTYPE=XLSX. If you are reading an *.xIs file, use
/FILE='C:\path\to\file.xlsx' JTYPE=XLS.
/SHEET=name 'Name-of-Sheet'
_ The most important lines in this code are /FILE="
/CELLRANGE=full and /SHEETomame
/READNAMES=0n
/ASSUMEDSTRWIDTH=32767. GET DATA /TYPE=XLSX
/FILE="C:\path'to\file_xlsx’
EXECUTE. /SHEET=name 'Name-of-Sheet’
/CELLRANGE=ull

DATASET NAME DataSetExcel WINDOW=FRONT. /READNAMES=on
[ASSUMEDSTRWIDTH=32767.

EXECUTE.




Importing Data from an Text
File(txt, csv)

GET DATA /TYPE=XLSX Note: If you are importing an *.xlIsx file, use
JTYPE=XLSX. If you are reading an *.xIs file, use
/FILE='C:\path\to\file.xlIsx' JTYPE=XLS.
/SHEET=name 'Name-of-Sheet'
_ The most important lines in this code are /FILE="
/CELLRANGE=full and /SHEETomame
/READNAMES=0n
JASSUMEDSTRWIDTH=32767. GET DATA /TYPE=XLSX
[FILE="C:\path\to‘file xlsx’
EXECUTE. /SHEET=name 'Name-of-Sheet’
[CELLRANGE=full

DATASET NAME DataSetExcel WINDOW=FRONT. /READNAMES=on
JASSUMEDSTRWIDTH=32767.

EXECUTE.
DATASET NAME DataSetExcel WINDOW="/ !



Importing - my experience ©

1. Don't leave data import to
automatic recognition.

2. Of all statics, the most important
thing is the correct data preparation,
do it carefully (in SPSS, in Excel, ...)
do a standard import.

3. Clear the data...




Opening the syntax editor

To open a new Syntax Editor window, click File > New > Syntax.

' *Syntax3 - IBM SPSS Statistics Syntax Editor
File Edit View Data Transform Analyze Graphs Utilities Run Tools Extensions Window

HeL e~ % A PO & X}

GET DATA () GET DATA /TYPE=XLSX
EXECUTE. /FILE=d:-\magdeburg\Decathlon xlsx
DATASET NAME /SHEET=name "Decathlon’
/CELLRANGE=full
/READNAMES=0n
0 /ASSUMEDSTRWIDTH=32767.

EXECUTE.

DATASET NAME DataSetExcel WINDOW=F~

R
|
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@ Descriptives

Vanable(s):
g & Team & Points
Syntax editor & Finished & vI00_m
& Long_jump
You can paste the syntax code of - iﬁf‘“;—."’”‘
every analysis you perform into a P oo
syntax editor window by clicking on & v110_m_hurdles

& Discus Throw v

. Save standardized v, as vanables
dialogue box. o i
OK\set Cancel || Help

Syntax code will
be pasted.




Syntax editor

The left panel of the Syntax Editor window shows an outline of the
commands in your syntax, and can be used to navigate within your
code. You can jump to a specific part of your code by clicking on the
command in the left panel.

(L *Syntax1 - IBM SPSS Statistics Syntax Editor

File Edit View Data Transform Analyze Graphs Utilities Run Tools Extensions Window Help
— = | B \ = [~
- AP0 & = HeHITO09

L 1
]2 DATASET ACTIVATE DataSet1.
1 PI DESCRIPTIVES VARIABLES=Points v100_m Long_jump Shot_put High_jump v400_m v110_m_hurdles

ATASET ACTIVATE
DESCRIPTIVES

WORRELATI ONS

Discus_Throw Pole_vault Javelin v1500_m
ISTATISTICS=MEAN SUM STDDEV MIN MAX.

Discus_Throw Pole_vault Javelin v1500_m
/OPTIONS CONFLEVEL=95 METHOD=FISHER

4
&
6
7 [J STATS CORRELATIONS VARIABLES=Points v100_m Long_jump Shot_put High_jump v400_m v110_m_hurdles
8
g
10 0O /MISSING EXCLUDE=YES PAIRWISE=YES.




Syntax editor

Syntax can be saved as an *.sps file.

lf_:ﬁ *Syntax1 - IBM SPSS Statistics Syntax Editor
File Edit View Data Transform Analyze Graphs Utilities Run Tools Extensions Window Help

New :EH’.%?;.*/*&

Open
Import Data > “TIVATE DataSet1.
General Open ES VARIABLES=Points v100_m Long_jump Shot_put High_jump v400_m v110_m
) row Pole vault Javelin v1500 m
&) Open Restore Point... 3=MEAN SUM STDDEV MIN MAX.
(30 Close Ctri+F4

Cii4S RELATIONS VARIABLES=Points v100_m Long_jump Shot_put High_jump v400 _r
,H'— row Pole_vault Javelin v1500_m
Save As... JNFLEVEL=95 METHOD=FISHER

- CLUDE=YES PAIRWISE=YES.

ore Point. ..

File Enabled for Auto-Recovery

Display Data File Information >
@ Stop Processor Ctri+Perioc




How to execute

Clicking Run > All will execute the procedure

ax Editor

nsform  Analyze  Graphs Ml Run Tools Extensions™ Window Help
~ ®= M IRl XV,

1
2 DATASET ACTIVATE DataSet1. = To End
3 PI DESCRIPTIVES VARIABLES=P¢  gte0 Through »  High_jump v400_m v110_m_hurdles

4 Discus_Throw Pole_vault Javel

5 /STATISTICS=MEAN SUM STD @ Continue otri+F3

b Active DataSet >

7 1) STATS CORRELATIONS VARIAC .« ciiew + ivv_vir murng_gueep Shot_put High_jump v400_m v110_m_hurdles
g Discus_Throw Pole_vault Javelin v1500_m

9 /OPTIONS CONFLEVEL=95 METHOD=FISHER

10 O /MISSING EXCLUDE=YES PAIRWISE=YES.

. ]



Making sense
of SPSS syntax




The Dataset Activate command

By default, when SPSS Statistics opens a new data file it labels it as
‘DataSetl’. When it opens a second data file, it labels it as

‘DataSet2’ and continues add a sequential number to each new

data f||e that iS Opened Transform  Analyze Graphs Utilities Run Tools Extensions Window Help

e XZ AP0 & =s He

DATASET ACTIVATE DataSet1.
BRSLRIPTIVES VARIAE POints v100_m Long_jump Shot_put High_jump w40
Discus_Throw Pole_vault Javelin v1500_m
ISTATISTICS=MEAN SUM STDDEV MIN MAX.

|

R,

l HIH

LN =

) STATS CORRELATIONS VARIABLES=Points vi00_m Long_jump Shot_put High_
Discus_Throw Pole_vault Javelin v1500_m
/OPTIONS CONFLEVEL=95 METHOD=FISHER
0 O /MISSING EXCLUDE=YES PAIRWISE=YES.

= 0 00 ~ OO M &




11

/'—_——-_-__———:-3

\ FREQUENCIES VARIABLES=v100_m Long_jump Shot_put
Cj /ORDER=ANALYSIS.

14) N\ 2 /

1. As with all SPSS syntax procedures it starts with a single Command:
FREQUENCIES

2. This is followed by an optional Keyword: VARIABLES

3. It then specifies 3 variables: v100m, Long_jump, Shot_put

4. This is followed by a slash with a Subcommand and another Keyword:

/ORDER=ANALYSIS

5. Finally the procedure is completed with a single period character:



A few things to note
SPSS Syntax is remarkably unfussy about how it’s typed:

a) It’s generally not case sensitive

b) You can use as many lines as you want to specify a single
command.

c) It normally doesn’t require correct indentation to run.



A few things to note

However there are some basic rules:

a) Each new command (e.g. Frequencies) must start on a new
line.

b) Each procedure must end with a period as a ‘command
terminator’.

c) Most subcommands are separated by slashes (/). The slash
before the first subcommand on a command is usually

optiona




Getting help with syntax

Notice the useful autocomplete function works when manually

typing syntax. 14
115 3 frequel
1 16 FREQUENCIES o
FUZZY
GATHERMD
GENLIN
GENLINMIXED
GENLOG
GET
GET CAPTURE
GET DATA
GET SAS
GET STATA "




Getting help with syntax

For instance, if you add a forward slash after a command, a list

of subcommands appears.

12 7 FREQUENCIES VARIABLES=v100_m Long_jump Shot_put

13 P /.

14 BARCHART

15 FORMAT

16 GROUPED
HISTOGRAM
MISSING
NTILES
ORDER
PERCENTILES
PIECHART
STATISTICS




Getting help with syntax

A really useful feature is the ability to
quickly look-up the syntax diagram for
a procedure just by highlighting the
command word and clicking the
Syntax Help button on the toolbar of
an open Syntax window.

v,
b §
Ll
=3
\ &
@
)

DATASET ACTIVATE DataSet1.
) DESCRIPTIVES VARIABLES=Points v100_m Long_|

Discus_Throw Pole_vault Javelin v1500_m
L1 /STATISTICS=MEAN SUM STDDEV MIN MAX.

'/ STATS CORRELATIONS VARIABLES=Points v100_
Discus_Throw Pole_vault Javelin v1500_m
/OPTIONS CONFLEVEL=95 METHOD=FISHER
10 0O /MISSING EXCLUDE=YES PAIRWISE=YES.
"
12 '/ FREQUENCIES VARIABLES=v100_m Long_jump Sh

13 P /ORDER=ANALYSIS]

14
15

D~ 0O m & Wk =

({n]




Examples

Remember that you can always create syntax simply by clicking
the Paste button in an SPSS dialog

e However, in the next few examples we will delve into aspects
of syntax that illustrate how different procedures work or reveal
functions that aren’t obvious to the casual user

e To begin with let’s look at opening data in IBM SPSS Statistics




Opening data files

The GET FILE command is used to import an SPSS data file (*.sav).

e The GET DATA command however is used to import non-native file
formats such as Excel workbooks or comma separated (CSV) files.

e Note the use of the /TYPE subcommand that specifies the file type
to be imported

GET DATA
/TYPE=XLSX
/FILE='D:\Magdeburg\Decathlon.xlsx '



Filtering data with the Select

Cases dialog

Using the paste button in the Select Cases

—_

ﬂ'ﬁ Select Cases

dialog tends to generate surprisingly complex
syntax

USE ALL.

COMPUTE filter_$=(Finished = 0).

VARIABLE LABELS filter_$ ‘Finished = 1 (FILTER) |
VALUE LABELS filter_$ 0 'Not Selected’ 1 'Selected'.
FORMATS filter_$ (f1.0).

FILTER BY filter_$.

EXECUTE.

! !
e il N

& Team

@) Finished

& Points

& v100_m

& Long_jump
& Shot_put

& High_jump
& va00_m

& v110_m_hurdles
& Discus_Throw
& Pole_vault

& Javelin

& v1500_m

lj FREQUENCIES VARIABLES=Long_jump
1 /ORDER=ANALYSIS.

Select

O All cases

@ If condition is satisfied
If Finished = 1

O Random sample of cases
Sample

O Based on time or case range
Range

O Use filter variable:
-

Output
@® Filter out unselected cases

O Copy selected cases to a new

O Delete unselected cases

Current Status: Do not filter cases

[ Paste H Reset HCancel” Helo



Useful Syntax Window Functions

e Breakpoints: Breakpoints are used to stop command syntax execution at
positions so you can check the results at each stage before moving on.

e Bookmarks: Creating bookmarks allow you to more easily navigate large
command syntax files.

e Step Through: You can step through command syntax one command at
a time.

e Split view: From the main menu click Window > Split View. This splits
the syntax editor window into two panes so that you can check one part
of the syntax file without losing focus on another.



Break point —

Bookmark

Line

Numbers

Useful Syntax Window functions

e § |
2 pen the data file
3 GET FILE='C\Temp\Employee data with age.sav'
4 DATASET NAME $DataSet WINDOW=
> [
B - "l FREQUENCIES VARIABLES=gender jobcat minonty
7 o] IORDER=AMNALYSIS.
8
2| L ] T DESCRIPTIVES VARIAELES=age educ salary salbeqin —
10 O] ISTATISTICS=MEAN STDDEV MIN MAX
11E »
12 ® |CROSSTABS
13 TABLES=gender minority EY jobcat
14 FORMAT=AVALLE TABLES
45 CELLS=01 IMT B
— —
37
38
39 DIOUTPUT MODIFY
40 ISELECT ALL EXCEFT [TABLES CHARTS)
41 0] /DELETEOBJECT DELETE =
42 -
43 Ul OUTPUT MODIFY
44 ISELECT TAELES
45 IF SUETYPES=["Frequencies"]
46 TABLECELLS SELECT=["Total"]
47 SELECTDIMENSION= Error Pane
43 STYLE= APPLYTO=
43
50 I
£ A4 e .
Line Command Information wln
1 GETFILE The document is already in use by another user or process. If ake changes to the document they may overwrite changes
made by othars oryour changes may be overwrittan by others,
3 Dataset Name The active dataset will replace the existing dataset named §Dataset

Split window




Without syntax,
SPSS would be
just another

beautiful GUI
without a soul
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25 examples ©

Add_99AtEndOfAllVariableNames.sps
AreAllWordsPresent.sps
BarChartsForSchoolTypesBySexWherePercentages
OfEachSexAddUpTo100Percent.sps
CalculateAge.sps
CalculateChi-squareSigGiven_q_and_df.sps
CalculateMcNemarChi-SquareTest.sps
CombineStringAndNumber.sps

CountOutliers.sps

decathlon factoral.sps

10 ExampleOfSurfacePlot.sps

11. ExampleWorkingWithMatrices.sps
12. ExcludeOutliersDefinedAsMeanPlusMinus2SD.sps

13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.

FAwithSpearmanCorrelation.sps
FindCubicRoot.sps

FindDuplicates.sps
FindInverseOfAMatrix.sps
FlagCasesWhereSalarylsInTop95percentile.sps
HowToSpeedUpIGRAPH.sps
ChangeAllStringsToLowerCase.sps
LogisticRegressionByMacro.sps
NewVarEqualsMeanOfAnotherVar.sps
ParseStringIntoManyVariables.sps
PopulationPyramid.sps
PrintMeanPlusMinusStddevIinTable.sps
ReverseDigitsOfAninteger.sps



