
Cvičení 3 – práce v prostředí Layout 

Lišta Layout 

V levém dolním rohu mapového okna se nachází nástroje na ovládání mapového okna. První 

dva nástroje slouží k přepínání mezi Data View – náhledem na obsah vrstev a Layout View – 

rozvržením pro tvorbu map a tisk. 

 

 

 

Lišta nástrojů Layout je aktivní pouze v Layout View. Nástroje vesměs slouží k ovládání 

náhledu na stránku, postupně zleva se jedná o přibližování a oddalování náhledu, posun, 

krokové přiblížení a oddálení, zobrazení pohledu 1:1, krok zpět, krok vpřed, nastavení 

velikosti náhledu pomocí procentuálního vyjádření. Zbývající čtyři nástroje mají následující 

funkce: vypínání zobrazování obsahu mapového pole, aktivace rámce mapového okna, 

změna velikosti stránky, nastavení možnosti více stránek v jednom náhledu. 

Vizualizace vrstev 

Formulář Layer Properties se zobrazí kliknutím pravé myši na vrstvu v Table Of Contents a 

výběrem Properties... Zvolte záložku Symbology. 

V okně Show se volí, zda se použije nastavení symboliky vrstvy stejné pro všechny prvky 

nebo se bude lišit pro různé hodnoty zvolených atributů. 

Features – jednotná symbolika pro celou vrstvu 

Categories – nastavení symboliky pro konkrétní hodnoty jednoho atributu nebo více atributů 

Quantities – nastavení symboliky pro stanové škály hodnot odstíny barev (graduated colors), 

různou velikostí symbolů (graduated symbols) nebo proporcionální velikostí symbolů 

(propotional symbols). 

Charts – tvorba kartodiagramů 

Multiple Attributes – nastavení symboliky podle kombinací unikátních hodnot až tři atributů 



V okně Fields se vybírají hodnoty atributů (sloupce v tabulce), na jejich základě se bude 

symbolika nastavovat. Ve zbývajícím okně se po výběru konkrétního atributu ve Fields 

načtou unikátní hodnoty nebo vytvoří škály – záleží na zvolené metodě symboliky. Po kliknutí 

pravou myší na toto okno se mohou zobrazit další možnosti úprav hodnot. Vyzkoušejte také 

nastavení volby hodnot škál u metody Quantities v okně Classification. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



Formulář Symbol Selector 

Zobrazí se následně: v záložce Symbology 

po kliknutí na objekt symbolu nebo na 

symboly v tabulkách hodnot a škál. Nebo 

dvojitým poklikáním na barevný symbol u 

vrstvy v Table Of Contents. 

Hlavní okno slouží k výběru symbolu. 

V pravé části pak mění barva jeho výplně 

(Fill Color), barva a tloušťka ohraničení 

(Outline Color, Outline Width). Tlačítko 

Edit Symbol zobrazí formulář pro další 

možnosti nastavení symbolu od 

čerchování čar až po nastavení symbolu na 

obrázek z externího souboru. 

Vkládání objektů do mapy 

Kompoziční prvky mapy se vloží do Layout pomocí 

záložky Insert. 

Tiráž a název jsou textová pole Insert -> Text. Dvojitým 

poklikáním na vložené textové pole se zobrazí formulář 

pro editaci textu Properties. Změnu formátování 

provedete po kliknutí na tlačítko Change Symbol. 

Měřítko a směrovka se vloží pomocí formuláře Scale Bar 

Selector a North Arrow Selector, po výběru stylu 

poklikáním a tlačítka OK. 

Legenda 

Legenda se vloží opět pomocí Insert -> 

Legend. Vložení probíhá pomocí průvodce o 

několika krocích: 

1) Výběr vrstev, jejichž znak bude 

obsažen v legendě 

2) Vložení názvu legendy a jeho 

formátování 

3) Formátování rámu legendy 

4) Úprava jednotlivých znaků 

vkládaných do legendy, které 

reprezentují jednotlivé vrstvy 

5) Úprava řádkování legendy 



Doporučuji průvodce v rychlosti odklikat a finální 

úpravy provádět editací již vložené legendy – 

dvojité poklikání na legendu a otevření Legend 

Properties. Důležitá je záložka Items, kde se pod 

tlačítkem Style skrývá formulář výběru stylu – 

Legent Item Selector. Je vhodné si vybrat styl, 

který neobsahuje příliš zbytečných popisů a 

podnázvů, většinou stačí popsat v názvu obsah 

legendy a popis jednotlivých znaků. 

 

 

Podrobný návod pro práci v prostředí Layout: 

Layout zobrazíte po kliknutí na ikonu Layout View, která je umístěna v levém rohu pod 

Zobrazovacím polem (viz obrázek 4). Nebo v Hlavním menu View → Layout View . Nyní se 

vám aktivovalo Layout menu v horní části okna, a můžete s ním tak pracovat. Pro uchycení a 

přesun mapy se používá ikona  Pan umístěná na nástrojové liště. 

Budete-li se potřebovat vrátit do výchozího zobrazení neboli zobrazení dat, kde můžete 

přidávat a upravovat vrstvy, máte opět dvě možnosti. Kliknutím na ikonu Data View, která 

je umístěna jako první v levém rohu pod Zobrazovacím polem (viz obrázek 4). Nebo Hlavní 

menu → View → Data View.  

Je nutné si uvědomit, jak velká bude výsledná mapa a nastavit si podle toho velikost a 

orientaci formátu (papíru), na kterém budete pracovat, popřípadě tisknout.  V Hlavním menu 

zvolíte File → Page and Print Setup (stránka a nastavení tisku). Zde si můžete nastavit 

tiskárnu, velikost a orientaci listu (Portrait = na výšku, Landscape = na šířku). Můžete si zde 

také nastavit vlastní velikost mapy → odškrtněte políčko Use Printer Paper Settings 

(použít nastavení tiskárny, papíru) a nastavte si velikost podle potřeby.  

 



 

Projekt můžete různě přemísťovat podle potřeby pomocí ikonky , umístěné na 

nástrojové liště. 

Různé přiblížení papíru si lze nastavit v kolonce , která je umístěná v Layout menu.  

Přestože jste správně nastavili velikost, přiblížení mapy a posunuli mapu do požadovaných 

míst, zobrazuje se vám rám, který je třeba přizpůsobit okrajům papíru -  roztáhnutím. 

V případě, že budete potřebovat vzít poslední krok zpátky, slouží k tomu tlačítko  Undo, 

umístěné ve Standardním menu. Tlačítko  Redo, umístěné hned vedle, má opačnou 

funkci.  

 

Přidání základních kompozičních prvků krok za krokem 

Název 

Název mapy vložíte následovně: V Hlavním menu kliknete na Insert (vložit) → Title 

(název). Zobrazí se vám tabulka Insert Title (viz obrázek 14), zde napíšete název mapy. 

Kliknete-li na název mapy dvakrát, objeví se tabulka Properties (vlastnosti) (viz obrázek 

14), kde můžete pomocí Change Symbol měnit velikost, typ nebo barvu písma.  



 
 

Měřítko 

Měřítko vložíte pomocí Hlavní menu →  Insert (vložit) → Scale Bar (měřítko). Vyberte 

typ a umístěte ho do mapy. Kliknutím na tlačítko Properties (vlastnosti) můžete nastavit 

charakteristiky měřítka. Můžete je také nastavit dodatečně, když po umístění měřítka na něj 

kliknete pravým tlačítkem myši a zvolíte možnost Properties. Nebo dvojitým pokliknutím 

na vložené měřítko. 

Na kartě Scale and Units (Stupnice a jednotky) (viz obrázek nížre) nastavíte počet 

hlavních a vedlejších dílků v měřítku. V políčku When Resizing (při změně velikosti) 

zvolíte, jak se má měřítko měnit při změně měřítka mapy. V poli Division Units (rozdělení 

jednotek) nastavíte jednotky měřítka (např. kilometry) a poté v poli Label napíšete, jak 

budou vepsány jednotky měřítka (např. km). V poli Label Position nastavíte, kde budou 

jednotky umístěny (zde vždy volte after labels). Aby se vám měřítko zobrazovalo od nuly, 

nesmí být před řádkem Show one division before zero zobrazena „fajfka“. Na další 

kartě Numbers and Marks (čísla a znaky) nastavujete, které čísla se na měřítku mají 

zobrazit (Frequency), a která rozdělení (Marks) mají být vykreslena.   

 



 

   

Měřítko textového či číselného charakteru (např. 1 : 10 000) vložíte obdobně jako grafické 

měřítko: Hlavní menu → Insert (vložit) → Scale Text (textové měřítko). V okně pak 

vyberete typ měřítka. Když kliknete na tlačítko Properties (vlastnosti), můžete v dalším 

okně nastavit charakteristiky tohoto měřítka. Výběr a nastavení vždy potvrďte kliknutím na 

OK.  

 

Legenda 

Legendu vložíte opět podobně jako u předešlých prvků: Hlavní menu → Insert (vložit)→ 

Legend (legenda). Otevře se okno Legend Wizard (průvodce legendou) (viz obrázek 

16). V levé části okna jsou vypsány všechny vrstvy, které máte v mapě. V pravé části, jsou 

vypsány vrstvy, které se budou zobrazovat v legendě. Položky se v legendě zobrazují tak, jak 

je máte nadefinované v Obsahu (Table Of Contents). Pokud chcete některou část legendy 

odstranit, kliknete na ni, aby se vybrala, a pak kliknete na šipky směřující doleva. Šipky 

nahoru a dolů vpravo umožňují nastavit pořadí vrstev, jak se vykreslí v legendě. Pokud máte 

vše nastaveno, kliknete na Next (další) a dostanete se do dalšího okna. 

 



 

 

 

V dalším okně (viz obrázek 17) se nastaví název legendy a parametry (velikost, barva, písmo) 

textu v legendě. Česká kartografie zakazuje označovat legendu nápisem „legenda“. Proto 

v tomto okně vymažte původní nastavení Legend.  Opět potvrdíte kliknutím na tlačítko Next 

(další).  Dostanete se do dalšího okna (viz obrázek 18), kde nastavíte orámování, barvu 

pozadí a stínování legendy. 

 

           

                        

 

V dalším okně (viz obrázek níže vlevo) můžete změnit velikost a tvar symbolu u jednotlivých 

liniových a polygonových vrstev. Kliknutím na Next (další) se dostanete k poslednímu oknu 

Legend Wizard. 



V posledním okně (viz obrázek níže vpravo) nastavíte mezery mezi jednotlivými částmi 

legendy. Do příslušných políček zapíšete číselnou hodnotu mezery. Pokud je vše nastaveno, 

klikněte na tlačítko Finish (Dokončit). Z tohoto okna se ještě můžete vrátit do předešlých 

dialogů pomocí tlačítka Back (Zpět). V každém kroku Legend Wizard můžete využít tlačítka 

Preview pro zobrazení náhledu legendy.  

 

          

 

Jakmile je legenda vytvořena a umístěna, můžete dále měnit její vzhled dvojitým kliknutím 

na legendu, nebo pravým kliknutím na legendu a zvolení možnosti Properties. Zobrazí se 

okno Legend Properties (viz obrázek níže). Na jednotlivých kartách měníte vlastnosti 

obdobně jako v Legend Wizard. Pokud chcete provést nějaké změny pouze u některých 

položek, je třeba je označit v záložce Items (položky). 

 

Tento krok provádějte pouze, pokud je to nezbytně nutné a až na konci všech úprav 

s mapou: Vytvořené základní kompoziční prvky vždy nemusí být přesně podle vašich 

představ. K podrobné úpravě (např. legendy) slouží tzv. „rozbíjení“, tím oddělíte jednotlivé 

položky legendy. Dále již nepracujete s legendou jako s celkem, ale můžete měnit jakoukoli 

její dílčí část. Rozbití provedete tak, že kliknete pravým tlačítkem myši na legendu a zvolíte 

možnost Convert To Graphics (převést na grafiku). Ještě musíte od sebe oddělit 

jednotlivé položky legendy, čehož docílíte, kliknete-li opět pravým tlačítkem na legendu a 

zvolíte možnost Ungroup (oddělit). Pomocí tlačítka Ungroup lze oddělit i jednotlivé prvky 

legendy (symbol a text). Jakmile budete s úpravou legendy hotovi, označíte položky, které 

chcete, aby se spojily, kliknete na ně pravým tlačítkem a zvolíte možnost Group (seskupit).  

 



 

 

Severka 

Severku vložíte výběrem z Hlavního menu → Insert (vložit) → North Arrow (severka). 

Otevře se okno North Arrow Selector, (viz obrázek 22), kde zvolíte typ severky. Potvrdíte 

kliknutím na OK. Severkou můžete pohybovat v mapě pomocí stisknutého levého tlačítka 

myši a přemístěním severky na vybrané místo. Dvojitým kliknutím na severku se zobrazí 

tabulka North Arrow Properties (viz obrázek níže), kde si opět podle potřeby nastavíte 

typ, velikost, barvu, rám a umístění.  Jelikož jsou data zobrazena v souřadnicovém systému S-

JTSK, je třeba nastavit kalibrační úhel na 7 stupňů. Severka v české kartografii musí být 

popsána česky, nikoli N jako North, ale S jako sever. Toho docílíte, když zvolíte Insert 

→ Text. Napíšete S, dvakrát na něj pokliknete a zde můžete upravit velikost. Zvolíte 

Change symbol → Edit symbol a v záložce Angle napíšete -7, aby mělo písmeno 

S stejný sklon jako severka.                   

 



 

 

           

  Tiráž         

Tiráž vložíte pomocí Hlavního menu → Insert (vložit) → Text. Objeví se obdélník, do 

kterého napíšete potřebné údaje. Rozhodnete-li se později tiráž upravit, kliknete na ni 

dvakrát, nebo pravým tlačítkem myši a zvolením možnosti Properties. Objeví se okno 

Properties (viz obrázek níže), ve kterém dále můžete měnit text, velikost a druh písma, 

barvu atd.  

 

 

 

 

Export mapy 

Konečnou fází je převedení vypracovaného projektu do běžného grafického formátu. 

V Hlavním menu zvolíte záložku File (soubor) → Export Map (export mapy) (viz obrázek 



níže). Zde máte na výběr několik formátů (např. PDF, BMP, JPEG, TIFF). Zvolíte si vámi 

požadovaný formát, navolíte název souboru, místo uložení a uložíte. 

 

 

 

 

 


