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Cvičení 1 
Seznámení s prostředím ArcGIS (ArcCatalog, ArcMap, ArcToolbox) 

 
 
 
 
 
 
 
 
 
 
 



 
 
 

0. Prolog 
Na ploše vytvořte podadresář ArcGIS_uvod. Naučte se nepoužívat v názvech adresářů ani souborů 
mezery, pro některé operace je mezera kdekoli v cestě nepřekonatelnou překážkou! Stejně tak se při 
pojmenovávání dat i složek vyhněte české diakritice nebo třeba pomlčkám či jiným „problémovým“ 
znakům. 
 
Provedli jste něco nelogického? 
 
Takže raději v C:\Temp si  vytvořte adresář ArcGIS_uvod a do něj si rozbalte data pro toto cvičení z 
učebních materiálů předmětu na is.muni.cz 
 

1. Komponenty ArcGIS: ArcMap, ArcCatalog, ArcToolbox, ArcScene… 
ArcCatalog – organizování a uspořádávání dat. 
ArcMap – tvorba map 
ArcToolbox – analýzy dat 
 
ArcScene – 3Dsceny 
ArcGlobe – zobrazení dat na globu 
 

2. Úrovně ArcGIS 
ArcGIS má tři úrovně (licence):  
ArcView umožňuje prohlížet, organizovat, analyzovat, editovat a dokumentovat data. Je 
nejzákladnějším a nejjednodušším modulem ArcGIS.  
ArcEditor má všechny funkce jako ArcView a navíc nástroje pro editaci shapefilů a geodatabází  
ArcInfo je nejvyšší (a také nejdražší) verzí GIS software od firmy Esri. Obsahuje všechny funkce výše 
zmíněné a obsahuje řadu dalších pokročilých analytických nástrojů pro práci s geodety 
 
Otevřete si ArcCatalog  a zjistěte jakou máte licenci (Help > About ArcCatalog) 
 

3. ArcCatalog 
Slouží k organizování a uspořádávání dat používaných v GIS. Tuto aplikaci lze přirovnat např. k 
programu Průzkumník či Total Commander, které se používají pro běžné nakládání se soubory v 
počítači. ArcCatalog je tedy takový průzkumník, vytvořený speciálně pro organizaci GIS dat – 
databází, mapových vrstev, map a metadat. Umožňuje náhledy těchto dat před jejich otevřením a 
bezrizikovou (časem zjistíte o jaká rizika jde) manipulaci s daty. 
 
Zobrazuje ArcCatalog včechna data na disku? Např. toto .pdf? 
 
Pokud byste chtěli změnit nastavení toho, jaké typy dat v ArcCatalogu zobrazovat, můžete to změnit 
v Customize  > ArcCatalog Options  > General  případně Tools  > ArcCatalog Options  > File Types. 

 
 
 
4. Obsah okna 



 
vlevo Catalog Tree – organizace dat – funguje podobně jako Windows Explorer, s tím rozdílem, že 
zobrazuje pouze soubory v určitých formátech. Proto mohou být některé složky  prázdné 
 
vpravo zobrazovací pole má tři záložky (Contents, Preview, Metadata) – umožňují zkoumat obsah 
vybraných složek a souborů 
 

Content – zobrazuje seznam položek obsažených ve vybrané složce, můžete si zvolit zda 
chcete zobrazovat pouze malé nebo velké ikony, ikony s náhledem (thumbnails) či podrobný 
seznam s atributy. 
 
Preview – zobrazuje náhledy geografických i tabulkových dat 
 
Description (dříve Metadata) – umožní přístup k metadatům, tedy k popisným informacím k 
dané složce či souboru. ArcCatalog obsahuje také Metadata editor, který umožňuje úpravy a 
vytváření metadat 

 
K čemu slouží další složky (např. Internet Servers) v Catalog Tree?  Zjistíte to (a zdaleka nejen to) 
v online heplu zde:  
 
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html  
 
 
 

5. Tvorba adresářů, souborů 
Na začátku jakékoli práce v GIS je dobré si pořádně rozmyslet organizaci dat. Přesouvání dat 
uprostřed rozdělané práce může způsobit potíže (časem uvidíte jaké). Struktura a tvorba adresářů a 
souborů v ArcCatalog je obdobná jako např. ve Windows Explorer. 
 

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html


Lze vytvořit v libovolném adresáři nový prázdný (daty zatím nenaplněný) shapefile nebo 
geodatabase?  
Lze vytvořit nový prázdný rastr? 
  

6. Folder connection 
Abyste nemuseli pokaždé při hledání dat procházet celý katalog, vytvoříte si přímé spojení k vaší 
složce:  
 

File> Connect to folder ( nebo  ) 
 
Poté, co najdete vaši složku ArcGIS_uvod a odklepnete OK, se v Catalog tree objeví nová položka, 
která popisuje cestu k vašim datům. 
 

Spojení se odstraní pomocí File > Disconnect from folder (nebo ). Odstraní se pouze spojení, nikoli 
data samotná! 
 

7. Zkoumání obsahu složek 
Všimněte si, že každý datový typ má jinou ikonku (což usnadňuje orientaci v datech). 

 
 
Kolik vektorových bodových vrstev je v adresáři ArcGIS_uvod? 
 



Všimněte si, jak jsou uložena vektorová a rastrová data na disku (použijte normální prohlížeč např. 
Total Commander nebo Průzkumník Windows – Start/Všechny programy/Příslušenství/ Průzkumník 
Windows). 
 
Přejmenujte v ArcCatalogu vrstvu Potenc1 na Potenc_vegetace a sledujte, jak se změní soubory v 
normálním prohlížeči. 
 
V Catalog tree vyberte soubor fytog_okr z adresáře ArcGIS_uvod a klikněte na Preview. 
 
Stejně jako v ArcMap můžete i v tomto náhledu použít zoom in, zoom out, pan, full extent a identify.  
 

 
 

Zoom in  funguje tak, že kliknete na ikonku a pak na místo, které chcete přiblížit, druhá možnost 
je kliknout do mapy a pak tažením kurzoru vytvořit výřez, který se zvětší. 

Totéž platí pro zoom out .  

Pan  umožňuje posun mapy (kliknout na ikonku, pak v mapě kliknout a táhnout).  
 

Back  a Forward  umožňují pohyb na předchozí a následující rozsah mapy. 
 

Kliknutím na Identify  a pak na polygon se zobrazí atributy daného polygonu.  
Vyzkoušejte si to. 
 
Preview umožňuje zkoumat i obsah atributových tabulek. Ve spodní části okna místo Geography 
zvolíte Table a zobrazí se atributová tabulka.  
 

  
 
V řádcích jsou záznamy jednotlivých polygonů, ve sloupcích jejich vlastnosti. V tabulce lze seřadit 
záznamy (PTM na hlavičku sloupce > Sort), počítat statistiky ((PTM na hlavičku sloupce > Statistics), 
mazat atributy a podobně, ale tyto operace si vyzkoušíte až v ArcMap, kde se to dělá stejným 
způsobem. 
 
Jakou rozlohu má fytogeografický okres Moravský kras?  
 
Který fytogeografický okres je největší? 
 
 

8. Přidávání dat do ArcMap 
Z ArcCatalog je také možné přidávat vrstvy do ArcMap. V ArcMap to sice jde i jinak, ale tato možnost 
se hodí například chcete-li přidat zároveň několik souborů z různých adresářů.  

Otevřete si ArcMap pomocí ikonky .  
 
Klikněte na Cancel v okně s výběrem dříve otevřených mapových dokumentů, otevře se prázdný 
mapový dokument. Zmenšete si okno ArcMap tak, abyste viděli vedle něj i ArcCatalog (stačí část s 
Catalog tree). Kliknutím a přetažením do ArcMap si můžete přidat vrstvu přidá vybraná vrstva.  



 
 
 
 
 

9. Přidávání a odstraňování vrstev v ArcMap 
Pokud jste přidali v předchozím kroku nějakou vrstvu, klikněte na její název v Table of contents 

pravým tlačítkem myši (PTM) a zvolte Remove. Pak pomocí   přidejte z adresáře ArcGIS_uvod 
jednu nebo více vrstev. Více vrstev zároveň můžete vybrat pomocí Ctrl. Upozornění  
 

 
 
si prozatím nevšímejte a odsouhlaste ho. V pravé části okna se postupně objeví mapa ČR složená z 
několika vrstev. Přehled přidaných vrstev vidíte v levé části okna v Table of contents (dá se zavřít a 
zase přidat z Window).  



 
 
Každá vrstva nese název a pod ním se nachází symbol, ze kterého je zřejmé, zda se jedná o 
vektorovou vrstvu prvků bodových, liniových nebo polygonů, popř. rastr nebo třeba TIN. Vlevo od 
názvu vrstvy se nachází čtvercové políčko. Pokud je zaškrtnuto, znamená to, že je vrstva zobrazena. 
Pokud do čtverečku kliknete, zaškrtnutí zmizí a vrstva v mapě zobrazena nebude. Kliknete-li do 
čtverečku znovu, bude vrstva opět zaškrtnuta a zobrazena.  
 
Důležité je i pořadí vrstev v Table of contents, první vrstva od shora se zobrazuje navrchu a ostatní 
vrstvy jsou dle svého pořadí zobrazovány pod ní. To znamená, že při nesprávném zvolení pořadí 
vrstva nemusí být všechna data viditelná. 
 
Table of Contens má 4 možnosti zobrazení: 
 



 
List By Drawing Order  (podle pořadí vrstev nad sebou), 

List By Source  (zobrazuje data podle struktury adresářů a databází, ve kterých jsou umístěny),  

List By Visibility  (rozděluje tabulku obsahu na skupinu dat zobrazených a nezobrazených) 

List By Selection  (umožňuje označit vrstvy, na kterých lze provést myší výběr – select) 
 
Nově přidané vrstvy se zařadí pod nebo nad stávající vrstvy v Table of contents? 
 
Zálaží při tom jedná-li se o bodovou, liniovou, nebo polygonovou vrstvu? Kam se zařadí rastry? 
 
Kromě datových vrstev lze do Table Of Contens přidat i podkladovou mapu, tzv. Basemap, a nebo 
data ležící mimo Váš počítač buď na ArcGIS Online nebo na jiných mapových serverech. 
 

 
 

10. Tools Toolbar 
 

  
 
Pokud si nejste jisti, co která ikona v nástrojové liště Tools dělá, můžete se podívat do online helpu, 
hledejte „Displaying maps in data view and layout view“ 
 

11. Symbologie 
ArcMap nezná smysl zobrazovaných prvků a přiřazuje jim tudíž barvy náhodně. Vy si teď symboly a 
barvy změníte tak, aby byla mapa na první pohled čitelná. Klikněte dvakrát na symbol, který se 
nachází pod názvem vrstvy hrcr_linie. V nabídce najděte symbol pro State boundary a případně 
zvolte požadovanou barvu a velikost. Stejný postup použijte i pro další symboly. Vodní toky nechť 
jsou světle modré, silnice červené a vodní plochy tmavě modré.  
 
Vrstvy fytogeografické okresy a potenciální vegetace obsahují několik kategorií, které byste rádi 
zobrazili různými barvami. Jaké to jsou katgorie zjistíte v atributové tabulce.  
 
Každá vektorová vrstva má svou atributovou tabulku: PTM na název vrstvy > Open attribute table 
(nebo Ctrl + dvojklik na název vrstvy). 
 
Pokud víte, podle jakého atributu chcete vrstvu klasifikovat, v Layer Properties použijte záložku 
Symbology. V Categories pro Show zvolte Unique values, ve Value field FYT_OBL a Add all values. 
 
Spojité proměnné (např. VYSKA ve vrstvě VYSKY - vrcholy) klasifikujte pomocí histogramu (Layer 
Properties > Symbology > Quantities > Graduated Colors > Classify) 
 



Zobrazit dvě polygonové vrstvy , které se navzájem překrývají, lze dvěma způsoby: 
První možností je zvolit pro horní vrstvu symbologii bez výplně (pouze pomocí outline), druhou 
možností je zprůhlednit vrstvu (Layer properties > Display > Transparency) 
 
 

12. Mapový dokument    .mxd 
Základní jednotkou, se kterou v ArcMapu pracujete je mapový dokument (soubor s koncovkou 
.mdx). Tento soubor uchovává informace o zobrazení veškerých dat načtených do ArcMapu a o všech 
dalších prvcích obsažených v mapě. Neobsahuje geografická data samotná. Veškerá data, která jsou 
v mapovém dokumentu obsažena, jsou ukládána zvlášť ve svých vlastních souborech. Mapový 
dokument uchovává cestu k místu uložení těchto dat na disku a informaci, jak se mají tato data na 
mapě zobrazit (symbologie, měřítko, souřadný systém…atd.) 
 
Jakých velikostí dosahuje mapový dokument .mxd ve srovnání se samotnými daty? 
 
Uložte mapový dokument (File > Save As) a zjistěte jeho velikost. 
 

13. Data Frame 
Samozřejmě můžete pracovat s více mapami v jednom mapovém dokumentu (jednom .mxd 
souboru). Vrstvy, které chcete zobrazovat v jedné mapě se seskupí do datové skupiny (Data frame, 
v Table of Contents je to pokud to nepřejmenujeme Layers), která odpovídá jedné mapě. Všechny 
data která v ArcMapu přidáváte do Table of Contens se přidávají do aktivního Data Frame.  Aktivní je 
ten Data Frame, jejož název je tučný. Přidat nový Data Frame lze několikrát (Insert > Data Frame). 
Pokud chcete zaktivnit jinou skupinu dat (Data Frame), klikněte pravým tlačítkem myši na její název, 
zobrazí se nabídka, klikněte na Activate. 
 
Každý Data Frame má svůj vlastní souřadný systém, měřítko, jednotky. 
 
Pomocí Copy a Paste lze vrsty kopírovat z jednoho Data Frame do druhého. 
 

14. Souřadný systém 
Každá vrstva by měla mít definován souřadný systém. Data Frame přebírá informaci o souřadném 
systému z první vrstvy, která je do něj načtena. Pokud tato první vrstva nemé definován souřadný 
systém, ani Data Frame ho mít definovaný nebude. To se nebude jevit jako problém do té doby, než 
budeme chtít přidat data v jiném souřadném systému.  
 
Nastavit, popř. změnit souřadný systém lze v Data Frame Properties (PTM na název Data Frame > 
Properties > záložka Coordinate system) 
 
Cesta ke třem v ČR nejpoužívanějším souřadným systémům je následující: 
 
S-JTSK: Predefined/Projected Coordinate Systems/National Grids/Europe/S-JTSK Krovak EastNorth.prj 
 
S-42: Predefined/Projected Coordinate Systems/Gauss Kruger/Pulkovo 1942/Pulkovo 1942 GK Zone 
3.prj. 
 
WGS-84: Predefined/Geographic Coordinate Systems/World/WGS 1984.prj 
 
Při změně souřadného systému je nutné kromě výběru správného cílového souřadného systému 
vybrat ještě správnou transformační rovnici (Transformations…): 
 



S_JTSK > WGS84 a naopak:  S_JTSK_To_WGS_1984_1 
S_JTSK > S42 a naopak:  S_JTSK_To_Pulkovo_1942 
S42 > WGS84 a naopak:  Pulkovo_1942_To_WGS_1984_5 
 
Pokud nevyberete transformační rovnici, data budou transformována, ale s menší přesností, pouze v 
režimu on the fly. 
 
Vytvořte třikrát Data Frame a v něm mapu fytogeografických okresů ve třech různých souřadných 
systémech. 
 
Otevřete si čistý mapový dokument (File > New) a přidejte si do něj vrstvu fytogeografických okresů. 
Zjistěte jaký souřadný systém má vrstva definován (možná to poznáte i podle souřadnic vpravo dole 
pod mapovým oknem). Pokud ne, podívejte se do Layer Properties (PTM na název vrstvy > Properties 
> Source). POZOR: je to trochu matoucí, nejedná se o Date Frame Properties, (PTM na název Data 
Frame (v tomto případě, pokud jsme to nepřejmenovali, tak se Data Frame zatím jmenuje Layers)  > 
Properties > Coordinate Systém). 
 
Zjistěte, jak souřadný systém vrstvy ovlivňuje souřadný systém Data Framu.  
Zkuste si do čistého (File > New)  
 
(POZOR: Nastačí vrstvy odebrat, informace o souřaném systému v Data Framu zůstává, je třeba ji 
„resetovat“)  
 
Data Framu přidat vrstvu fytogeografických okresů a potom vrstvu silnic. 
Nyní si do čistého Data Framu přidejte vrstvu fytogeografických okresů a potom vrstvu krajů. 
 

 
 
Vyzkoušejte další kombinaci: do čistého Data Framu nejdříve vrstvu silnic, poté vrstvu krajů. 
 
Zkuste vysvětlit, v čem byl rozdíl. 
 

 



15. Layout view 
Pod oknem, ve kterém se zobrazuje mapa, lze volit buď Data View nebo Layout View. 
Data View slouží k práci na jednotlivých mapách (Data Frame), zobrazuje vždy pouze aktuální Data 
Frame. 
Layout View slouží k vytvoření výsledné mapové kompozice před tiskem, popř. exportem. Může 
obsahovat několik map (Data Frame), legendu, grafické měřitko, severní šipku, síť souřadnic, tabulky, 
grafy, obrázky, text... 
Do Layoutu se položky vkládají Insert > Legend ( Scale Bar, North Arrow, Text….) 
 
K navigaci v Layoutu se používá Layout Toolbar. Nástroje zde nepracují s mapou, ale s „výkresem“. 

Pro výběr prvků v Layoutu se používá nástroj Select Elements z nástrojové lišty Tools. 
 
ArcMap nabízí velmi mnoho Toolbars, není praktické je mít na pracovní ploše všechny, o tom, které 
tam mít budete, rozhodnete v Customize/Toolbars. 
 

 
 
 

 
 
V Layout View zobrazte všechyny tři Data Frame se třemi mapami fytogeografických okresů ve třech 
různých souřadných systémech. Čím se na první pohled liší S42 a S-JTSK 
 
 
 


