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Geografické informacni systémy
v botanice a zoologii

Cviceni 1
Seznameni s prostfedim ArcGIS (ArcCatalog, ArcMap)
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1. Komponenty ArcGIS: ArcMap, ArcCatalog, ArcScene, ArcGlobe
ArcCatalog — organizovdni a usporadavani dat.

ArcMap — tvorba map

ArcScene —3Dsceny

ArcGlobe — zobrazeni dat na globu

2. Urovné ArcGIS

ArcGIS ma tfi urovné (licence):

Basic umoznuje prohlizet, organizovat, analyzovat, editovat a dokumentovat data. Je nejzdkladné;jSim
a nejjednodussim modulem ArcGIS.

Standard ma vSechny funkce jako ArcView a navic nastroje pro editaci shapefil(l a geodatabazi
Advanced je nejvyssi (a také nejdrazsi) verzi GIS software od firmy Esri. Obsahuje vsechny funkce
vySe zminéné a obsahuje fadu dalsich pokrocilych analytickych nastrojl pro praci s geodety

Otevrete si ArcCatalog a zjistéte jakou mate licenci (Help > About ArcCatalog)

3. ArcCatalog

Slouzi k organizovani a usporadavani dat pouzivanych v GIS. Tuto aplikaci Ize pfirovnat napf. k
programu Prizkumnik ¢i Total Commander, které se pouZivaji pro bézné nakladani se soubory v
pocitaci. ArcCatalog je tedy takovy prazkumnik, vytvoreny speciadlné pro organizaci GIS dat —
databazi, mapovych vrstev, map a metadat. Umoznuje nahledy téchto dat pred jejich otevienim a
bezrizikovou (¢asem zjistite o jaka rizika jde) manipulaci s daty.

Zobrazuje ArcCatalog v€echna data na disku? Napfr. toto .pdf?




4. Obsah okna
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vlevo Catalog Tree — organizace dat — funguje podobné jako Windows Explorer, s tim rozdilem, Ze

zobrazuje pouze soubory v urcitych formatech. Proto mohou byt nékteré slozky prazdné

vpravo zobrazovaci pole ma tfi zalozky (Contents, Preview, Description) —
vybranych sloZek a soubort

umoznuji zkoumat obsah

Content — zobrazuje seznam poloZek obsazenych ve vybrané sloZce, mizZete si zvolit zda

chcete zobrazovat pouze malé nebo velké ikony, ikony s ndhledem
seznam s atributy.

Preview — zobrazuje nahledy geografickych i tabulkovych dat

Description (dfive Metadata) — umozni pfistup k metadatlim, tedy k popisnym informacim k
ktery umoZiuje Upravy a

dané sloZce Ci souboru. ArcCatalog obsahuje také Metadata editor,
vytvareni metadat

5. Tvorba adresara, soubort

(thumbnails) ¢i podrobny

Na zacatku jakékoli prace v GIS je dobré si porfadné rozmyslet organizaci dat. Pfesouvani dat

uprostred rozdélané prace muze zplsobit potiZe (Casem uvidite jaké). Struktura a tvorba adresail a

soubor(l v ArcCatalog je obdobna jako napf. ve Windows Explorer.

Lze vytvorit v libovolném adresati novy prazdny (daty zatim nenaplnény) shapefile nebo

geodatabase?
Lze vytvorit novy prazdny rastr?




6. Folder connection

Abyste nemuseli pokazdé pri hledani dat prochazet cely katalog, vytvofrite si pfimé spojeni k vasi

slozZce:

File> Connect to folder ( nebo &%)

Poté, co najdete vasi slozku ArcGIS_uvod a odklepnete OK, se v Catalog tree objevi nova polozka,

kterd popisuje cestu k vasim datlm.

Spojeni se odstrani pomoci File > Disconnect from folder (nebo E'Ej). Odstrani se pouze spojeni, nikoli

data samotna!

7. Zkoumani obsahu slozek

Vsimnéte si, Ze kazdy datovy typ ma jinou ikonku (coZ usnadriuje orientaci v datech).
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Kolik vektorovych bodovych vrstev je v adresari ArcGIS uvod?

Vsimnéte si, jak jsou uloZena vektorova a rastrova data na disku (pouZijte normalni prohlizec napfr.
Total Commander nebo Prizkumnik Windows — Start/Vsechny programy/Prislusenstvi/ Prizkumnik

Windows).



Pfejmenujte v ArcCatalogu vrstvu Potencl na Potenc_vegetace a sledujte, jak se zméni soubory v
normalnim prohlizedi.

V Catalog tree vyberte soubor fytog_okr z adresare ArcGIS_uvod a kliknéte na Preview.

Stejné jako v ArcMap muZete i v tomto nahledu pouzit zoom in, zoom out, pan, full extent a identify.

23810 ¢+ O &

Zoom in @ funguje tak, ze kliknete na ikonku a pak na misto, které chcete pfriblizit, druhd moznost
je kliknout do mapy a pak tazenim kurzoru vytvofit vyrez, ktery se zvétsi.

Totéz plati pro zoom out Q .

Pan T umoznuje posun mapy (kliknout na ikonku, pak v mapé kliknout a tahnout).
Back * a Forward umoziuji pohyb na predchozi a ndsledujici rozsah mapy.

Kliknutim na Identify® a pak na polygon se zobrazi atributy daného polygonu.
Vyzkousejte si to.

Preview umoznuje zkoumat i obsah atributovych tabulek. Ve spodni ¢asti okna misto Geography
zvolite Table a zobrazi se atributova tabulka.

Preview: |Geography j

V fadcich jsou zaznamy jednotlivych polygon, ve sloupcich jejich vlastnosti. V tabulce Ize sefadit
zaznamy (PTM na hlavicku sloupce > Sort), pocitat statistiky ((PTM na hlavicku sloupce > Statistics),
mazat atributy a podobné, ale tyto operace si vyzkousite az v ArcMap, kde se to déla stejnym
zpUsobem.

Jakou rozlohu ma fytogeograficky okres Moravsky kras?

Ktery fytogeograficky okres je nejvétsi?

8. Pridavani dat do ArcMap
Z ArcCatalog je také mozné pridavat vrstvy do ArcMap. V ArcMabp to sice jde i jinak, ale tato moznost
se hodi napriklad chcete-li pridat zaroven nékolik soubort z riznych adresara.

9

Otevrete si ArcMap pomoci ikonky .

Kliknéte na Cancel v okné s vybérem dfive otevienych mapovych dokument(, otevre se prazdny
mapovy dokument. Zmensete si okno ArcMap tak, abyste vidéli vedle néj i ArcCatalog (staci ¢ast s
Catalog tree). Kliknutim a pretazenim do ArcMap si mUZete pfidat vrstvu.
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9. Pridavani a odstranovani vrstev v ArcMap
Pokud jste pfidali v pfedchozim kroku néjakou vrstvu, kliknéte na jeji ndzev v Table of contents

pravym tlacitkem mysi (PTM) a zvolte Remove. Pak pomoci b - pfidejte z adresare ArcGIS_uvod
jednu nebo vice vrstev. Vice vrstev zaroven muzete vybrat pomoci Ctrl.
Upozornéni:

A% Unknown Spatial Reference 7| x|

The following data sources you added are missing spatial reference
information. This data can be drawn in ArcMap, but cannot be projected:

GEOLOGIE =]

si prozatim nevéimejte a odsouhlaste ho. V pravé ¢asti okna se postupné objevi mapa CR sloZena z
nékolika vrstev. Pfehled pridanych vrstev vidite v levé ¢asti okna v Table of contents (d4 se zavfit a
zase pridat z Window).
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Kazda vrstva nese nazev a pod nim se nachazi symbol, ze kterého je zfejmé, zda se jednd o
vektorovou vrstvu prvkl bodovych, liniovych nebo polygon(, popf. rastr nebo tfeba TIN. Vlevo od
nazvu vrstvy se nachazi ¢tvercové policko. Pokud je zaskrtnuto, znamena to, Ze je vrstva zobrazena.
Pokud do ¢tverecku kliknete, zaskrtnuti zmizi a vrstva v mapé zobrazena nebude. Kliknete-li do
¢tverecku znovu, bude vrstva opét zaskrtnuta a zobrazena.

Dtlezité je i pofadi vrstev v Table of contents, prvni vrstva od shora se zobrazuje navrchu a ostatni
vrstvy jsou dle svého poradi zobrazovdny pod ni. To znamena, Ze pfi nespravném zvoleni poradi

vrstva nemusi byt vSechna data viditelna.

Table of Contens ma 4 moznosti zobrazeni:
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= Frontage Dimension

M maa Dl iy, gpetans

List By Drawing Order e (podle poradi vrstev nad sebou),

List By Source = (zobrazuje data podle struktury adreséid a databazi, ve kterych jsou umistény),
List By Visibility “* (rozdéluje tabulku obsahu na skupinu dat zobrazenych a nezobrazenych)

List By Selection 8 (umoZiiuje oznadit vrstvy, na kterych Ize provést mysi vybér — select)

Nové pridané vrstvy se zaradi pod nebo nad stavajici vrstvy v Table of contents?

Zalazi pri tom jedna-li se o bodovou, liniovou, nebo polygonovou vrstvu? Kam se zaradi rastry?

Kromé datovych vrstev Ize do Table Of Contens pfidat i podkladovou mapu, tzv. Basemap, a nebo
data leZici mimo Vas pocita¢ bud na ArcGIS Online nebo na jinych mapovych serverech.

& -|l 7|

& addData...

EE Add Basemap...

BH add Data From ArcGIS Online. ..

10. Tools Toolbar

Qe Qe B-E O/ 2 NH2 TR

Pokud si nejste jisti, co ktera ikona v nastrojové listé Tools déla, mlzete se podivat do online helpu,
hledejte ,Displaying maps in data view and layout view”

11. Symbologie

ArcMap nezna smysl zobrazovanych prvk( a pfifazuje jim tudiz barvy nahodné. Vy si ted symboly a
barvy zménite tak, aby byla mapa na prvni pohled Citelna. Kliknéte dvakrat na symbol, ktery se
nachdzi pod ndzvem vrstvy hrcr_linie. V nabidce najdéte symbol pro State boundary a pfipadné
zvolte poZadovanou barvu a velikost. Stejny postup pouzijte i pro dalsi symboly. Vodni toky necht
jsou svétle modré, silnice ¢ervené a vodni plochy tmavé modré.

Vrstvy fytogeografické okresy a potencialni vegetace obsahuji nékolik kategorii, které byste radi
zobrazili rGznymi barvami. Jaké to jsou katgorie zjistite v atributové tabulce.

Kazda vektorova vrstva ma svou atributovou tabulku: PTM na nazev vrstvy > Open attribute table
(nebo Ctrl + dvojklik na ndzev vrstvy).

Pokud vite, podle jakého atributu chcete vrstvu klasifikovat, v Layer Properties pouzijte zalozku
Symbology. V Categories pro Show zvolte Unique values, ve Value field FYT_OBL a Add all values.

Spojité proménné (napf. VYSKA ve vrstvé VYSKY - vrcholy) klasifikujte pomoci histogramu (Layer
Properties > Symbology > Quantities > Graduated Colors > Classify)



Zobrazit dvé polygonové vrstvy , které se navzajem prekryvaji, Ize dvéma zpUsoby:
Prvni mozZnosti je zvolit pro horni vrstvu symbologii bez vyplné (pouze pomoci outline), druhou
moznosti je zprahlednit vrstvu (Layer properties > Display > Transparency)

12. Mapovy dokument .mxd

Zakladni jednotkou, se kterou v ArcMapu pracujete je mapovy dokument (soubor s koncovkou
.mdx). Tento soubor uchovava informace o zobrazeni veskerych dat nactenych do ArcMapu a o vSech
dalsich prvcich obsazenych v mapé. Neobsahuje geograficka data samotna. Veskera data, kterd jsou
v mapovém dokumentu obsazena, jsou ukladana zvlast ve svych vlastnich souborech. Mapovy
dokument uchovava cestu k mistu uloZeni téchto dat na disku a informaci, jak se maji tato data na
mapé zobrazit (symbologie, métitko, souradny systém...atd.)

Jakych velikosti dosahuje mapovy dokument .mxd ve srovnani se samotnymi daty?

UloZte mapovy dokument (File > Save As) a zjistéte jeho velikost.

13. Data Frame

Samoziejmé muZete pracovat s vice mapami v jednom mapovém dokumentu (jednom .mxd
souboru). Vrstvy, které chcete zobrazovat v jedné mapé se seskupi do datové skupiny (Data frame,

v Table of Contents je to pokud to nepfejmenujeme Layers), ktera odpovida jedné mapé. Vsechny
data kterd v ArcMapu priddvate do Table of Contens se pfidavaji do aktivniho Data Frame. Aktivni je
ten Data Frame, jejoZ nazev je tucny. Pfidat novy Data Frame lze nékolikrat (Insert > Data Frame).
Pokud chcete zaktivnit jinou skupinu dat (Data Frame), kliknéte pravym tlac¢itkem mysi na jeji nazev,
zobrazi se nabidka, kliknéte na Activate.

v v

Kazdy Data Frame ma svQj vlastni souradny systém, méfitko, jednotky.
Pomoci Copy a Paste Ize vrsty kopirovat z jednoho Data Frame do druhého.

14. Souradny systém

Kazda vrstva by méla mit definovan soufadny systém. Data Frame prebird informaci o souradném
systému z prvni vrstvy, kterd je do néj nactena. Pokud tato prvni vrstva nemé definovan souradny
systém, ani Data Frame ho mit definovany nebude. To se nebude jevit jako problém do té doby, nez
budeme chtit pfidat data v jiném soufadném systému.

Nastavit, popf. zménit soufadny systém lze v Data Frame Properties (PTM na ndzev Data Frame >
Properties > zdloZka Coordinate system)

Cesta ke tfem v CR nejpouzivanéjsim souradnym systémiim je nasledujici:
S-JTSK: Predefined/Projected Coordinate Systems/National Grids/Europe/S-JTSK Krovak EastNorth.prj

S-42: Predefined/Projected Coordinate Systems/Gauss Kruger/Pulkovo 1942/Pulkovo 1942 GK Zone
3.prj.

WGS-84: Predefined/Geographic Coordinate Systems/World/WGS 1984.prj

PFfi zméné souradného systému je nutné kromé vybéru spravného cilového souradného systému
vybrat jesté spravnou transformacni rovnici (Transformations...):



S_JTSK > WGS84 a naopak: S JTSK To WGS 1984 1
S_JTSK > S42 a naopak: S JTSK To_ Pulkovo 1942
S42 > \WGS84 a naopak: Pulkovo 1942 To WGS 1984 5

Pokud nevyberete transformacni rovnici, data budou transformovdna, ale s mensi presnosti, pouze v
rezimu on the fly.

Vytvorte tfikrat Data Frame a v ném mapu fytogeografickych okrest ve tfech rdznych souradnych
systémech.

Otevrete si ¢isty mapovy dokument (File > New) a pfidejte si do néj vrstvu fytogeografickych okresu.
Zjistéte jaky souradny systém ma vrstva definovan (moZna to pozndte i podle soufadnic vpravo dole
pod mapovym oknem). Pokud ne, podivejte se do Layer Properties (PTM na ndzev vrstvy > Properties
> Source). POZOR: je to trochu matouci, nejedna se o Date Frame Properties, (PTM na ndzev Data
Frame (v tomto pfipadé, pokud jsme to neprejmenovali, tak se Data Frame zatim jmenuje Layers) >
Properties > Coordinate Systém).

Zjistéte, jak souradny systém vrstvy ovliviiuje soufadny systém Data Framu.
Zkuste si do Cistého (File > New) ...

(POZOR: Nastaci vrstvy odebrat, informace o souraném systému v Data Framu zUstav4, je treba ji
,resetovat”)

...Data Framu pfidat vrstvu fytogeografickych okrest a potom
vrstvu silnic.

Nyni si do Cistého Data Framu pfidejte vrstvu fytogeografickych okresl a potom vrstvu kraja.

Geographic Coordinate Systems Warning 7] x|

The following data sources use a geographic coordinate system that is different fram
the one used by the data frame you are adding the data into:

Data Source | Geographic Coordinate System |
KRAJE GCS_Pulkova_1942

Alignment and accuracy problems may arise unless there is a correct transformation
between geographic coordinate systems.,

You can use this button to spedfy or modify the E o
transformation(s) used by this data frame: =

The Transformations dialog can also be accessed from the Data Frame Properties
dialog's Coordinate Systems tab after you have added the data.

[” Don't warn me again in this session

I Don't warn me again ever

Vyzkousejte dalsi kombinaci: do Cistého Data Framu nejdfive vrstvu silnic, poté vrstvu kraja.

Zkuste vysvétlit, v ¢em byl rozdil.




15. Layout view
Pod oknem, ve kterém se zobrazuje mapa, lze volit bud Data View nebo Layout View.

Data View slouzZi k praci na jednotlivych mapach (Data Frame), zobrazuje vZdy pouze aktualni Data
Frame.

Layout View slouzi k vytvoreni vysledné mapové kompozice pred tiskem, popf. exportem. Mlze

obsahovat nékolik map (Data Frame), legendu, grafické méritko, severni Sipku, sit souradnic, tabulky,
grafy, obrazky, text...

Do Layoutu se polozky vkladaji Insert > Legend ( Scale Bar, North Arrow, Text....)

K navigaci v Layoutu se pouziva Layout Toolbar. Nastroje zde nepracuji s mapou, ale s ,,vykresem®.
Pro vybér prvkl v Layoutu se pouziva ndstroj Select Elements K nastrojové listy Tools.

ArcMap nabizi velmi mnoho Toolbars, neni praktické je mit na pracovni plose vSechny, o tom, které
tam mit budete, rozhodnete v Customize/Toolbars.
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V Layout View zobrazte vSechyny tfi Data Frame se tfemi mapami fytogeografickych okrest ve tfech
rliznych soufadnych systémech. Cim se na prvni pohled ligi S42 a S-JTSK




