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1. Instalační pokyny 
 
Xfit – pozor, při rozbalení dojde k rozbalení VŠECH položek někam. Je z toho pak 

bordel. Doporučuji nejprve vytvořit složku a v ní extrahovat. 
 
 
Celref, Poudrix – nemělo by dělat žádný problém 
 
 
JANA2006 – execute Janainst.msi and follow instructions 
Instalace vytvoří shortcut k Jana2006 na Ploše a v nabídce Start 
 

Konfigurace programu 
 
Spustit Jana2006, jdi do „Tools → preferences, nastavte velikost okna (60% plochy) 
a velikost písma (mezi 15 and 18 pixcely). 
 
Jděte do „Tools → Programs“ vyberte myší textové pole „Graphic viewer“ a definujte 
(použijte tlačítko „Browse“) pathname pro Vesta.exe 
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2. Peak fitting with Xfit 
 

1. Run Xfit 
 

 
Toto je zakladní okno 
 

2. Otevření datového souboru, definice vlnové délky, manipulace s daty  

  
 

„File“ → „Load data“ → (vyber v dialogu „zobrazit soubory typu“ Files (.cpi) 
„Pyrite.cpi“ → „OK“ 
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Click „File details“ 

 
 
Click „Assign LAM to Files“ 
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Pak click on „pyrite.cpi“ (in the left bottom window) → pak click to “Assigned 
Lam Files” window → a následně na “Assign”, které se objeví v “Options” → 
následně se otevře dialog “Select LAM file to assign to selected files” 
 
Jakýkoliv jiný způsob nevede ke kýženému výsledku 
 
Go to the Xfit parent directory → select “CuKA_2.lam, “OK” → then minimize 
the window 
 
Go to “Edit” in the main window → select “Edit x-y scales” 
 
 Manipulace s daty: 
Pomocí tabulky Window: pyrite.cpi (x1=…, x2=…), pomocí funkce “Arrow” v 
“Options” okénku 
 
To funguje tak, že levý click označí oblast z leva, pravý click zprava. Try it! 
 

3. Fitování 
 
Select “Ins/Del peaks” 
Objeví se okénko “Peak edit options” 
Select “PVII” and 2theta 
To je profilová funkce PearsonVII, která zohledňuje nízkoúhlovou asymetrii. 
Pohledem na difrakční maxima zjistíme, že se zde nemusíme příliš obávat. 
Proto můžeme zvolit i fci PV (Pseudovoigt), která je fyzikálně lépe čitelná a 
okamžitě nám poskytuje informaci o FWHM fitovaného profilu. Zůstaňme u fce 
PVII 
Click on the diffraction peak by left mouse button and see… 
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Go to “Fit” → “Fit Marquart” 

 
Click on “Start” “Fit” → “Fit Marquart” 
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Refinement converged in 13 steps, with RP = 4.150 and final difference -0.003. 
Press “OK” and “Keep refined values” 
 
You can try to make one more round via “Fit” → “Fit Marquart” → “Start” 
A je evidentní, že fit zůstal stejný → dobrý výsledek! 
 
Nyní, pokud chceme na další peak, je nutné pohybovat se po datech pomocí 
tabulky “x-y” 
Tedy zadáme například x2=35 enter 
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Jdeme na další profil…opakujeme předešlé procedury, až máme nafitován 
celý záznam 

 
 
 

4. Extrakce dat (little bit tricky) 
Jdi do “File details” → click on “Peaks” → select “Split PearsonVII” → “Values” 
→ “Create TXT report” 
Tady se nacházíme v choulostivé fázi, tedy BACHA! (jak říká Petr Čtvrtníček: 
“Jedním jebem to všecko smázneš”) 
 Označ si data, Ctrl+c → Ctrl+v do Notepadu, ulož 
 
Následně zavři okno, bez uložení změn (jinak se to sekne, nebo to spadne). 
Můžete zkusit uložit jako project. Někdy se to sekne, někdy to spadne, někdy 
to nejde naloadovat. Je to již trochu dřevní program, a není zvyklý na 
Windows 7 natož Vista 
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4. Co s daty z Xfitu? 
 

Tady se dostáváme k zajímavému úkolu. Je potřeba si vytvořit přepočetní 
vzorec v Excelu (nejlépe). Pohledem na data získaná, zjišťujeme, že máme: 
 

 
Přičemž nás zajímá zejména nyní sloupec Th2, což je pozice difrakce ve 
°2theta. 
 
Některé programy fungují na základě inputu naměřených pozic ve °2theta, 
některé v dhkl (Angstromy) 
 
Cvičně si to udělejme také, neboť program Unit-cell pracuje na bázi obou 
možných inputů 
 
Tedy vytvořte vzorec, tak abychom z uhlové informace získali mezirovinnou 
vzdálenost v Angstromech 
 
A to na základě znalosti Braggovy rovnice. Vlnová délka zde odpovídá záření 
CuKa1, tedy 1.54056 Angstrom. 
 
Hodnoty dhkl odpovídají mezirovinným vzdálenostem, jejichž indexy budeme 
vyšetřovat dále 
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5. Program Poudrix 
 
Šikovný prográmek na výpočet teoretických difračních práškových dat ze 
známé krystalové struktury 
 

 
 
 “File” → “Open” → “.Cif” → nahraj “Pyrite.cif” 

 
Click on Xrays (červene) 
Musí být v tomto případě zatrženo XRays tube (p=0.5); polarizační faktor 
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“OK” 
 
Select Wavelength v okně “Wavelength” jako CuKa1. V dialogu “Experiment” 
zadej hodnotu 2thete2 jako 101, hodnoty U V a W nech default 
Click on Calcul. 

 
Můžeme si zobrazit i náš experimentální záznam ve spodním okně. 
Následovně: 
 
“File” → “Open” → “Cpi format (.cpi) → “Pyrite.cpi” 
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Vidíme shodu experimentu s teorií, co se týče pozic i intenzit 
Můžeme upravit FWHM teoretického záznamu, neboť je zde jistá diference 

 
za 

 
 
Pokud budete používat tento program, je dobré číst hodnoty v live-view. 
Program sice nabízí export výsledků, nicméně bývá chybný 
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6. Indexování difrakčního záznamu 
 
Úhlovým hodnotám difrakcí získaných z profilového fitování přiřazujeme dané 
indexy hkl, které reprezentují dané osnovy rovin mezi nimiž se ony dané 
mezirovinné vzdálenosti nacházejí. 
 
Nuže 
 
2Th               h           k            l 
28.5262 1 1 1 

 33.0488 0 0 2 
37.0854 1 0 2 
40.7788 1 1 2 
47.435 2 0 2 

56.2819 3 1 1 
59.0373 2 2 2 
61.6825 3 0 2 
64.2884 2 1 3 
76.6032 3 1 3 
78.9824 0 2 4 
81.3175 1 2 4 
83.6406 3 2 3 
88.3092 2 2 4 
95.2614 

 
1 
3 

1 
3 

5
3 
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7. Program UnitCell 
 
http://www.ccp14.ac.uk/ccp/web-mirrors/crush/astaff/holland/UnitCell.html 
 
Často užívaný program v mineralogické obci. Metoda nelineárních nejmenšíxh 
čtverců. Souhrný článek od autorů doporučuji při používání programu přečíst: 
 
Holland, TJB & Redfer, SAT (1997) Unit cell refinement from powder 
diffraction data: the use of regression diagnostics. Mineralogical Magazine 61: 
65-77. 
 
Máte následující soubory: 

 
Kde “Pyrit” byl vytvořen jako kopie ze složky “Examples”. Podívejte se, jak tyto 
soubory vypadají. 
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Máme tedy “hlavičku”, potom sloupce “hkl”, “pozice” (zde úhel). Zadání není 
pozičně citlivé, což je jistá výhoda (narozdíl např. od starého programu 
Burnham). Hlídat si, kde se člověk uklikl není vždy příjemné. 
 
Vyplníme textový soubor naším pyritem 
 
 

 
Uložíme 
 
Spustíme UnitCell 

 
Nastavíme dle obrázku, tzn. “Input data” máme ve formě 2tet, “lambda” délka 
je jaká je (můžeme změnit na 1.54056 (je to celkem zanedbatelné)). Pyrit je a 
snad i bude za normálních podmínek kubický, “minimalizujeme” na 2t, což má 
výhodu minimálním zaváděním nepřesností a korelací (viz. článek). “Brief 
diagnostics” nám dává statistiku, “refine zero-shift” můžeme nechat 
nerefinovaný 
 
Press “Run” 
Otevřeme “Pyrit” a v mžiku oka nám vyskočí výsledek: 
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Kde máme popořadě: 
1. Hlavičku 
2. Shrnutí zadání refinementu 
3. Nový mřížkový/ové parametr/y po proběhnutí refinementu, tedy zpřesněný 

zde parametr jest 5.41733(8), následuje 95% hladina spolehlivosti, která 
udává chybu na pozici 5.4173(2), což odpovídá i kolonce “sigmafit = 
1.9396” kterou by měly být hodnoty sigma násobeny, zejména pokud je 
větší než 1. Více v návodu+článku. Následuje hodnota reciprokého 
kubického parametru 

4. Oddělení udávájící pro jednotlivé hkl naměřené hodnoty mezirovinných 
vzdáleností (dobs), vypočtené (dcalc), jejich rozdíl (res(d)) a to samé pro 
úhlovou informaci 
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A dále následuje regresní diagnostika. 
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8. Program Celref 
 
Program pro refinement mřížkových parametrů metodou nejmenších čtverců. Výhoda 
je visualizace powder patternu, tedy okamžitá kontrola, co se děje. Nevýhoda je 
zdlouhavý input dat. 
 

 
 
“File” → “Open” → “Profile file → “.Cpi” → “Pyrite.cpi” 
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Click on button “Diagram” → objeví se nové okno → Click on “Peak search” 

 
 
Nastavte hodnoty z obrázku 

 
 
Poté click na “Options” → “DrawSecond Derivate” 
 
V programu se pohybujeme sipkami na spodni liste. Z- je oddaleni. POZOR, x 
rusi vse. Casto se clovek uklikne. 
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Takto se zobrazi 2nd derivate. Projedte v priblizeni cely zaznam a zjistete, jak 
jsou nahledany pozice (v minimu druhe derivace) 
 
OK. Pak “File”, “Save”, “Measured peaks”, “Bruker format” (.dif) 
 
Napr. “Pyrite.dif”, OK. 
 
Close the dialog. 
 
Poté “File”, “Open”, “Peak file”, “Bruker format”, “Pyrite.dif” 
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Click na “Initial cell parameters” a button”keyboard” 

 
 
Vyberte možnost “Cubic” v okně “System”,v okně “H-M standard symbols” 
vyberte prostorovou grupu “Pa3” a vyplňte mřížkový parametr a = 5.416 a 
stistkněte “Calc.” 

 
Zobrazí se napočítané pozice dle zadaných parametrů 
 
Přejděte do dalšího dialogu “Selection of the reflections”, select “Mouse 
selection Mode 2”. 
Klikněte na černou úsečku v difrakčním profilu a po té jí odpovídající teoretické 
linii ve spod (zelená). Po tomto úkonu zmodrají a označí se číslicí 1. 
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Pokračujte tímto způsobem i u dalších difrakcí 
 

 
Jdětě do dialogu Cell refinement a stisknete tlačítko s Kalkulačkou. Program 
ukáže refinované hodnoty 
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Vlevo, hodnoty před, uprostřed mřížkové parametry, vpravo hodnoty po 
refinementu s mean square deviationa úhlech. 
 
Zkusmo zavedeme korekci na zero-shift/displacement (kolonka v odd. Mříž. 
Parametrů označená delta2theta). Zjišťujeme, že nemá vliv, ba naopak fit 
zhorší. 
 
Export: 
Click na značku programu Excel 
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Vybrat možnost long. Označit vše, ctrl+c, ctrl+v do Excelu (nutno nezávisle 
oteřít). 
 
Pozor na importované hodnoty zpřesněného mřížkového objemu. Je zde 
chyba a dojde k importu bez sigma. 
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9. Program JANA2006 
 
Petříček et al. (2006) 
 
Komplexní nástroj krystalografické analýzy, umožnující řešení krystalových 
struktur pomocí “dceřiných”/vyvolatelných programů, jako jsou Superflip 
(Palatinus and Chapuis 2007) nebo SIR97 (Altomare et al. 1997), a refinement 
krystalových struktur na základě monokrystalových/práškových dat 
RTG/neutron/elektron zdojů. 
 

 
 
První kroky – pohyb v základním okně 
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1. Le Bail refinement eulytinu, kub. Bi4(SiO4)3 
 
File → Structure → New, vyberete soubor eulytite.dat 
 

 
 
Select “powder data” 

 
“Next” 
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Vyplňte do kolonky “cell parameters” hodnotu kubického mřížkového 
parametru a = 10.2867 
 

 
“Next” 
 
Reading of pattern, counting out reflections 
 
Pak “OK” 
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I would like to accept changes 
 
OK 
 
Pak se objevi nasledujici okno 

 
Začněte “Edit refinement commands” 

 
Zvyšte počet cyklů na 100 
Zaškrtněte ”Apply Berar´s correction” 
“OK” 
  
Click na “Show powder profile” 
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Pohybujete se pomocí myši (levé tlačítko + táhnout = zvětšit; pro reset zoomu 
použijte tlačítko “Shrink”) 
Back to main window with “Quit” 
 
Start with “Edit profile parameters” 
V záložce “Profile” zvolte možnost “Pseudo-Voigt” a zatrhněte chlívek u 
kolonky GW. 
V záložce “Corrections” zatrhněte “Shift” 
“OK” 2x 
Pak “Run refine” 
 
Sledujeme pokles na Rwp=35.77% zhruba v deseti krocích. Otevřeme 
“Listing” 
Otevřeme “Powder profile” 
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Edit profile paramters. Nechejme refinovat mřížkový pametr a. Ostatní nechme 
fixováno. 
 
Run 
 
Pokles asi v 17 cyklech na Rwp=25% a GOF=11 
Podívejme se, jak se změnil fit. 

 
Edit profile parameters 
V oddílu “Profile” aktivujte refinement LY, kde změntě z 0 na 1 
OK, run 
 
Pokles Rwp na hodnotu 17% a GOF kolem 7.5 

 
Edit profile parameters 
Asymmetry, aktivujte refinement typu Simpson 
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Decrease na Rwp=9% a GOF=3.75 
Activate refinement of the peak cutoff na 10 FWHM 
Pokles na Rwp=8.86% a 3.87 GOF 
 
“Finish” 
“Yes” 
“Next” 
“Next” 
“Next” 
 
Select centering I 
“Next” 
Select I -4 3 d 
“next” 
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Select “Accept the space group in the standard settings” 
And “Finish” 
Next 
Nerefinovat znovu 
Next 
Okno structure solution 
 
Nastavte následovně 

 
Při jiném nastavení Z, hodnoty hustoty vycházejí nereálně. Takto je okolo 6.7 
g.cm-3. 
 
OK 
Proběhne LeBailská dekompozice a objeví se okno 

 
Kde přepište v řádku “repeatmode nosuccess” na “repeatmode 5” 
Okno zavřete a dejte uložit (optional) 
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Řešení konvergovalo. Dejme “Accept the results” 
 
Problem 
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2. Rietveld refinement eulytinu, kub. Bi4(SiO4)3 
 
File, Structure, New, Eulytite 
 
Structure from CIF, next 
 
Vyber Eulytine.cif, OK 
Next 
Vyber Powder data, Various CW 
Select Bragg-Brentano fixed divergence slit 
Next 

 
Next 
Finish 
OK 
 
Go to Refine, select 100 cycles, Apply Berar´s correction and Make only 
profile matching 
 
Do LeBail 
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Pak Refinement options, Switch-off Profile Matching a také Automatic 
refinement keys. OK. Dejte pouze Yes, nezapínejte refinement. 
 
Edit atoms 
Select all 
Dvojklik na jeden z atomů 
V okne jdete na záložku Edit a dejte Fix all 
OK, OK, Yes 
Pak začněte Refine 
 
Refinement by se měl chytit po několikanásobné změně škálového faktoru 
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Podívejte se, jak vypadá difrakční profil a fit 

 
A zjistíte, že zcela jinak než předchvílí, zejména intenzity na prvních dvou 
dirakčních maximech jsou podfitovány. 
 
 
“Rozumně” vypadající fit si uložte pod nějakým chytrým jménem a pokračujte s 
ním. 
 
Zkuste postupně povolit atomové koordináty. Ukážeme si jak je v tomto 
případě možné/důležité postupovat. To samé platí pro ADP, které zkusíme 
povolit a refinovat. 
 
Zjistíme, že většina (alespoň u mne Si a O mají ADP non-positively definite). 
 
 
Pokusíme se nyní odhalit příčinu. Pohledem na difrakční profil a kalkulovaný 
pochopitelně odhalíme značné diference v intenzitách. 
 
Nuže uvažme, že látka, kterou jsme podrobili difrakčnímu experimentu 
obsahuje 4 atomy Bi (83 elektronů) na buňku při Z = 4, tedy 16 atomů v 
základní buňce, jejíž objem je 1000 Angstrom3. To je látka o značné absorpční 
schopnosti pro RTG záření, najmě měkkého jako je CuKalpha. 
 
Informaci o absorpčním koeficientu mí pro danou látku a záření nalezneme 
pod ikonkou “Edit M50” v hlavním okně 
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Pohlídáme si počty vzorcových jednotek (okamžitě se projeví v hodnotě 
hustoty a Absorption coefficient). 
 
OK, změny přijmout, OK. 
 
Dále, “Parameters”, “Powder”, “Sample” 

 
Zapněte volbu “Absorption correction” ve formě Mí x thickness (zadáno 0.5 
mm), absorpční koeficient má rozměr mm-1, tento parametr tedy funguje jako 
jakýsi škálový faktor.  
 
Proveďte refinement kompletní (koordináty, ADP) 
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Reálnější hodnoty, žádné záporné ADP (ani O atom). OK 
 

 
Slušný fit, i když intenzity prvních dvou difrakcí “podfitované” (dost častý 
efekt). Na to, jak jaká je to látka, celkem dobrý výsledek. 
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Velmi užitečnou kontrolu refinementu krystalových struktur představuje Bond-
valence analýza. Tato je v případě JANY implementovaná v rutině DIST. 
Rozlikneme pravým tlačítkem myši ikonu DIST a postupujeme následovně. 

 
Odklikněte d(max) volbu a vyplňte d(max) 3 a d(min) 0.5, po té spusťte “Define 
coefficients…” 
Definujte 1st atomic type jako Bi, 2nd jako O, rozklikněte “From file” a zadejte 
hodnotu 2.094 a 0.37, OK, a nahrajte do okna. Totéž udělejte i pro pár Si a O. 
Je dobré se koncentrovat, jaké zadáte valence prvků, často se dá rychle 
udělat chyba. 
 
OK a OK. 
Yes+start 
 
Open listing, dojeďte až nakonec, kde zjistíte následující 
 
************************* 
* List of bond valences * 
************************* 
 
 
Bond valence for : Bi      4.0(3) 
Bond valence for : Si      3.3(3) 
Bond valence for : O       2.1(2) 
 
Kde kyslík ok, Bi je diference 1.0 v.u. a Si také 1.0 v.u., což je hodně. 
 
Můžeme přemýšlet, co s tím. 
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Pohledem na data zkusme něco vymyslet. 
 
 
“Powder”, “Sample”, “Roughness” 
Type “Suorti 1” 
 
Nechte refinovat. Zjistíte, že se po chvilce dostáváme na Robs=2.15. 

 
Fit vypadá také již lépe: 

 
Důležité je, že všechny ADP jsou nezáporné. Zkusme provést BV analýzu 
získaných meziatomových vzdáleností. 
 
Bond valence for : Bi      3.2(3) 
Bond valence for : Si      4.4(4) 
Bond valence for : O       2.2(3) 
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Což je již o mnoho lepší 
Bi3+, Si4+, O2- 
 
Tak to by bylo. Ještě nám zbývají možnosti exportu dat, což si ukážeme v 
závěru. 
 
Good night. 
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