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Vypocty v programu
gaussian

Gaussian
http://www.gaussian.com/

Komercéni program urceny prevazné pro kvantoveé chemické vypocty. Instalovany
na klastru WOLF.
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Wl spousténivypoctu

Vypocty v programu gaussian provadime na vypocetnim klastru WOLF.

1) Aktivace modulu gaussian: . . L
pouze jednou v daném terminalu

$ module add gaussian:03.El
2) Pfimé spusténi vypoctu (NEPOUZIVAT v domovském adresari !!!1!):

$ g03 soubor

/ jméno vstupniho souboru bez pfipony .com

Po skonceni vypoctu bude v adresari novy soubor (soubor.log)
obsahujici vysledky vypoctu.
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Spousteni vypoctu, Il

3) Davkové spouéténi (PREFEROVANY ZPUSOB):

$ psubmit localhost@short soubor.com

AN

jméno vstupniho souboru v€etné pripony .com
skript ulohy se vytvori automaticky

vypocet spusti na lokalnim stroji ve fronté short

Nezapomen:
 kazdy vypocet musi byt spustén v samostatném adresari!!
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Optimalizace geometrie
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l Optimalizace geometrie,_

optimalizace geometrie

metoda
\%M:S Op NOSymm = neuvaZovat symetrii

komentar popisujici (p raz dl’ly rade k)
vypocet ——_
komentar multiplicita,
(prazdny rade 1=singlet
nabo’j

/////’znacka X

celkovy naboj

Y Z
systému (celé Cislo) acka x y 2
Y Z

znacka x

Znaéka jed notlivvch ooooooooooooooo

o kartézské souradnice atomu
atomu (prazdny radek)

soubor uklddame s priponou .com




l Opt. geometrie, ukazka _

kartézské souradnice atoml v Angstromech

ethan.com

# PM3 Opt Nosymm

Ethan

01

C -8.17932 3.14871 -0.03132
C -7.00267 2.20120 0.03204
H -7.90498 4.06824 -0.55607
H -8.51264 3.41431 0.97740
H -9.01757 2.68656 -0.56001
H -6.16234 2.66559 0.55546
H -6.67317 1.93085 -0.97667
H -7.27527 1.28418 0.56205
prazdny radek
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l Priprava vstupniho soubo

1)
2)
3)
4)
5)

Project 1: NEMESIS - Molecular Modelling Package

Projekt: Build Structure
Sestavime molekulu

File->Export Structure as -> Gaussian Input
Nastavime metodu a typ vypoctu, ulozime

Een B & 3 ty 4)) 8:55PM &

Provedeme optimalizaci pomoci molekulové mechaniky

tr Kulhanek it

Structures [E5] Build panel

Structures | Merge | Actions

Basic | General

& =

|
Name sID Ato C., T= =C=
P /
P Structure 1 1
[F= Cl- =
0= O- Pk
N=EENE Ay
& O Gaussian Input
- Title: Title | =
i Delete atom Makepond
| Calculation: | Geometry Optimization . Processors: |1
L Lt Break bond Deletepond
Theory: | PM3 Basis: Optimize
Ad charge: 0 Multiplicity: | 1
A Format: | Cartesian s O t- I- t .
P & Checkpoint @& Include PBC [ Include fragments p “ I la Izace geOI I le rle
1| #¥Chk=checkpoint.chk
# REM3 Opt NoSymm Geometry @

Title

1.562094

& savesetup [ Close onsave

| Reset | Save. | | Close |

HsTcacoer 15 2 @ [s]  selectaconnect atom (open valence) to attach a molecular fragment

jstance Angle Torsion

PM3
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Vysledny soubor

1) Otevrete vystupni soubor v textovém editoru:
S kwrite soubor.log &> /dev/null &

2) Projdéte souborem, pouvazujte nad vyznamem jednotlivych sekci:

Input orientation:

SCF Done: E(RPM3) = -0.289342988150E-01 A.U. after 8 cycles

Center Atomic Forces (Hartrees/Bohr)
ITtem Value Threshold Converged?
Maximum Force 0.000311 0.000450 YES
RMS Force 0.000068 0.000300 YES
Maximum Displacement 0.009047 0.001800 NO

RMS Displacement 0.004622 0.001200 NO

Optimization completed.
-—- Stationary point found.

Normal termination of Gaussian 09
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l Nacteni vystupniho soub

1) Projekt: Trajectory
2) File->Import Trajectory as -> Gaussian Geometry Optimization

Project 1: NEMESIS - Molecular Modelling Package FHen B & £ ty 4)) 9:01PM L Petrkulhanek £t

Trajectories [E5] Properties Manager 3]
Name Trajectory Al Mame Type Description ID
P Trajectory 1 Structure 1 "
-
Basic Play  Segments | Filters Referenced by
dVOJ kl I k sl Mame Snapshosts Type
1 ethan 6 Gaussian Geometry ¢
@ Gaussian Geometry tlmlzatlnn
] »
Number of trajectories: 1 Basic || Energy || Info 4
9 [+ e *
. L
Q‘H 3“ 5" > ID Energy [a.u.] Relative Energy [kcz
Trajectories | Structures 1 -0.028617175 0.00/ | pury ®
i 2 -0.028893932 -0.17
Active Profile [£3] 3 -0.028929498 .0.20 | ftion Distance Angle Torsion
Active profile: Profile 1 4 -0.028931879 -0.20
5 -0.028934299 -0.20
Profile objects 6 -0.028935040 -0.20
MName Ty
* Light 1 Light
B Background 1 Backgrc 1
& standard Model 1 Standar
Freezed Atoms 1 Freezed
*
= f
e 2P sla/le COHEBW oD ribéh optimalizace
_ P P
(= GDP S ERIS
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Optimalizace geometrie
alternativni postupy
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Priprava vstupniho soubor

Vstupni soubor pro vypocet miZzeme vytvorit pomoci programu Avogadro.
Prislusny nastroj naleznete v menu Extensions->Gaussian.

-~

Gaussian Input

Title:

Calculation: Processors:

Theory: Basis:

Charge: Multiplicity:

Output: Checkpoint:

Format: | Cartesian = | | Hide Preview |

# PM3 Opt NoSymm

Ethan

01

C 14871 -0.03132
C 2.20120 0.03204
H 4.06824 -0.55607

-8.51264  3.41431 0.97740
-9.01757  2.68656 -0.56001
-6.16234  2.66559  0.55546

ru¢né upravime P prem——— (Gl [ close |
podle typu vypoctu 7

vytvori vstupni soubor pro vypocet

Pokud je struktura vysledkem predchoziho vypoctu v programu gaussian, neméli
bychom tuto strukturu v programu Avogadro ménit (napr. optimalizovat geometrii)!
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l Optimalizace geometrie_

1) Aktivace modulu gmutil:

$ module add gmutil I pouze jednou v daném termindlu
2) Zobrazeni prubéhu optimalizace (energie):

$ extract-gopt-ene soubor.log
3) Prubéh optimalizace (vSechny geometrie):

$ extract-gopt-xyz soubor.log > soubor opt.xyz
4) Ziskani optimalizované geometrie (posledni):

$ extract-xyz-str soubor opt.xyz last > soubor last.xyz

Je vhodné podivat se na priibéh optimalizace, napft. v programu vmd , Avogadro, nebo
Nemesis.
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l Optimalizace geometrie_

Prtiibéh optimalizace (energie):

[kulhanek@wolf ethan]$ extract-gopt-ene soubor.log
# Coordinate:

# Step Energy [kcal/mol] Energy [au]

# _____________________________________________
1 0.000 -0.02865090601
2 -0.171 -0.028922822
3 -0.188 -0.028950914
4 -0.190 =0.02895393

relativni energie vici

cislo optimalizacniho
vychozi geometrii

kroku

absolutni energie v
Hartree

l

Energie optimalizované struktury, tedy geometrie obsazené v soubor_last.xyz, v Hartree.
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Vibracni analyza
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Vysledkem vibracni analyzy jsou normalni vibrace (linearné nezavislé pohyby
atom0 v molekule) odpovidajici zprazenym harmonickym oscilatorim (jedna se o
aproximaci). Vibracni analyzu lze vyuzit k predpovédi absorpcnich spekter v
oblasti infraCerveného zareni (neni pfiliS presné) nebo k wurcCeni typu
stacionarniho bodu na plose potencialni energie. Lze tak od sebe odlisit
optimalni strukturu (vSechny frekvence vibraci jsou kladné) od tranzitniho stavu
(prave jedna frekvence musi byt imaginarni).

Vibra¢ni analyza se provadi pro geometrii, ktera byla

optimalizovana stejnou metodou,

jaka bude pouzita pro vibracni analyzu. V opa¢ném pripadé budou spoctené
frekvence zcela chybné.




lVibraEnl’ analyza, vstup _
/frekvenénl' analyza

# PM3 FREQ NoSymm
(prazdny radek)
komentar

(prazdny radek)

optimalizovana HabOj 1
geometrie 7nacka x YV Z

\\\\ znacka x y z

znacka x y z

(prazdny radek)

soubor uklddame s priponou .com
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l Priprava vstupniho soubo

1) Optimalizaovana geometrie
2) File->Export Structure as -> Gaussian Input
3) Nastavime metodu a typ vypoctu, ulozime

Frequencies

Project 1: NEMESIS - Molecular Modelling Package Een B £ T3 «) 9:48PM X PetrKulhanek %%
Trajectories = Properties Manager &

Name Trajectory Al
P Trajectory 1 Skructure 1

Description D

x

PM3

Basic Play | Segments | Filters Referenced b

sl Name Snapshosts
1 ethan 6 Gaussian Geometry ¢

@& 0 Gaussian Input

Title: Title

| Calculation: | Freguencies - ssors: | 1 B F
Numberf Theory:  [PM3 2| / Basks k Energy | Info LD
ch E 0 i % Multiplicity: | 1 : q 3 f
| arge: = uHIplcity: Energy [a.u.] Relative Energy [kez s
Trajectorl Format: | Cartesian | -0.028617175 0.00| | etry =
. 1 — -0.028893932 -0.17
Active Pro| [& Checkpoint [ Include PBC [ Include fragments -0.028925498 .0.20 ltion Distance Angle Torsion
Active pr¢ | $Chk=checkpoint.chk - -0.028931879 -0.20
$ RPM3 Freq NoSymm -0.028934299 -0.20
Proflle: -0.028935040 -0.20
Title
* Lig
. Bar “ _l - .
& st ¢ -0 0.2
Fre ° Y e
H -0 -0.6
H C _: . E I d Vé L I L ’ L]
c o 1.1 Posledni (optlma |zovana) geometrle
H 1. 0.9

| & Save setup [ Close on save b
[ | B — r
|| Reset | Save || Close |
x 6 /| 8 ) L IR

s GDP S ERs
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ll Vysledny soubor

1) Otevrete vystupni soubor v textovém editoru:

$ kwrite soubor.log &> /dev/null &

2) Projdéte souborem, pouvazujte nad vyznamem jednotlivych sekci:

Input orientation:
SCF Done: E(RPM3) = -0.289350395641E-01 A.U. after 9 cycles....

Harmonic frequencies (cm**-1), IR intensities (KM/Mole), Raman scattering
activities (A**4/AMU), depolarization ratios for plane and unpolarized
incident light, reduced masses (AMU), force constants (mDyne/A),

and normal coordinates:

1 2 3
A A A
Frequencies -- 224.6457 878.1828 878.1936....
- Thermochemistry - _, http://gaussian.com/g_whitepap/thermo.htm
Zero-point vibrational energy 194420.2 (Joules/Mg
Item Value Threshold Converged?
Maximum Force 0.000005 0.000450 H XAt v D4
o 0 000005 0 000300 Vibracni analyzu Ize provadet pouze na
Maximum Displacement 0.000091 0.001800 Stac|ona'rnl'ch bodech
RMS Displacement 0.000049 0.001200

(optimalizovanych geometriich).

Normal termination of Gaussian 09 at Sun Mar 10 20:28
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l Nacteni vystupniho soub

1) Projekt: Trajectory
2) File->Import Trajectory as -> Gaussian Vibrations

Project 1: NEMESIS - Molecular Modelling Package EHen B £ 13 «) 10:08PM XL PetrKulhanek %
Trajectories = Properties Manager =
Name Trajectory At X Name Type Description ID

P Trajectory 1 Struckture 1

A 4

Basic Play Segments | Filters Referenced by

Sl Name Snapshosts Type
o . 1 ethan_freq 180 Gaussian Vibratic
dvojklik dvojklik

L

@ Gaussian Vibrations

Basic | Vibrations | Setup

— ) . ¥ Frequency IRIntensity  Scc -
Number of trajectories: 1 1 224.6 0.0 L
? : : [+ = *
‘5—. q,pn e 5 I , . b 2 878.2 0.0 4
Trajectories | Structures ZVO “ I le VI ra ( 3 878.2 0.0 =
4 1120.0 0.0
Active Profile ® 5 1120.0 0.0 stance Angle Torsion
Active profile: Profile 1 h 6 1378 0.0
e 7 1359.3 0.0
rofile objects
) 8 1408.2 0.0
Name Ty ] 9 1408.2 0.0
* Light1 Light 1 S T An -

Il Background 1 Backgre
& Standard Model 1 Standar

NumN§er of vibrations: 24
Freezed Atoms 1 Freezed

ActiveYibrations: 0

| Activite imaginary | | Deactivate all |

— spustime animaci

? 3 1]/ [0 ]| O m
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Vibracni analyza
alternativni postupy
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Vibracni analyza, vystup -

Do programu Avogadro nacteme soubor.log, obsahujici vysledky vibracni analyzy. Souhrn
frekvenci jednotlivych normalnich vibraci najdeme v menu Extensions->Vibrations.

Avogadro EHcs 2 Ty <) 12222PM 1%
Ll & K D § W& Tool Settings... | Display Settings...

Navigate Settings @ ®

View 1

& Display visual cues

@ Molecular Vibrations 3

Frequency (cm~7) Intensity (km/mol)

223.7 0.0

877.8 1.5
878.0 1.5
1,119.8 0.0

,119.9

0 N O AW -

Options

Scale:

Display force vectors

Animation speed set by frequency

Close

Start,ﬁnimat'o\n Export...
Messages

vizualizace vibraci frekvence vibraci

_ a molekulové modelovani | - cviceni




l Vibracni analyza, V\'/stup_

Molekel
http://molekel.cscs.ch/wiki/pmwiki.php

Program pro vizualizaci molekularnich struktur.

1) Aktivace modulu molekel:
$ module add molekel

2) Otevreni programu molekel:
S molekel

3) Nacist do programu soubor soubor.log:
4) Animation->Per molecule settings ...
Animation (Tab) - Animation mode - Vibration

Vibration (Tab) = zvolit danou vibraci

4) Animation->Start animation
http://www.youtube.com/watch?v=Aan97dvvVgk
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l Cviceni

1. Namodelujte molekulu formaldehydu. Najdéte optimalni geometrii. K vypoctu energie
pouzijte semiempirickou kvantové chemickou metodu PM3. Jaka je délka vazby C=07

2. Provedte vibracni analyzu na optimalizované geometrii. Jaka je charakteristicka vibrace
vazby C=0°7

3. Jaky je vztah normalnich vibraci vicéi vlastnim Cislim a vektoriim Hessianu.

IRRBBIBBEAC0VE chemie a molekulové modelovani | - cvident



