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Dávkové systémy 
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Dávkové zpracovaní 

Dávkové zpracování je vykonávání série programů (tzv. dávek) na počítači bez účasti 
uživatele. Dávky jsou připraveny předem, takže mohou být zpracovány předány bez účasti 
uživatele. Všechna vstupní data jsou předem připravena v souborech (skriptech) nebo 
zadána pomocí parametrů na příkazovém řádku. Dávkové zpracování je opakem 
interaktivního zpracování, kdy uživatel až teprve za běhu programu poskytuje požadované 
vstupy. 

Výhody dávkového zpracování 
    sdílení zdrojů počítače mezi mnoha uživateli a programy 
    odložení zpracování dávek do doby, kdy je počítač méně vytížen 
    odstranění prodlev způsobeným čekáním na vstup od uživatele 
    maximalizace využití počítače zlepšuje využití investic (zejména u dražších počítačů) 

zdroj: www.wikipedia.cz, upraveno 
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Nástroje pro dávkové spouštění 

 OpenPBS 
 http://www.mcs.anl.gov/research/projects/openpbs/ 
 

 PBSPro 
http://www.pbsworks.com 
 

 Oracle Grid Engine 
http://www.oracle.com/us/products/tools/oracle-grid-engine-075549.html 
 

 Open Grid Scheduler 
http://gridscheduler.sourceforge.net/ 
 

 Torque 
http://www.adaptivecomputing.com/products/open-source/torque/ 

 

open source 

je použit jako dávkový systém v MetaCentrum VO, na klastrech SOKAR a WOLF 
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Infinity 
https://lcc.ncbr.muni.cz/whitezone/development/infinity/ 
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Přehled příkazů 

Správa software: 
• site aktivace logických výpočetních zdrojů 
• module  aktivace/deaktivace software 
 

Správa úloh: 
• pqueues přehled front z dávkového systému dostupných uživateli 
• pnodes  přehled výpočetních uzlů dostupných uživateli 
• pqstat přehled všech úloh zadaných do dávkového systému 
• pjobs přehled úloh uživatele zadaných do dávkového systému 
• psubmit  zadání úlohy do dávkového systému 
• pinfo informace o úloze 
• pgo  přihlásí uživatele na výpočetní uzel, kde se úloha vykonává 
• paliases definovaní aliasů 
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Úloha 

Úloha musí splňovat následující podmínky: 

• každá úloha se spouští v samostatném adresáři 

• všechny vstupní data úlohy musí být v adresáři úlohy 

• adresáře úloh nesmí být do sebe zanořené 

• průběh úlohy je řízen skriptem nebo vstupním souborem (u automaticky 
detekovaných úloh) 

• skript úlohy musí být v bashi 

•  ve skriptu úlohy se nesmí používat absolutní cesty, všechny cesty musí být uvedeny 
relativně k adresáři úlohy 

/home/kulhanek 

job1 

job2 

/home/kulhanek 

job1 

job2 
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Spuštění úlohy 

Úlohu spouštíme v adresáři úlohy příkazem psubmit. 

psubmit destination job [resources] [syncmode] 

destination (kam) je buď: 
• název_fronty 
• název_uzlu@název_fronty 

 
job je buď: 

• název skriptu úlohy 
• název vstupního souboru pro automaticky rozpoznávané úlohy 

 
resources jsou požadované zdroje pro úlohu, pokud není uvedeno, požaduje se běh na 1 

CPU 
 
syncmode určuje způsob kopírování dat mezi adresářem úlohy a výpočetním uzlem, 

výchozím módem je "sync" 
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Monitorování běhu úlohy 

K monitorování průběhu úlohy lze použít příkaz pinfo, který se spouští buď v adresáři úlohy 
nebo v pracovním adresáři na výpočetním uzlu. Dalšími možnostmi jsou příkazy pjobs a 
pqstat. 
 
Pokud je úloha spuštěna na výpočetním uzlu, je možné použít příkaz pgo, který se naloguje 
na výpočetní uzel a změní aktuální adresář do pracovního adresáře úlohy. 
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Servisní soubory 

V adresáři úlohy vznikají při zadání úlohy do dávkového systému a dále v průběhu života 
úlohy a po jejím ukončení servisní soubory. Jejich význam je následující: 

•  *.info kontrolní soubor s informacemi o průběhu úlohy 

•  *.infex vlastní skript (wrapper), který se spouští dávkovým systémem 

•  *.infout standardní výstup z běhu *.infex skriptu, nutno analyzovat při  
  nestandardním ukončení úlohy 

•  *.nodes seznam uzlů vyhrazených pro úlohu 

•  *.gpus seznam GPU karet vyhrazenych pro úlohu 

•  *.key unikátní identifikátor úlohy 

•  *.stdout standardní výstup z běhu skriptu úlohy 
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Cvičení I 

1. Vytvořte textový soubor obsahující následující text. Soubor nazvěte get_hostname a 
uložte jej do samostatného adresáře uloha01. 
 
 
 

2. Nastavte souboru práva pro spuštění: 
 
 

3. Vytvořený skript spusťte v terminálu. Co se stane? 
 
 

4. Skript zadejte ke spuštení do dávkového systém. K zadání úlohy použijte frontu short. 
 
 

5. Průběh úlohy monitorujte příkazem pinfo. 
 

6. Na kterém výpočetním uzlu se úloha spustila? Analyzujte obsah souboru 
get_hostname.stdout v textovém editoru. 

#!/bin/bash 

hostname 

$ chmod u+x get_hostname 

$ ./get_hostname 

$ psubmit short get_hostname 
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Cvičení II 

1. Vytvořte textový soubor obsahující následující text. Soubor nazvěte long_job a uložte 
jej do samostatného adresáře uloha02. Co dělá příkaz sleep (použijte manuálové 
stránky)? 
 
 
 
 

2. Skript zadejte ke spuštení do dávkového systém. K zadání úlohy použijte frontu short. 
 
 

3. Průběh úlohy monitorujte příkazem pinfo. Úlohy ostatních uživatelů příkazem pqstat. 
Obsazení jednotlivých výpočetních uzlů pak příkazem pnodes. 

#!/bin/bash 

hostname 

sleep 240 

$ psubmit short long_job 
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Výpočty v programu 
gaussian 

Gaussian 
  http://www.gaussian.com/ 
 Komerční program  určený převážně pro kvantově chemické výpočty. Instalovaný 

na klastru WOLF. 
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Spouštění výpočtu 

1) Aktivace modulu gaussian: 
 
 $ module add gaussian:03.E1 

 
2) Přímé spuštění výpočtu (POUŽÍVAT JEN PRO KRATKÉ VÝPOČTY): 
 
 $ g03 soubor 

pouze jednou v daném terminálu 

jméno vstupního souboru bez přípony .com 

Po skončení výpočtu bude v adresáři nový soubor (soubor.log) 
obsahující výsledky výpočtu. 

Výpočty v programu gaussian provádíme na výpočetním klastru WOLF. 
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Spouštění výpočtu, II 
3) Dávkové spouštění (PREFEROVANÝ ZPŮSOB): 
 

 $ psubmit localhost@short soubor.com 

jméno vstupního souboru včetně přípony .com 
skript úlohy se vytvoří automaticky 

výpočet spustí na lokálním stroji ve frontě short 

Nezapomeň: 
• každý výpočet musí být spuštěn v samostatném adresáři!! 
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Optimalizace geometrie 
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Optimalizace geometrie, vstup 

# PM3 Opt NoSymm 

(prazdny radek) 

komentar 

(prazdny radek) 

naboj 1 

znacka x y z 

znacka x y z 

znacka x y z 

............... 

(prazdny radek) 

optimalizace geometrie 

neuvažovat symetrii 

celkový náboj 
systému 

multiplicita, 
1=singlet 

metoda 

komentář popisující 
výpočet 

značka jednotlivých 
 atomů 

soubor ukládáme s příponou .com 

kartézské souřadnice atomů 
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Opt. geometrie, ukázka vstupu 

# PM3 Opt Nosymm 

 

Ethan 

 

0 1 

C         -8.17932        3.14871       -0.03132 

C         -7.00267        2.20120        0.03204 

H         -7.90498        4.06824       -0.55607 

H         -8.51264        3.41431        0.97740 

H         -9.01757        2.68656       -0.56001 

H         -6.16234        2.66559        0.55546 

H         -6.67317        1.93085       -0.97667 

H         -7.27527        1.28418        0.56205 

 

prázdný řádek 

ethan.com kartézské souřadnice atomů v  Ångströmech 
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Příprava vstupního souboru, NEMESIS 

1) Projekt: Build Structure 
2) Sestavíme molekulu 
3) Provedeme optimalizaci pomocí molekulové mechaniky  
4) File->Export Structure as -> Gaussian Input 
5) Nastavíme metodu a typ výpočtu, uložíme 

PM3 

Optimalizace geometrie 
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Výsledný soubor 

1) Otevřete výstupní soubor v textovém editoru: 

  $ kwrite soubor.log &> /dev/null & 

2) Projděte souborem, pouvažujte nad významem jednotlivých sekcí: 

Input orientation:  

.... 

 SCF Done:  E(RPM3) = -0.289342988150E-01 A.U. after    8 cycles 

.... 

 Center     Atomic                   Forces (Hartrees/Bohr) 

.... 

 Item               Value     Threshold  Converged? 

 Maximum Force            0.000311     0.000450     YES 

 RMS     Force            0.000068     0.000300     YES 

 Maximum Displacement     0.009047     0.001800     NO  

 RMS     Displacement     0.004622     0.001200     NO  

.... 

  Optimization completed. 

    -- Stationary point found. 

..... 

 Normal termination of Gaussian 09 
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Načtení výstupního souboru, NEMESIS 

1) Projekt: Trajectory 
2) File->Import Trajectory as -> Gaussian Geometry Optimization 

dvojklik 

dvojklik 

průběh optimalizace 



TSM – Modelování molekulárních struktur -22- 

Optimalizace geometrie 
alternativní postupy 
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Příprava vstupního souboru, Avogadro 

Vstupní soubor pro výpočet můžeme vytvořit pomocí programu Avogadro. 
Příslušný nástroj naleznete v menu Extensions->Gaussian.  

ručně upravíme  
podle typu výpočtu 

vytvoří vstupní soubor pro výpočet 

Pokud je struktura výsledkem předchozího výpočtu v programu gaussian, neměli 
bychom tuto strukturu v programu Avogadro měnit (např. optimalizovat geometrii)! 
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Optimalizace geometrie, výsledek 
1) Aktivace modulu qmutil: 
 
 $ module add qmutil 

 
2) Zobrazení průběhu optimalizace (energie): 
 
 $ extract-gopt-ene soubor.log 

 
3) Průběh optimalizace (všechny geometrie): 
 

 $ extract-gopt-xyz soubor.log > soubor_opt.xyz 

 
4) Získání optimalizované geometrie (poslední): 
 

 $ extract-xyz-str soubor_opt.xyz last > soubor_last.xyz 

pouze jednou v daném terminálu 

Je vhodné podívat se na průběh optimalizace, např. v programu vmd , Avogadro, nebo 
Nemesis. 
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Optimalizace geometrie, výsledek 
Průběh optimalizace (energie): 

[kulhanek@wolf ethan]$ extract-gopt-ene soubor.log  

# Coordinate:  

# Step      Energy [kcal/mol]  Energy [au]        

# --------- ------------------ ------------------ 

          1              0.000       -0.028650961 

          2             -0.171       -0.028922822 

          3             -0.188       -0.028950914 

          4             -0.190       -0.028953934 

 

číslo optimalizačního 
kroku 

relativní energie vůči 
výchozí geometrii 

Energie optimalizované struktury, tedy geometrie obsažené v soubor_last.xyz, v Hartree. 

absolutní energie v 
Hartree 
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Vibrační analýza 
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Výsledkem vibrační analýzy jsou normální vibrace (lineárně nezávislé pohyby 
atomů v molekule) odpovídající spřaženým harmonickým oscilátorům (jedná se o 
aproximaci). Vibrační analýzu lze využít k předpovědi absorpčních spekter v 
oblasti infračerveného záření (není příliš přesné) nebo k určení typu 
stacionárního bodu na ploše potenciální energie.  Lze tak od sebe odlišit 
optimální strukturu (všechny frekvence vibrací jsou kladné) od tranzitního stavu 
(právě jedna frekvence musí být imaginární). 

Vibrační analýza se provádí pro geometrii, která byla  

optimalizována stejnou metodou,  

jaká bude použita pro vibrační analýzu. V opačném případě budou spočtené 
frekvence zcela chybné. 
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Vibrační analýza, vstup 

# PM3 FREQ NoSymm 

(prazdny radek) 

komentar 

(prazdny radek) 

naboj 1 

znacka x y z 

znacka x y z 

znacka x y z 

............... 

(prazdny radek) 

frekvenční  analýza 

soubor ukládáme s příponou .com 

optimalizovaná  
geometrie 
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Příprava vstupního souboru, NEMESIS 

1) Optimalizaovaná geometrie 
2) File->Export Structure as -> Gaussian Input 
3) Nastavíme metodu a typ výpočtu, uložíme 

PM3 

Frequencies 

Poslední (optimalizovaná) geometrie 
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Výsledný soubor 

1) Otevřete výstupní soubor v textovém editoru: 

  $ kwrite soubor.log &> /dev/null & 

2) Projděte souborem, pouvažujte nad významem jednotlivých sekcí: 

Input orientation:  

.... 

 SCF Done:  E(RPM3) = -0.289350395641E-01 A.U. after    9 cycles.... 

.... 

 Harmonic frequencies (cm**-1), IR intensities (KM/Mole), Raman scattering 

 activities (A**4/AMU), depolarization ratios for plane and unpolarized 

 incident light, reduced masses (AMU), force constants (mDyne/A), 

 and normal coordinates: 

                     1                      2                      3 

                     A                      A                      A 

 Frequencies --   224.6457               878.1828               878.1936.... 

..... 

 ------------------- 

 - Thermochemistry - 

 ------------------- 

... 

Zero-point vibrational energy     194420.2 (Joules/Mol) 

... 

 Item               Value     Threshold  Converged? 

 Maximum Force            0.000005     0.000450     YES 

 RMS     Force            0.000002     0.000300     YES 

 Maximum Displacement     0.000091     0.001800     YES 

 RMS     Displacement     0.000049     0.001200     YES 

... 

Normal termination of Gaussian 09 at Sun Mar 10 20:23:36 2013. 

http://gaussian.com/g_whitepap/thermo.htm 

Vibrační analýzu lze provádět pouze na 
stacionárních bodech 
(optimalizovaných geometriích). 
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Načtení výstupního souboru, NEMESIS 

1) Projekt: Trajectory 
2) File->Import Trajectory as -> Gaussian Vibrations 

dvojklik dvojklik 

zvolíme vibraci 

spustíme animaci 
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Vibrační analýza 
alternativní postupy 



TSM – Modelování molekulárních struktur -33- 

Vibrační analýza, výstup - Avogadro 

Do programu Avogadro načteme soubor.log, obsahující výsledky vibrační analýzy. Souhrn 
frekvencí jednotlivých normálních vibrací najdeme v menu Extensions->Vibrations.  

frekvence vibrací vizualizace vibrací 
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Vibrační analýza, výstup - Molekel 

http://www.youtube.com/watch?v=Aan97dvvVqk 

1) Aktivace modulu molekel: 
 $ module add molekel 

 
2) Otevření programu molekel: 
 $ molekel 

 
3) Načíst do programu soubor soubor.log: 
 
4) Animation->Per molecule settings … 

•Animation (Tab) → Animation mode → Vibration 
•Vibration (Tab) → zvolit danou vibraci 

 
4) Animation->Start animation 

Molekel 
 http://molekel.cscs.ch/wiki/pmwiki.php 

 Program pro vizualizaci molekulárních struktur. 
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Cvičení 

1. Namodelujte molekulu formaldehydu. Najděte optimální geometrii. K výpočtu energie 
použijte semiempirickou kvantově chemickou metodu PM3. Jaká je délka vazby C=O? 
 

2. Proveďte vibrační  analýzu na optimalizované geometrii. Jaká je charakteristická vibrace 
vazby C=O? 
 


