
Využití Maple v matematického modelování  
V této výukové jednotce shrneme základy využití Maple v matematického modelování biologických 
systémů, aby si studenti uvědomili jak jej výhodně využívat v matematickém modelování a pochopili, 
proč využívat vlastností Maple a jeho webového systému MapleCloud a palet Component a 
MapleCloud v zápisnících a dokumentech Maple k nalezení, modelování a simulaci řešení chování 
zkoumaného systému. Soustředíme se na pochopení webového rozhraní systému MapleCloud a 
interaktivního dynamického modelování s využitím komponent z palety Component a MapleCloud s 
možností napojení na systém MapleCloud, které umožňující každému uživateli se zaregistrovat na 
webu na adrese http://maplecloud.maplesoft.com/. 

Jakýkoli Maple dokument v MapleCloud umožňuje využívat interaktivní komponenty z palet 
Components prostřednictvím grafického rozhraní (GUI – Graphic User Interface), jako jsou grafy, 
posuvníky, číselníky, matematická vstupní a výstupní pole, která lze interaktivně využívat a nejen 
prohlížet, a to i těmi uživateli, kteří nemají Maple. Každý uživatel, který má instalován Maple může své 
matematické aplikace (zápisníky a dokumenty) v Maple použít pomocí systému MapleCloud a podělit 
se o ně s kýmkoliv, kdo je zaregistrovaný v systému MapleCloud. Takto lze řešit a zkoumat stovky 
nejrůznějších řešených úloh v Maple, provádět výpočty a simulace a vizualizovat výsledky řešení v 2-D, 
3-D grafech a animaci. 

Výstupy v této výukové jednotce budou pro studenty následující: 

1. seznámí se základními předpoklady využití Maple a webového systému MapleCloud a včetně 
možností interaktivního využití položek Component a MapleCloud z PALETY Maple; 

2. dokáží popsat základní způsoby matematického modelováni s využitím Maple a MapleCloud a 
ukázat je na příkladech; 

3. seznámí se s možnostmi řešení modelu problému, simulace jeho řešení a jeho vizualizace s 
využitím Maple, palet Component a MapleCloud a systému MapleCloud; 

4. umí popsat jak řešit model, případně je modifikovat v Maple a MapleCloud. 

Slovo úvodem 
Systém Maple je výkonný program vhodný k řešení komplexních matematických problémů. Patří do 
skupiny systémů počítačové algebry, umožňuje symbolické i numerické výpočty a slouží především k 
vytvoření speciálních dokumentů, prezentací, interaktivních výpočetních modulů v prostředí Maple. 
Systém Maple též obsahuje komponenty podporující výuku matematiky. 

Výrobcem systému je kanadská společnost Maplesoft Inc., jejíž webové stránky (www.maplesoft.com) 
poskytují široké informace o systému a jeho dalších příbuzných programech jako je MapleSim 
(www.maplesoft.com/products/Maplesim/), Maple T.A. (www.maplesoft.com/products/Mapleta/), 
Möbius Project (www.maplesoft.com/products/mobiusproject/), Maplesoft Engineering Solutions 
services (www.maplesoft.com/products/proservices/) a mnoho dalších nástrojů a programů. Webové 
stránky Maplesoftu mimo jiné obsahují tzv. Aplikační centrum (www.maplesoft.com/applications/) z 
nějž si může každý zaregistrovaný uživatel stáhnout ukázkové programy demonstrující použití systému 
Maple při řešení mnoha různých matematických i technických problémů. Na webových stránkách je i 
tzv. Studentské centrum (www.maplesoft.com/studentcenter/), kde si zaregistrovaný student může 
stáhnout mnoho studijních materiálů a dále je zde tzv. Učitelské centrum 
(www.maplesoft.com/TeacherResource/), kde jsou videa výukových příklady a ke stažení dokumenty, 
jejichž cílem je pomáhat učitelům naučit studenty matematické koncepty rychleji a s větším 
porozuměním. Zde uvedené příklady zahrnují např. diferenciální a integrální počet jedné a více 
proměnných, řešení soustav lineárních, diferenčních, diferenciálních a integrálních rovnic, úlohy 



lineární algebry a vektorového počtu.  

Maple obsahuje více než tisíc symbolů, pomocí nichž můžeme tvořit matematické výrazy a 
typograficky kvalitní text. Patří mezi ně písmena a číslice, jimiž vytváříme jména (posloupnost znaků 
začínající písmenem, za kterým může následovat kombinace písmen, čísel a vybraných symbolů), 
reálná čísla (celá, racionální, iracionální, s desetinou tečkou nebo v notaci pohyblivé řádové čárky), 
komplexní čísla, aritmetické,  booleovské a jiné operátory (+, –, !, /, *, ∫, lim, ...), konstanty (π, e, ...), 
imaginární jednotku, ∞ (nekonečno), matematické funkce (cos(x), sin(x), ...) a proměnné 
(pojmenované jménem ...). Velkou předností systému Maple je jeho schopnost jak symbolických 
matematických výpočtů, tak i numerických výpočtů.  

V následujícím textu se budeme stručně zabývat dosud poslední verzí Maple 2015, podrobnější popis 
funkcí Maple je uveden v knize Úvod do matematického modelování s využitím Maple1 na Elportálu E-
learning na Masarykově univerzitě [1].  

Spuštění Maple 
Se systémem Maple je možné pracovat několika různými způsoby, které volíme při jeho spuštění ze 
startovacího menu počítače nebo kliknutím na příslušnou ikonu na ploše. Grafické uživatelské 
prostředí Maple se spustí ze startovacího menu počítače výběrem položky Programy > Maple 2015 
> Maple 2015 nebo kliknutím na ikonu Maple 2015 na ploše, které otevře startovací výpočetní 
prostředí Maple, obr. 3.1, které budeme nazývat zápisník. 

 
Obrázek 3.1: Startovací výpočetní prostředí Maple 

Uživatel si může zvolit v zápisníku výpočetní režim Maple; jednak Document Mode (New Document), 
jednak Worksheet Mode (New Worksheet), nebo nápovědu pro začátečníky v Maple (Getting 
Started), případně komplexní systém nápovědy (Help). Zkušenější uživatelé si mohou zvolit již oblast 
konkrétních aplikací (např. Calculus, Curve Fitting atd.) nebo novinek v Maple 2015 (What’s New?).  

Menu zápisníku Maple má tři vodorovné lišty: HLAVNÍ MENU (zcela nahoře), NÁSTROJOVOU LIŠTU 
(pod hlavním menu) a KONTEXTOVOU LIŠTU (pod nástrojovou lištou), obr. 3.2. Zápisník Maple dále 

                                                             
1 http://is.muni.cz/elportal/?id=930553 



obsahuje PALETY (svislý blok na levé straně2), vlastní pracovní pole – DOKUMENT, do nějž zadáváme 
příkazy, texty, provádíme výpočtové a grafické operace, a STAVOVOU LIŠTU (zcela dole), kde je vidět 
kolik vnitřní paměti zabírá program Maple a čas výpočtu v zápisníku. Vlastní pracovní pole je možné 
zobrazit přes celou obrazovku skrytím palet a všech lišt (kromě hlavního menu) kliknutím na příslušné 
položky v záložce View hlavního menu. 

 
Obrázek 3.2: Výpočetní prostředí Maple 

KONTEXTOVÁ LIŠTA nabízí celkem pět režimů Text, Math (matematika, obr. 3.2) Drawing (kreslení, 
obr. 3.4), Plot (kreslení, obr. 3.5, 3.6) a Animation (animaci, obr. 3.7). Každý z nich má jinou funkci, 
která napovídá jeho název, například v režimu Text je uživatel schopen přizpůsobit styl písma, jeho 
velikost (obr. 3.3.):  

 

Obrázek 3.3 Menu v režimu Text 

V režimu Drawing (obr. 3.4) malovat schémata a obrázky: 

 
Obrázek 3.4 Menu v režimu Drawing 

nebo zatímco režimu Plot je možné zobrazovat a modifikovat 2-D a 3-D grafy (viz obr. 3.5, 3.6):  

 
Obrázek 3.5 Menu v režimu Plot pro 2-D grafy 

 
Obrázek 3.6 Menu v režimu Plot pro 3-D grafy 

                                                             
2 Palety se automaticky zobrazují v levém bloku. Prostředí systému nabízí blok pro palety i po pravé straně 
obrazovky (automaticky zavřený), kam je možné některé (ale i všechny) přesunout. 



V režimu Animation je možné modifikovat animaci v grafech (viz obr. 3.7): 

 
Obrázek 3.7 Menu v režimu Animation 

Podrobnější popis výše uvedených režimů KONTEXTOVÉ LIŠTY lze nalézt v systému nápovědy Maple, 
(Getting Started→Menus→Toolbar Menu). 

Výpočetní režimy Maple 
Zápisník Maple má dva výpočetní režimy: Worksheet Mode a Document Mode, které je možno volit 
pomocí záložky File v HLAVNÍM MENU, viz obr. 3.2.  

V prostředí Worksheet Mode je každý příkaz Maple uvozen symbolem [> a musí být ukončen 
dvojtečkou (výsledek se nezobrazí) nebo středníkem (výsledek se zobrazí na dalším řádku uprostřed). 
Otevírá se v hlavním menu zvolením File > New > Worksheet Mode.  

Režim Document Mode poskytuje přehlednější zápis příkazů a matematických vzorců bez 
„přebytečných“˙ symbolů. Při otevření nového souboru z NÁSTROJOVÉ LIŠTY je automaticky spuštěn 
právě tento režim, jinak je možné jej též otevřít z hlavního menu v položce File > New nebo 
současným stisknutím kláves Ctrl a N. 

Obvykle je výpočetní prostředí zápisníku Maple nastaveno do jednoho režimu, který je možné  zvolit 
při otevírání nového souboru v hlavním menu (File > New > ...). Existuje však i možnost přepínat mezi 
režimy v rámci jednoho prostředí Maple, kdy je část vytvořena v jednom režimu, část v jiném. Z režimu 
Document Mode se přepne do režimu Worksheet Mode kliknutím na ikonku [> v NÁSTROJOVÉ LIŠTĚ, 
viz obr. 3.2. Naopak z režimu Worksheet Mode se do režimu Document Mode přepne výběrem 
položky v HLAVNÍM MENU (Format > Create Document Block). 

Pro rozlišení příkazů a obyčejného textu v režimu Document Mode slouží KONTEXTOVÁ LIŠTA 
zápisníku, viz obr. 3.2, kde máme na výběr režimy Text (obr. 3.3) a Math (obr. 3.2). Režim Math 
odpovídá příkazům Maple v režimu Worksheet Mode (po stisku klávesy Enter dojde k jejich 
vyhodnocení), v režimu Text píšeme texty dokumentu podobně jako např. v textovém editoru Word 
(po stisku klávesy Enter přejdeme na nový řádek bez jakéhokoli vyhodnocení).  

Volit režim zápisu v zápisníku Maple můžeme buď kliknutím myši (v KONTEXTOVÉ LIŠTĚ nad 
dokumentem jsou uvedeny názvy představující jednotlivé možnosti, viz obr. 3.2) nebo výběrem 
položky v HLAVNÍM MENU (Edit > Switch to Text Mode pokud jsme v režimu Math nebo Edit > 
Switch to Math Mode když jsme v režimu Text). Totéž lze rychleji provést stisknutím klávesy F5. 

V režimu Worksheet Mode lze pro text i pro příkazy v zápisníku Maple použít oba druhy zápisu. Pro 
psaní textu je nutné kliknout na ikonku T v NÁSTROJOVÉ LIŠTĚ nebo zvolit položku v HLAVNÍM MENU 
(Insert > Text). Podobně pro zápis příkazů Maple v zápisníku je nutné kliknout na ikonku [> v 
NÁSTROJOVÉ LIŠTĚ nebo zvolit položku v HLAVNÍM MENU (Insert > Maple Input).  

Při otevření nového souboru v kontextovém menu je výpočetní prostředí Maple automaticky 
nastaveno na psaní příkazů v režimu Document Mode a Math. 

K příkazům Maple máme možnost zapisovat komentáře, a to uvedením symbolu mřížky (#) před text, 
který má být komentářem. 

Operace se zápisníky (dokumenty) Maple 
Již víme, jak spustit Maple a jak zvolit výpočetní režim v zápisníku, který chceme používat. Otevřít již 
vytvořený zápisník můžeme z HLAVNÍHO MENU (File > Open ...) nebo jeho spuštěním rovnou z 
operačního systému (případně nějakého souborového manažeru).  



Když chceme vytvořený Maplovský program uložit, zvolíme položku File > Save (resp. File > Save 
As) v HLAVNÍM MENU. Programy prostředí standardního zápisníku (Standard Worksheet) mají 
příponu .mw, programy prostředí klasického zápisníku (Classic Worksheet) mají příponu .mws. 
Klasickými zápisníky se nebudeme pro jednoduchost zabývat. Maple umožňuje otevřít oba typy 
souborů. 

Maple poskytuje také možnost exportovat Maplovský program (zápisník) jako soubor s formátem 
jiného typu. Podporovány jsou typy: HTML (.html,.htm), PDF (.pdf) , LaTeX (.tex), Maple Input (.mpl), 
Maplet (.maplet), Maple Text (.txt), Plain Text (.txt), Maple T.A. (.zip) a Rich Text Format (.rtf). Pro 
export programu vybereme v HLAVNÍM MENU (File > Export As …) z vyskakovacího okna knihovnu, 
kam chceme zápisník uložit a příslušný formát. 

Maplovský zápisník lze uložit také do prostředí MapleCloud na serveru v Maplesoftu (Googlu), když 
zvolíme v HLAVNÍM MENU (File > Save to Cloud). K tomu je však třeba, aby se uživatel nejprve stal 
členem komunity uživatelů produktů Maplesoftu a zaregistroval se na webovské adrese 
(www.maplesoft.com/Members/sign_up_form.aspx) a tím získal úplný přístup k sdílení dokumentů 
Maple, zápisníků Maple a aplikací s ostatními uživateli na Internetu i v případě, že nemají Maple.  

Základní ovládání systému Maple 
Nyní si ukážeme, jak v systému Maple zadávat jednoduché příkazy pro symbolické a numerické 
výpočty. Budeme proto předpokládat, že zápisník je již nastaven pro psaní příkazů (Math Mode).  

Základní operace: pro sčítání používáme symbol plus (+), pro odčítání mínus (–), pro násobení (*), ale 
pozor, pro dělení musíme používat pouze lomítko (/), dvojtečka (:) má jiný význam (viz dále). 

Maple provádí základní operace přesně nad celými čísly, zlomky (racionálními čísly) které zobrazuje 
přesně a vybranými iracionálními čísly (např. mocniny celých a racionálních čísel, Ludolfovým číslem π, 
Eulerovým číslem e atd.). 

Zlomek zadáme v zápisníku Maple tak, že zadáme čitatel, lomítko (/) a jmenovatel nebo použijeme 
paletu Expression. Pro opuštění zápisu jmenovatele stačí stisknout šipku doprava (ve zlomku je též 
možno pohybovat se šipkami). 

Mocniny zadáme v zápisníku Maple tak, že zadáme základ a symbol stříška (ˆ) nebo (**) a exponent 
nebo použijeme paletu Expression. Pro opuštění zápisu exponentu je opět možné použít šipku 
doprava. 

Některé z matematických symbolů, které můžeme použít, nejsou na klávesnici, a tak se zadávají buď z 
PALETY nebo pomocí svých názvů3  

Příkazy v zápisníku vyhodnotíme stiskem klávesy Enter. Výsledek se zobrazí na dalším řádku uprostřed 
a na pravé straně pole DOKUMETu se objeví jeho číslo v závorce. V dřívějších verzích Maple bylo nutné 
příkaz ukončovat středníkem, aby se provedl. Tato možnost nadále zůstala (tj. zadáme-li za příkaz 
středník, „nic nepokazíme“) a v některých situacích je dokonce jediná možná – např. textový režim 
(Text Mode) příkazů v režimu Worksheet Mode. Z předešlých verzí Maple se uchovala i funkcionalita 
symbolu dvojtečka (:), která po zařazení za příkaz a následného stisku klávesy Enter potlačí zobrazení 
výsledku na dalším řádku (tj. příkaz se provede, ale na obrazovku se nic nevypíše). Proto není možné 
dvojtečku používat jako operátor dělení.  

V režimu Document Mode je navíc možné zapisovat příkaz i s výsledkem na jeden řádek. Po napsání 
příkazu k tomu stačí namísto stisku klávesy Enter stisknout současně klávesy Ctrl a =. 
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Jak bylo zmíněno dříve, interaktivní dokumenty v Maple jsou „živé“. Tím 
máme na mysli skutečnost, že i v dříve vytvořeném programu s 
vyhodnocenými příkazy, který se otevře po libovolně dlouhé době můžeme 
kterýkoli výraz upravit, znovu vyhodnotit (stisknout Enter nebo Ctrl a =) a 
dostaneme nový (správný) výsledek. Označíme-li myší několik (libovolně 
mnoho) příkazů a stiskneme ikonku ! (vykřičník) z NÁSTROJOVÉ LIŠTY, 
všechny označené příkazy budou postupně vyhodnoceny. K vyhodnocení 
všech příkazů v celém zápisníku slouží ikonka !!!  (tři vykřičníky) v 
NÁSTROJOVÉ LIŠTĚ. 

K zadávání příkazů v zápisníku slouží jednotlivé PALETY zpravidla při levém 
okraji zápisníku (viz obr. 3.2). Palety jsou pojmenované „obdélníčky˙ s 
nabídkou předdefinovaných symbolů, zápisů, výrazů apod. (obr. 3.8).  

Každá paleta obsahuje symboly příslušné skupiny. Například paleta s 
názvem MapleCloud nabízí nejrůznější dokumenty (zápisníky) ze severu 
MapleCloud, paleta Expression nabízí některé základní matematické 
výrazy, paleta Greek písmena řecké abecedy, paleta Matrix umožňuje 
vkládat do zápisníku matice, paleta Components umožňuje vkládat do 
zápisníku interaktivní komponenty, které sdílí mezi sebou data atd. 
Standardně zůstává několik palet nezobrazených. V HLAVNÍM MENU (View 
> Palettes) můžeme seznam zobrazených palet upravit tím, že některé 
přidáme, odebereme, ale třeba i jinak seřadíme. Totéž lze provést jen za 
pomoci myši. Přidržením levého tlačítka myši vybranou paletu přesuneme 
na jiné místo, stisknutím pravého tlačítka vyvoláme stejnou nabídku, jako 
bychom postupovali přes HLAVNÍ MENU. Kliknutí levého tlačítka myši na 
některou z palet se zobrazí (příp. skryjí) symboly, které paleta nabízí.  

Vložit z palety symbol do zápisníku pak stačí pouhým kliknutím, případně 
jeho „přetáhnutím“ s pomocí levého tlačítka myši. Speciální roli při zápisu 
matematických výrazů má paleta Expression, viz obr. 3.8. Obecné barevně 
zvýrazněné symboly z výrazu z palety Expression je možné dále v zápisníku 
specifikovat (upravovat) dosazením příslušných hodnot (výrazů, textů, 
symbolů, čísel atd.), s nimiž potřebujeme pracovat. 

Obrázek 3.8: Palety  

Mimo palet můžeme k zápisu symbolů užívat jejich názvů. Například symbol π vložíme zapsáním jeho 
názvu Pi, pro odmocninu je vyhrazen název sqrt, takže √x vložíme napsáním sqrt(x). Při vkládání 
symbolů pomocí názvů nebo při tvorbě příkazů se může hodit funkce „dokončování˙. Pro zadání 
symbolu pak stačí napsat jeho úvodní písmeno (písmena) a pomocí klávesy Esc nebo současným 
stiskem kláves „Ctrl a mezerník“ následně z vyskakovacího okénka zvolit požadovaný příkaz.  

Kontextové menu v zápisníku 
Kontextové v zápisníku je funkce Maple, která je generována dynamicky v závislosti jaký matematický 
objekt nebo výraz je vybrán zápisníku. Tj. vyvolá se označením konkrétní položky (matematického 
objektu nebo výrazu) a stiskem pravého tlačítka myši, které vyvolá vyskakovací okno „pop-up“ se 
seznamem funkcí (obr. 3.9), které nabízí například uživateli získat koeficienty výrazu, derivovat jej 
vzhledem k zvolené proměnné, zobrazit jeho graf a mnoho dalších. Podrobnější dokumentace o 
kontextové menu je uvedena v nápovědě Help, kterou vyvoláme z HLAVNÍHO MENU a zvolením 
Getting Started → Menus → Context-Sensitive menu. 



Obrázek 3.9: Část seznamu kontextového menu 

Nápověda 
Pokud nevíme jak zadávat v zápisníku příkazy, texty, provádět výpočty a zobrazovat grafy, tak 
využijeme nápovědy (Help) kterou vyvoláme z HLAVNÍHO MENU (Help > Maple Help) nebo 
současným stisknutím kláves Ctrl a F1. Tím se vyvolá hlavní menu nápovědy, viz obr. 3.10.  

 
Obrázek 3.10: Hlavní obrazovka systému nápovědy 

Vyhledávat informace v nápovědě lze buď zadáním hledaného textu do textového pole v levé horní 
části okna (na obr. 3.10 je toto pole prázdné), nebo tematickým vyhledáváním ve stromové struktuře 
témat v levé části okna (na obr. 3.10 je rozbalena nápověda Getting Started a v ní témata Maple 
Portal, Shortcut Keys, How Do I … atd.) a popis Maple Help System je v pravé části okna. 

Položka Help HLAVNÍHO MENU poskytuje ještě několik dalších forem nápovědy, kde položka Take a 
Tour of Maple zobrazí interaktivní přehled systému Maple (jeho nejdůležitějších prvků). Kliknutí na 
položku Quick Reference se otevře tabulka informací o ovládání Maple, zejména pro nové uživatele. 
Jedná se o základní informace s odkazy do nápovědy Maple Help pro jejich případné doplnění. 



 

 

Obrázek 3.11: Nápověda Help 

Položka Quick Help nabízí ještě stručnější tabulku než předchozí nápověda. Standardně se objevuje v 
každém novém zápisníku při pravé straně v podobě černého okénka (pokud toto nastavení 
nezrušíme). Po zavření je možné ji vyvolat stiskem klávesy F1, či jako položku v HLAVNÍM MENU. 

Další položkou je What’s New která uvádí přehled rozšíření stávající verze Maple oproti předcházející 
verzi. Poslední velmi užitečná položka je On the Web, která umožňuje čerpat podle daného linku 
informace z webu, viz obr. 3.11, když klikneme např. na Application Center tak se otevře webová 
stránka (www.maplesoft.com/applications/?p=maple2015) apod. 

Maple Portal 
Nápověda obsahuje velmi užitečnou stránku Maple Portal. Spustit ji můžeme přes nápovědu v 
HLAVNÍHO MENU (Help > Maple Help), a vybrat je z otevřeného menu Getting Started (obr. 3.10). 

Maple Portal je navržen jako startovní místo pro všechny uživatele Maple. Pomůže jim začít s užíváním 
Maple, dozvědět se o základních nástrojích, které jsou k dispozici a provede je řadou řešených úloh. 
Odtud jsou odkazy na podrobnější témata v Portálu pro inženýry (Engineers), studenty (Students) a 
matematické pedagogy (Math Educators), viz obr. 3.12. 

 
Obrázek 3.12: Maple Portal 

http://www.maplesoft.com/applications/?p=maple2015


Maple poskytuje nápovědu tzv. „pomocné nástroje“ (Tools) pro řešení úloh. Jsou to: Pomocníci 
(Assistants), Matematické aplikace (Math Apps), Instruktoři (Tutors) a Úlohy (Tasks), které vyvoláme z 
HLAVNÍHO MENU (Tools > Assistants, Tools > Math Apps, Tools > Tutors a Tools > Tasks). 

Pomocníci (Assistants) obsahují například nástroje pro hledání funkční závislosti v datech, optimalizaci 
funkcí, řešení diferenciálních rovnic a další. Pro daný typ úlohy mají implementováno několik často 
používaných algoritmů. Po vyvolání provedou uživatele nastavením a specifikací parametrů úlohy a 
zvolenou metodou úlohu vyřeší. Při vyvolání příslušného pomocníka se otevře nový zápisník Maple 
nebo okno s jeho vlastním uživatelským rozhraním (GUI). Na obr. 3.13 je uveden příklad pomocníka 
Equation Manipulator, demonstrující řešení pomocníka pro manipulaci s rovnicí 7x+5y-9=0. 

 
Obrázek 3.12: Assistent manipulátor s rovnicí 7x+5y-9=0. 

Matematické aplikace (Math Apps) ilustrují různé řešené matematické a vědecké úlohy v zápisníku, 
který se po vyvolání Math Apps otevře a umožňují v něm rychlou navigaci v těchto matematických 
aplikacích. Kliknutím na ikonu zvolené aplikační oblasti se otevře odpovídající zápisník Maple. 

Instruktoři (Tutors) provedou uživatele řešenou problematikou pomocí jednoduchých názorných 
příkladů a nabízí podrobné vysvětlení ke konkrétním tématům, které mohou být užitečné například 
pro studenty, kteří chtějí pochopit celý proces výpočtu místo získání pouze výsledku. Na obr. 3.13 je to 
ilustrováno na příkladu Newtonovy metodu pro hledání kořene rovnice x3-x2+12 = 0. 



 
Obrázek 3.13: Tutor Newtonovy metody 

Úlohy (Tasks) zobrazují na příkladech, jak řešit různé úlohy s využitím Maple. Na obr. 3.14 je příklad 
úlohy řešící vzdálenost mezi dvěma rovinami x+y+z=4 a x+y+z=-2 v prostoru. 

 
Obrázek 3.14: Úloha řešení vzdálenosti mezi dvěma rovinami v prostoru 

Zapsáním otazníku (?) následovaným názvem příkazu Maple se otevře nápověda týkající se zadaného 
příkazu. Tj. například ?solve otevře nápovědu Maple popisující syntaxi a sémantiku příkazu solve 
spolu s příklady jeho použití, obr. 3.15.  



 

Obrázek 3.15: Nápověda k příkazu solve 

Provádění výpočtů 
Maple provádí přesně numerické výpočty s celými, racionálními i iracionálními čísly. Každý zadaný 
matematický výraz se snaží co nejvíce zjednodušit  (např. zlomek zkrátit a převést na základní tvar, 
upravit algebraický výraz, ...), ale ne za cenu ztráty přesnosti. To znamená, že například racionální čísla 
(zlomky) udržuje stále v jejich základním tvaru. Podobně s konstantami π, e a dalšími, s odmocninami 
a jinými výrazy pracuje jako se symboly. Tímto je zaručena absolutní přesnost výpočtů v Maple i v 
případě, kdy nepracuje pouze s celými čísly. 

Jsou však situace, kdy potřebujeme znát přibližnou hodnotu reálného nebo racionálního čísla v 
pohyblivé řádové čárce. K tomu slouží příkaz evalf, jenž vrátí zaokrouhlenou hodnotu svého 
argumentu na počet platných cifer mantisy specifikovaný systémovou proměnnou Digits. Ta je 
standardně nastavena na hodnotu 10. Všechny výpočty, při nichž je nutné zaokrouhlovat čísla, provádí 
proto Maple s přesností na 10 platných míst. Proměnnou Digits můžeme nastavit na takřka 
libovolné přirozené číslo. Omezení, jak vysoké toto číslo může být, zjistíme příkazem 
kernelopts(maxdigits). Pro představu uveďme, že pro Maple 2015 je toto číslo 
38 654 705 646, tedy více než 38 miliard platných cifer, s kterými dokáže systém počítat. 

Maple rozeznává přesná čísla (mezi něž patří i zmíněné symboly π a e, zlomky atd.) a čísla typu 
Floating-Point, nebo-li čísla v pohyblivé řádové čárce (např. -2.76E10, 234.567, ). Jestliže v zápisníku 
zadáme výraz, v němž některý z jeho podvýrazů bude typu Floating-Point, může Maple na celý výraz 
pohlížet jako by byl tohoto typu a bude výsledky výpočtů zaokrouhlovat. 

K provedení výpočtu v zápisníku máme zpravidla více možností. Jednak pomocí příkazů jazyka Maple, 
tj. když chceme vypočítat například odmocninu z čísla 2.5, zapíšeme v systému Maple příkaz 
sqrt(2.5). Stejného výsledku dosáhneme použitím symbolu pro odmocninu z palety Expression, viz 
obr. 3.15.  

Pokud chceme určit nejmenší společný násobek čísel 10, 12 a 15, můžeme využít příkazu Maple lcm, 
nebo zapsat čísla na řádek za sebe (oddělená čárkami), označit je myší a pomocí jejího pravého 



tlačítkai zvolit z kontextové nabídky funkci Apply Function > Least Common Multiple, viz obr. 3.15, 
3.16.  

Obrázek 3.15: Různé možnosti provedení výpočtu 

Obrázek 3.16: Provedení výpočtu pomocí kontextové nabídky 

Každému zobrazenému výsledku se v zápisníku přiřazuje číselné označení, které se zapisuje zcela 
vpravo na řádek s odpovídajícím výsledkem. Díky číselnému označení se lze na předešlé výsledky 
odvolávat a používat je při tvorbě dalších příkazů, viz obr. 3.17. Z důvodu jednoduchosti budeme 
v dalším číselné označení vynechávat. 



Obrázek 3.17: Označení výsledků 

Číselné označení výsledků je možné potlačit (tj. nezobrazovat), znovu vyvolat, případně upravit jeho 
formát v HLAVNÍM MENU (Format > Equation Labels  > ...).  

Pokud chceme například přičíst k číslu 10 výsledek s označením (2), viz obr. 3.17, pak napíšeme „10+“ 
a současným stisknutím kláves „Ctrl a L“ vložíme požadované označení výsledku (tj. do vyskakujícího 
okna˙“pop-up“ zadáme číslo 2 a potvrdíme (OK), viz obr. 3.18).  

Obrázek 3.18: Vyskakující okno „pop-up“ pro zadání označení výsledku 

Místo současného stisku kláves „Ctrl a L“ je možné použít HLAVNÍ MENU (Insert > Label ...).  

Pozor však, zapíšeme-li na klávesnici jako číselné označení výsledku text „(2)“ při tvorbě příkazu, tak se 
výsledek číselně označený (2) na obr. 3.17 do příkazu nepřenese. Pro vložení výsledku z číselného 
označení do příkazu Maple je třeba důsledně používat předešlý postup s „vyskakujícím okénkem“ 
zobrazeným na obr. 3.18. 

Přiřazení hodnot a výrazů do proměnných v Maple 
V zápisníku Maple se lze odkazovat na výrazy po jejich přiřazení k nějaké proměnné. Operátorem 
přiřazení je (dvoj)symbol := (dvojtečka + rovnítko). Místo (dvoj)symbolu := můžeme k přiřazení použít 
příkaz assign. Tak, jak můžeme výrazy do proměnných přiřazovat, tak můžeme přiřazení zrušit (tj. 
odebrat proměnné uloženou hodnotu). Provede se to příkazem unassign nebo přiřazením názvu 
proměnné v apostrofech, viz obr. 3.19. 

Obrázek 3.19: Přiřazení hodnot do proměnných a odstranění uložené hodnoty 

Přiřazovat hodnoty můžeme i do tzv. systémových proměnných. Již jsme se setkali s proměnnou 
Digits vyjadřující počet platných míst, s nimiž Maple počítá. Odstranit uloženou hodnotu v 
systémové proměnné nelze.  



Do systémových proměnných můžeme hodnoty pouze přiřazovat, nebo současně vrátit příkazem 
restart nastavení všech systémových proměnných na jejich původní hodnoty. Provedení příkazu 
restart odstraní všechny uložené hodnoty v paměti (tedy i námi definované proměnné, načtené 
balíky atd.). Příkaz restart se proto používá zpravidla na počátku řešení nové úlohy, zejména pak na 
začátku každé práce se zápisníkem (aby se předešlo tomu, že budeme používat proměnnou, v níž je z 
dřívějška uložena pro nás nesprávná hodnota). 

Knihovny (packages) Maple 
Knihovna příkazů jazyka Maple je rozdělena na hlavní knihovnu a tzv. balíky4 (packages). Příkazy, s 
nimiž jsme se doposud setkali, patří do hlavní knihovny Maple, a můžeme je tak používat ihned po 
spuštění systému Maple. Naproti tomu většina příkazů Maple naleží do balíků, které musíme před 
použitím příslušného příkazu buď načíst do zápisníku pomocí příkazu with, nebo zadat příkaz spolu s 
názvem balíku. Načtení balíku pomocí příkazu with umožní používání všech příkazů z příslušného 
balíku. Naopak zadání příkazu spolu s názvem balíku je nutné provádět při každém použití tohoto 
příkazu, pokud balík nenačteme (příkazem with). Načtení balíku můžeme zrušit příkazem unwith. 
Pokud balík nenačteme a použijeme z něj nějaký příkaz, Maple jej nerozpozná a příkaz vypíše jako 
textový řetězec.  

Jedním z významných balíků je balík s názvem RealDomain. Systém Maple pracuje zpravidla s 
komplexními čísly a právě balík RealDomain umožňuje se v některých případech omezit pouze na 
množinu reálných čísel (obr. 3.20). 

Obrázek 3.20: Použití balíku RealDomain. 

Řešení rovnic v Maple 
K řešení rovnic v systému Maple slouží příkaz solve a několik příkazů k němu příbuzných závislých na 
typech rovnic, viz tab. 3.1. 

Tabulka 3.1: Příkazy pro řešení rovnic 

Typ rovnice Příkaz pro řešení 
Rovnice a nerovnice solve, fsolve 
Rekurentní rovnice rsolve 
Obyčejné diferenciální rovnice dsolve 
Parciální diferenciální rovnice pdsolve 
Rovnice v oboru celých čísel isolve 
Rovnice v oboru celých čísel v konečném tělese msolve 

                                                             
4 Kromě pojmu balík se v češtině používá také termín knihovna 



Lineární integrální rovnice intsolve 
Systémy lineárních rovnic LinearAlgebra[LinearSolve] 

Rovnice můžeme řešit též pomocí kontextové nabídky. Zapíšeme rovnici, označíme ji myší a pravým 
tlačítkem myši zvolíme požadovaný příkaz z kontextové nabídky. Obr. 3.21 ilustruje některé příklady 
řešení rovnic. 

Obrázek 3.21: Ukázka řešení různých druhů rovnic jednak použitím příkazu Maple,  
jednak pomocí kontextové nabídky (uvedené na šipkou). 

Příkazy pro řešení rovnic nemusí vždy zobrazit všechna řešení. Pokud je chceme zobrazit, přidáme 
příkazu solve nepovinný parametr AllSolutions, viz obr. 3.22. 

Obrázek 3.22: Zobrazení všech řešení rovnice  



Symbol Z2∼ na obr. 3.22 představuje libovolnou celočíselnou proměnnou. Že jde o celočíselnou 
proměnnou poznáme podle toho, že se v symbolu vyskytuje písmeno Z. Podobně by výskyt například 
písmena C značil proměnnou komplexní a písmeno R reálnou proměnnou. Cifra 2 v symbolu 
proměnné označuje pořadí, v jakém byla proměnná v zápisníku zavedena a nakonec znak ∼ vyjadřuje, 
že proměnná splňuje nějaký předpoklad. Jaké předpoklady proměnná splňuje přitom zjistíme 
příkazem about, případně zápisem proměnné a po kliknutí pravým tlačítkem myši zvolením What 
Assumptions z kontextové nabídky. V zobrazeném příkladu na obr. 3.22 je předpoklad celočíselnosti 
(u již celočíselné) proměnné přebytečný. 

Dále může příkaz solve zobrazit výsledek se strukturou RootOf vyjadřující kořen (tj. řešení) rovnice 
v nevyhodnoceném tvaru. Řešení pak vyhodnotíme buď příkazem allvalues (pro symbolické 
vyjádření), nebo příkazem evalf (pro numerické vyjádření) – obr. 3.23. Kromě těchto příkazů 
můžeme též využít pravého tlačítka myši, tj. zvolit z kontextové nabídky položku All Values (pro 
symbolické vyjádření) a získaný výsledek převést na numerickou hodnotu zvolením např. 
Approximate > 10 (pro 10 platných míst) z kontextové nabídky. 

Obrázek 3.23: Tvar zobrazení řešení rovnice 

Symboly Z ve struktuře RootOf nyní nepředstavují celočíselnou proměnnou (neboť za Z nenásleduje 
číslo), nýbrž proměnnou libovolnou (tj. i komplexní). Struktura RootOf z obr. 3.23 tedy zastupuje 
kořen rovnice z4 − 2 z3 + 2 = 0. 

Systém Maple po zadání příkazu vypíše zpravidla pouze řešení, případně chybová hlášení či varování. 
U příkazu solve (a nejen u něj) je „prázdný výpis“ v případě, že Maple žádné řešení nenašel. Pro 
výpis podrobnějších informací o průběhu vyhodnocení příkazu a výsledcích slouží proměnná infolevel. 
Můžeme ji nastavit buď pro každý příkaz samostatně, přičemž do hranatých závorek za proměnnou 
vložíme název příslušného příkazu, nebo ji nastavíme všem příkazům současně na stejnou hodnotu 
uvedením slova all do hranatých závorek. Proměnná může nabývat hodnot 1, 2, ..., 5. Čím vyšší 
hodnota je přiřazena v proměnné infolevel, tím více informací o vyhodnocení příkazu obdržíme. 
Standardně není proměnná nastavena na žádnou hodnotu, což v podstatě odpovídá nastavení 
proměnné na hodnotu 0. Použití proměnné infolevel dokumentuje obr. 3.24. 



Obrázek 3.24: Proměnná infolevel a příkaz solve  

Paleta Components 
PALETA Componets (obr. 3.25) umožňuje vložit komponenty (ovládací prvky 
anglicky widget) grafického rozhraní do zápisníku nebo dokumentu Maple, 
které umožňují jejich základní komunikaci mezi sebou a interakci s uživatelem, 
tj. zadávat či měnit s jejich využitím například parametry v příkazech Maple. 
Každá komponenta je v PALETĚ vizuálně ztvárněna ikonou a slouží pro různou 
manipulaci s daty v zápisníku. Například, pomocí komponenty Slider mohou být 
nastaveny hodnoty proměnných v zápisníku, které využijí ostatní komponenty. 
Komponenty provádí akce a zobrazují informace určené jejich konstrukčními 
nebo jinými vlastnostmi. V paletě Components (obr. 3.23) jsou následující 
komponenty: Button, Toogle Button, Combo Box, Check Box, Radio Button, 
Text Area, Label, List Box, Slider, Rotary Gauge, Volume Gauge, Meter, Dial, 
Plot, Math Expression, Shortcut, Data Table, Video Player.  

K předávání informací (dat i kódu programu) mezi komponentami slouží 
speciální příkazy uvedené v balíku DocumentTools, umožňující uložení a získání 
informací z jiných komponent v zápisníku. Zejména příkaz Do z tohoto balíku 
poskytuje snadný způsob, jak specifikovat operace pro tyto komponenty.  

Obrázek 3.25: Paleta Components 



Chcete-li umístit zvolenou komponentu do zápisníku Maple, otevřete PALETU Components a 
přetáhnete její ikonu (například Button, Slider, Math Expression, Plot) na požadované místo v 
zápisníku. 

Více komponent na jednom řádku v zápisníku lze oddělit buď mezerou mezi nimi, nebo je umístit na 
samostatné řádky v zápisníku stisknutím klávesy Enter. Přesnější rozložení komponent v zápisníku 
může být dosaženo vložením tabulky z HLAVNÍHO MENU (Insert - > Table s vybráním počtů řádků a 
sloupců z vyskočeného pomocného menu) a vložením daných komponent do požadovaného místa v 
tabulce. V takto vytvořené tabulce mohou být umístěny libovolně vybrané komponenty. 

Komponenty je třeba nakonfigurovat dříve, než se použijí. Konfigurováním komponenty se určí, jednak 
jak komponenta vypadá (např. název komponenty Button, velikost grafické oblasti pro komponentu 
Plot apod.), a jednak jak funguje (např. stanovení rozsahu hodnot, které komponenta podporuje, nebo 
úprava programu v komponentě, který se spouští kliknutím na ni). 

Chceme-li nakonfigurovat komponentu, např. 
Button, kterou už máme v poli DOKUMET 
v zápisníku, klepne se na ni pravým tlačítkem myši. 
Vyskočí okno „pop-up“, obr. 3.26, ze kterého se dají 
vyvolat další okna Component Properties… a Edit 
Click Action…, viz obr. 3.27, umožňující 
nakonfigurovat vlastnosti komponenty Button a 
naprogramovat akce, které se provedou.  

 
Obrázek 3.26: Paleta okna „pop-up“ u komponenty Button 

 

Obrázek 3.27: Okna Components Properties… a Edit Click Action… u komponenty Button 

Po dokončení konfigurace vlastností komponenty Button v okně Components Properties… (do pole 
Name se zadá název, do pole Caption název tlačítka a zaškrtnou se volby Options) se obsah okna uloží 
klepnutím na tlačítko „OK“. Každá komponenta má nastavitelný název, (na obr. 3.27 je uveden název 
Button0), který slouží ke komunikaci a sdílení dat mezi jednotlivými komponentami s využitím balíku 
Document Tools. 



Okno Edit Click Action…. editoru programového kódu slouží k zapsání příkazů akcí, které se mají 
provést při kliknutí na komponentu Button. Má předefinovaný obsah pro využití příkazů balíku 
Document Tools (obr. 3.27). Tento druh programování akcí komponent budeme diskutovat v 
následující části. 

Komponenty lze konfigurovat následujícím způsobem: 

1. Uživatel na komponentu v zápisníku klikne a může do ní psát (např. v komponentách Math 
Expression, Text apod.) nebo táhnout ve vstupním poli myší (např. v komponentách Plot, ). To 
způsobuje změnu jejího stav, případně spuštění programu nastaveného dříve, když komponenta 
již byla konfigurována. 

2. Komponenty spouští program určující, jaké akce se mají provést, když se změní její stav. Při psaní 
programu v okně editoru kódu je dovoleno jak běžné programování v Maple (např. běžné příkazy, 
ale i příkazy if, for atd.), tak speciální programování akcí, které se v komponentě provádí pomocí 
příkazu Do z balíku DocumentTools. Obvykle program v komponentě obsahuje jeden nebo více 
řádků ve formuláři příkazu Do(%widgetName = výraz); kde výraz může obsahovat také 
názvy komponent, které bere z pole Name, viz obr. 3.27. Proměnné, funkce ve výrazech v  okně 
otevřeného Edit Click Action…. , které nezačínají symbolem % se berou jako standardní příkazy 
Maple. Jména na pravých stranách výrazů jsou obvykle vstupní komponenty a hodnoty, které jsou 
použity ve výrazu k výpočtu výsledku, který se zobrazí ve výstupu komponenty, která má název 
widgetName a který je uveden na levé straně výrazu. 

V dalším stručně popíšeme vlastnosti nejvíce používaných komponent: 

Komponenta Button definuje tlačítko v zápisníku nebo dokumentu Maple, které po kliknutí provede 
akci nebo posloupnost akcí, v nichž komunikuje s jinými komponentami, jejichž názvy jsou 
komponentě Button uvedeny. Nakonfiguruje se tak, že se na ni umístí kurzor myši a kliknutím pravým 
tlačítkem se vyvolá „pop-up“ okno (obr. 3.26) a z něj položky Components Properties… a Edit Click 
Action…. Komponenta Button může například zobrazit popisek nebo vytvořit graf či vypočítat řešení 
rovnice. 

Komponenta Combo Box definuje pole se seznamem, ze kterého lze vybírat jeho položky, které pak 
mohou sdílet ostatní komponenty. Tj. provede akci nebo série akcí, které mají komunikovat s jinými 
komponentami, když se vybere položka ze seznamu Combo Box. Nakonfigurujeme ji tak, že klepneme 

pravým tlačítkem myši na Combo Box a z vyskočeného „pop-up“ 
okna vyberte volbu Component Properties…, (obr. 3.28) ze které 
otevřeme dialogové okno editoru pro Item List, kde zadáme položky 
seznamu, které chceme vybírat v této komponentě.  

Chceme-li provést akci, když je vybrána položka ze seznamu 
v Combo Box, tak ji naprogramujeme s využitím Edit Click Action…, 
(podobně jako v obr. 3.27) kterou se otevře dialogové okno editoru 
kódu pro Combo Box, kam se zadají příkazy, které se mají 
s vybranou položkou ze seznamu provést. 

Obrázek 3.28: Okno Components Properties…komponety Combo Box 

Komponenta Slider definuje hodnotu jezdce v posuvníku v zápisníku nebo dokumentu Maple. Tato 
komponenta provede akci nebo série akcí, kde komunikuje s jinými komponentami, když se mění 
poloha jezdce na posuvníku. Chceme-li provést akci, když se změní poloha jezdce na posuvníku, 



nakonfigurujeme ji tak, že z vyvolaného „pop-up“ okna vybereme položku Edit Value Changed 
Action…, která otevřete dialogové okno editor kódu pro Slider, kam se zadají příkazy, které chcete 
provést při spuštění této komponenty podobně jako u komponent Button a Combo Box. Rozdílná od 
těchto komponent je položka Component Properties …., viz obr. 3.29, kterou se otevře konfigurační 
okno, kde lze nastavit název komponenty, její dolní a horní rozsah hodnot, pozici jezdce, značky na ose 
a dále zatrhnout příslušnou volbu Options. Konfigurační okno se uloží stisknutím „OK“ tlačítka.  

 

Obrázek 3.29: Okno Components Properties…komponety Slider 

Popisy voleb v Options, které můžeme zatrhnout, lze získat z HLAVNÍHO MENU (Help > Maple Help) 
nebo stiskem kláves Ctrl a F1 a zapsáním textu „Slider Component“ ve vyhledávacím poli nápovědy, 
která příslušné informace zobrazí, viz obr. 3.10. 

Komponenta Text Area definuje textovou oblast v zápisníku nebo dokumentu Maple. Tato 
komponenta provede akci nebo posloupnost akcí, kde komunikuje s jinými komponentami, při změně 
obsahu v textové oblasti. Chceme-li ji nakonfigurovat, tak otevřeme vyskakovací „pop-up“ okno, kde 
se vybere položka Component Properties…, která je podobná jako u Combo Box a otevře se okno 
editoru textu Edit u položky Content, kam se zapíše příslušný text. Chceme-li, aby se provedly ještě 
další akce, tak se vybere položka Edit Content Changed Action…, kterou se otevře dialogové okno 
editoru kódu pro Text Area, kam se zadají příkazy, které se mají provést spuštěním této komponenty. 

Komponenta Plot definuje oblast grafu v zápisníku nebo dokumentu Maple. Tato komponenta 
provede akci nebo série akcí, které mohou komunikovat s dalšími komponentami, když se klikne nebo 
táhne grafem. Chceme-li ji nakonfigurovat, tak na ni klineme a z vyskakovacího „pop-up“ okna viz obr. 
3.30, lze otevřít okno Component Properties… a dále okna:  
• Edit Click Action…, kde můžeme zapsat pomocí editoru kódu příkazy akce, která se provede, když 

se myši klepne na komponentu Plot;  



• Edit Drag End Action, kde můžeme zapsat příkazy akce, která se provede při uvolnění myši z tažení 
v komponentě Plot;  

• Edit Dragged Action, kde můžeme zapsat příkazy akce, která se provede při tažení myši v 
komponentě Plot.  

Poznámka: Tyto akce se uskuteční pouze pokud kliknete na ikonu  (Execute click and drag code) 
v KONTEXTOVÉ LIŠTĚ v režimu Plot, viz obr. 3.5. 

Obrázek 3.30: Vyskakovací „pop-up“ okno komponenty Plot  

V okně Component Properties… je možné zvolit název komponenty Plot, zadat do pole Plot 
Expression příkaz Maple pro animaci grafu, např.  

plot3d(x^2*cos(y),x=-1..1,y=-2*Pi..2*Pi); 
dále šířku a výšku grafu v pixelech v zápisníku a zpoždění při animaci v milisekundách a zaškrtnout 
volby Options, které lze nalézt v nápovědě.  

 
Obrázek 3.31: Okno Component Properties… komponenty Plot 

Příklad 3.1. 
Vytvořte graf funkce sin(k ∙ x), kde k, x ϵ <0, 10> a jeho barvu bude možno volit mezi červenou (red), 
modrou (blue) a zelenou (green). 

Návrh řešení:  
Komponentu Button použijeme na spuštění ostatních komponent, pro měnící se hodnoty parametru k 
vybereme komponentu Slider, pro výběr barvy komponentu ComboBox a pro zobrazení grafu 
komponentu Plot. Hodnoty parametru k z komponenty Slider zobrazíme pomocí komponenty Text 
Area.  



Postup řešení: 

1. V zápisníku vytvoříme tabulku z HLAVNÍHO MENU (Insert > Table) s jedním řádkem a dvěma 
sloupci. Do prvního sloupce z PALETY Components přetáhneme na samostatné řádky postupně 
komponenty Button, Slider, Text Area a Combo Box a do druhého sloupce přetáhneme komponentu 
Plot. Před komponentu Text Area přidáme vlevo popisný text „Hodnota k“ a před komponentu 
Combo Box text „Barva“. To lze provést jiným způsobem tak, že by se k zadání textu do tabulky u 
jakékoli komponenty umístil kurzor, za kterým se chce zadávat text, který by se zadal 
pomocí HLAVNÍHO MENU (Insert-> Text) nebo po stisknutí kláves Ctrl a T. 

2. Klepnutím pravým tlačítkem myši na komponentu Slider, 
otevřeme vyskakovací „pop up“ okno a zvolíme Component 
Properties…, která otevře konfigurační okno viz obr. 3.32, kde 
nastavíme název SliderK, dolní (0) a horní (10) hodnoty pro k, 
vzdálenost značek na posuvníku, šířku a výšku posuvníku v pixlech. 
Dále zatrhneme příslušné volby Options, jak je znázorněno obr. 
3.32 a uzavřeme konfigurační okno stisknutím „OK“ tlačítka. 

3. Klepnutím pravým tlačítkem myši na komponentu Text Area 
otevřeme vyskakovací „pop up“ okno a zvolíme Component 
Properties…, která otevře konfigurační okno, viz obr. 3.33, kde 
nastavíme její název kText, počet viditelných znaků (10) a řádků (1) 
a zaškrtneme zvolené volby Options. Pomocí editace Contents lze 
nastavit později vlastnost, umožňující z komponenty Slider přebírat 
a zobrazit hodnotu k. Hodnoty nastavené v komponentě Text Area 
se uloží kliknutím na „OK“. 

Obrázek 3.32: Nastavení Slider 

4. Klepnutím pravým tlačítkem myši na komponentu Combo Box 
otevřeme vyskakovací „pop up“ okno a zvolíme Component 
Properties…, která otevře konfigurační okno, viz obr. 3.28, kde 
nastavíme její název colorBox a pomocí editoru zavedeme seznam 
barev „red“, „green“ a „blue“, viz obr. 3.34, který se uloží kliknutím 
na „OK“. 

 

Obrázek 3.33: Nastavení Text Area   Obrázek 3.34: Nastavení seznamu v Combo Box 

5. Komponenta Plot se nastaví pomocí Component Properties, aby její jméno bylo Graf_sin(kx), 
podobně jako na obr. 3.31 je název Plot0. 



6. Nyní naprogramujeme komponenty Slider a Button tak, že budou sdílet data s komponentami Text 
Area a Plot. Klepneme pravým tlačítkem myši na komponentu Slider a z vyskočeného „pop-up“ okna 
menu vybereme položku Edit Value Changed Action, kterou se vyvolá okno editoru kódu komponenty 
Slider. Do kódu přidáme speciální příkaz Do( %kText=%SliderK), viz obr. 3.35, před příkaz end use;. 
Tento příkaz vloží aktuální hodnotu jezdce posuvníku do komponenty Text Area.  

 

Obrázek 3.35: Úprava kódu programu komponenty Slider 

Většina z kódu, který se zobrazí v programu na obr. 3.35 jsou komentáře, které vysvětlují užití příkazů 
Do( %component_name ); a Do( %component_name = value ); a jejich činnost. 

7. Podobným způsobem naprogramujeme tlačítko Button kde místo příkazu Do( %kText=%SliderK), 
vložíme příkaz: 

Do( %Graf_sin)=plot(sin(%SliderK * x),x=0..10, color=%colorBox) ); 

Který v komponentě Plot vykreslí graf funkce sin(k ∙ x), kde hodnota k se bere z komponenty Slider (její 
jméno je SliderK), x ϵ <0, 10> a jeho barvu se volí pomocí komponenty Combo Box (její jméno je 
colorBox), kde je definován seznam barev, viz obr. 3.34. 

8. Nyní lze pracovat se všemi komponentami. Vyberte hodnotu k, vyberte barvu a pak klikněte na 
tlačítko Button a zobrazí se Vám graf funkce sin(k ∙ x) v intervalu <0,10>, k=4, viz obr. 3.36. 

 
Obrázek 3.36: Dynamické interaktivní vykreslení grafu funkce sin(k ∙ x). 



MapleCloud 
Společnost Maplesoft vytvořila systém MapleCloud (http://maplecloud.maplesoft.com/) , který 
umožňuje uživateli publikovat, sdílet zápisníky a dokumenty Maple, ať již pro své vlastní skupiny 
uživatelů, nebo pro všechny uživatele tzv. Public MapleCloud a MathApps. Systém MapleCloud 
umožňuje vytvářet své vlastní skupiny uživatelů (Community), pro které můžete sdílet své dokumenty, 
případně i dokumenty ostatních členů této skupiny. 

Systém MapleCloud je nyní přístupný z webových prohlížů, a to jak z počítačů, tak i tabletů – stačí se 
jen připojit na webovu adresu (http://maplecloud.maplesoft.com/) , což umožňuje procházet a 
vyhledávat v celém obsahu MapleCloud, číst jeho zápisníky a dokumenty, a dokonce i pracovat s 
aplikacemi Maple, a to bez použití Maple.  

Chcete-li sdílet obsah zápisníku "jako" sdílený obsah, vytvářet, spravovat a připojovat skupiny 
uživatelů a zobrazovat obsah specifický pro Vámi vytvořenou skupinu, musíte se nejprve zaregistrovat 
do Maplesoft komunity na webové adrese (www.maplesoft.com/members/sign_up_form.aspx), kde 
stačí vyplnit několik informací, viz obr. 3.37, kterými si vytvoříte svůj účet. 

 
Obrázek 3.37: Registrace do Maplesoft komunity 

Maplesoft Vám zašle e-mail na Váš e-mail uvedený v registračním formuláři a po potvrzení vlastnictví 
zadaného emailového účtu pomocí odkazu v zaslaném emailu od Maplesoftu je možné se hned do 
systém MapleCloud přihlásit a aktivně v něm pracovat. 

Systém MapleCloud je možné použít i bez jakékoliv registrace, ale to jen v případě, že není potřeba 
žádat o členství v nějaké soukromé skupině. Toto použití je možné, ale jsou k dispozici zápisníky a 
dokumenty v Maple ve dvou seznamech Public MapleCloud a Math Apps, které jsou převzaty 
z nápovědy Maple, viz obr. 3.38 . 

http://www.maplesoft.com/members/sign_up_form.aspx


 
Obrázek 3.38: MapleCloud bez přihlášení 

Existuje mnoho způsobů, jak přistupovat k obsahu v systému MapleCloud: 

a) Prostřednictvím webového prohlížeče: MapleCloud je přístupný z webového prohlížeče, jak 
z počítačů, tak tabletů. Můžete procházet a vyhledávat velké množství zápisníků Maple, číst 
dokumenty, a dokonce i komunikovat s aplikacemi v Maple, to vše bez instalovaného Maple. 
Technologie MapleNet poskytuje matematický výkon Maple v aplikacích zápisníků, takže vše, 
co potřebujete, je standardní webový prohlížeč.  

b) Pomocí volné aplikace Maple Player: Každý může získat přístup do MapleCloud pomocí volně 
stažitelné aplikace Maple Player a komunikovat s aplikacemi zápisníků zde uložených. Po 
stažení dokumentu nebo zápisníku Maple, lze použít aplikaci Maple Player také pro práci v 
režimu offline na mobilu nebo tabletu. 

c) Pomocí Maple: Uživatelé, kteří mají instalovaný Maple mohou přistupovat do MapleCloud ze 
zápisníku Maple prostřednictví PALETY MapleCloud a okamžitě stahovat dokumenty a 
zápisníky z MapleCloud do jejich běžících zápisníků. 

Webové rozhraní systému MapleCloud 
I v základním režimu systému MapleCloud bez přihlášení však můžete provádět některé operace, 
které jsou dostupné i po přihlášení. Jde zejména o: 

• Přihlášení do systému MapleCloud 
• změnu sekcí a skupiny zobrazených dokumentů v MapleCloud, 
• vyhledávání v MapleCloud, 
• sdílení složky v MapleCloud, 
• použití dostupných nástrojů v MapleCloud. 

Levý sloupec webového rozhraní MapleCloud reprezentuje menu, které je možné pomocí tlačítka    
minimalizovat případně rozbalit. Obě situace jsou vidět na obr. 3.39. 

 



 
Obrázek 3.39: Rozbalení či sbalení levého menu 

Levé  menu  obsahuje  tři  hlavní  položky:  

• Login: umožňuje přihlášení do MapleCloud, a to pomocí Maplesoft komunity účtu případně 
Google účtu. 

• Community: obsahuje jednotlivé skupiny, a to jak globálně dostupné, tak i skupiny, ve kterých je 
uživatel členem, případně přímo skupiny vytvořené uživatelem. Bez přihlášení uživatele jsou 
dostupné pouze skupiny globálně dostupné, tedy ty stejné, jako v Maple. 

• Tools: rozbalí odkazy pro dostupné nástroje případně další užitečné odkazy, např. stažení 
aplikace Maple Player, odkazu na novinky v MapleCloudu apod. 

Jednotlivá zobrazení levého menu jsou přehledně ukázána na obr3.40. 

 
Obrázek 3.40: Jednotlivá zobrazení levého menu systému MapleCloud 

Vyhledávání dokumentů 
Vyhledávání dokumentů v systému MapleCloud je možné pomocí ikony lupy . Po kliknutí na ni 
se objeví lišta pro zadání hledaného textu, do které se napíše hledaný text a pak se stiskne klávesa 
ENTER, viz obr. 3.41. 



 

Obrázek 3.41: Vyhledávání dokumentů v systému MapleCloud 

Poznámka: 
V některých prohlížečích se bohužel stává, že lišta není dostatečně zobrazena, v tom případě po 
kliknutí na ikonu vyhledávání jednoduše začněte psát text a následně stiskněte ENTER a 
vyhledané dokumenty se zobrazí.  

Otevírání dokumentů 
Otevření nalezeného dokumentu v systému MapleCloud je velmi jednoduché. Stačí kliknout na název 
dokumentu a dokument se v prohlížeči otevře. Není nutné mít nainstalován žádné další doplňkové 
programy. Systém MapleCloud využívá možnosti jazyka HTML5. Na obr. 3.42 je ukázáno, že dokument 
otevřený dokument v systému MapleCloud může obsahovat i interaktivní dokumenty Maple, které lze 
jednoduše používat, a v prohlížeči budou fungovat. Toho využijeme v kombinaci palet MapleCloud a 
Componets z PALETY v Maple. 
 

 
Obrázek 3.42: Otevřený dokument s interaktivními prvky ve webovém rozhraní MapleCloud 

Sdílení dokumentů či složek 
Po otevření konkrétního dokument případně po otevření sekce či skupiny je možné dokumenty či 
složky sdílet s jinými uživateli. K tomu slouží tlačítko Share. Po jeho stisknutí se objeví webový 
formulář, který umožňuje zaslat odkaz na právě otevřený dokument jinému uživateli (případ vybrání 
emailu), případně je možné tento dokument sdílet přímo na sociálních sítích, jako je Facebook, 



Twitter, či Google+, obr. 3.43. 

 

Obrázek 3.43: Sdílení dokumentu pro jiné uživatele či na sociální sítě 

Obdobná situace je i v případě sdílení celé složky s dokumenty, viz obr. 3.44. 

 
Obrázek 3.44: Sdílení složky pro jiné uživatele či na sociální sítě 

Paleta MapleCloud 
Systém MapleCloud umožňuje sdílet obsah zápisníku Maple a zobrazovat obsah zápisníků sdílených s 
jinými uživateli systému MapleCloud. Pomocí nástrojů v PALETĚ MapleCloud v zápisníku Maple, lze 
nahrát celý zápisník, nebo výběr z něho na hostitelský server systému MapleCloud a pak umožnit 
jiným uživatelům kopii tohoto zápisníku zobrazit a stáhnout na jiný počítač, kde má Maple 
nainstalován a tam jej spustit. Nástroje pro výměnu dokumentů v systému MapleCloud lze také použít 
k uložení zápisníků v soukromém (privat) umístění v systému MapleCloud, které není přístupné 
ostatním uživatelům. 



Otevřením PALETY MapleCloud v levé části zápisníku Maple se zobrazí seznam sdílených zápisníků, ke 
kterým má uživatel oprávnění k jejich zobrazení. Lze také určit, kdo si může zobrazit obsah zápisníku, 
který sdílíte v systému MapleCloud nahráním jeho obsahu v dané uživatelské skupině. V systému 
MapleCloud jsou následující uživatelské skupiny: public, private, Maplesoft@admin, vlastní uživatelská 
skupina (např. RLopez) a MathApps. Na obr. 3.45 je uvedena PALETA MapleCloud, kde je zvolena 
uživatelská skupina public. 

 
Obrázek 3.45: Paleta MapleCloud 

V PALETĚ MapleCloud lze pomocí vyhledávacího pole provádět prohledávání dokumentů (zápisníků) 
ve vybrané sekci či skupině. Na obr. 3.45 se jedná o skupinu public. 

V PALETĚ MapleCloud jsou tři následující přednastavené skupiny: 

a) Skupina public: Všichni uživatelé Maple mohou zobrazovat a sdílet obsah zápisníků skupiny 
“public”. Obsah zápisníku v této skupině mohou si zobrazit všechny komunity používající 
MapleCloud. Všichni uživatelé Maple jsou členy této skupiny. Chcete-li sdílet však obsah 
Vašeho zápisníku, musíte být přihlášeni v systému MapleCloud. Nemusíte být přihlášen, 
abyste si zobrazil obsah sdílený jinými uživateli. 

b) Skupina Maplesoft@admin umožňuje jen čtení zápisníků. Jsou zde zobrazeny dokumenty jako 
Novinky v Maple, základní školení Maple apod. Maplesoft v ní sdílí například zápisníky, aplikací 
a další obsah, který může pomoci s řešením projektů v Maple. Všichni uživatelé Maple jsou 
členy této skupiny. Není nutné být přihlášen k zobrazení obsahu zápisníku v této skupině. 

c) Skupina MathApps umožňuje využití aplikaci z MathApps v zápisníku Maple. Uživatel Maple si 
může zvolit libovolnou aplikaci z této skupiny. Existují stovky interaktivních aplikací Math Apps 
dostupných v systému MapleCloud, např. z diferenciálního a integrálního počtu, lineární 
algebry statistiky, grafů, fyziky, inženýrství a dalších. Aplikace MatApps je možno načíst i 
z HLAVNÍHO MENU pomocí záložky Tools > MathApps. 

Při přihlášení do systému MapleCloud jsou k dispozici ještě dvě další skupiny: 

a) Skupina privat: V této skupině lze nahrávat obsah dokumentů, aby byly dostupné odkudkoliv 
na Internetu. Uživatelé, kteří nejsou členové této skupiny si nemohou zobrazit obsah 
dokumentů v této skupině privat. V této skupině lze nahrát obsah zápisníku, například pro 
uložení jeho obsahu, který se chce načíst v jiném počítači. 



b) Vlastní uživatelské (customs) skupiny: Kterýkoliv uživatel Maple, který je přihlášen v 
MapleCloud může vytvořit vlastní skupinu. Ve vlastní skupině vlastník skupiny schvaluje 
požadavky uživatelů pro připojení ke skupině a přiřadí členům skupiny oprávnění pro 
zobrazení a sdílení obsahu. Například vlastník skupiny může omezit členy skupiny ze sdílení 
obsahu a prohlížení obsahu sdíleným ostatními členy. Uživatel, který vytvoří skupinu, se 
automaticky stává vlastníkem skupiny a může spravovat členství ve skupině a obsah sdílených 
zápisníků ve skupině. Kromě schvalování žádosti o připojení do skupiny a přiřazování 
oprávnění členům skupiny může vlastník skupiny odstranit členy ze skupiny a odstranit obsah, 
který sdílí její členové. 

V PALETĚ MapleCloud  lze vybrat ze zvolené skupiny tři typy dokumentů (obr. 3.39): 

• Popular – zobrazuje nejpopulárnější dokumenty v této skupině; 
• New – zobrazuje nové dokumenty v této skupině; 
• Favorites – zobrazuje uživatelem nadefinované oblíbené dokumenty v této skupině. 

Pro procházení dokumentů v dané skupině slouží tlačítka označena jako „tlačítka na procházení 
seznamu“ na obr. 3.45. Pomocí těchto tlačítek se zobrazují další strany dostupných dokumentů. 

V případě nutnosti aktualizace zobrazení je možné kliknout na ikonu , viz obr. 3.45. 

Publikování dokumentu do systému MapleCloud 
Ikona  v PALETĚ MapleCloud slouží pro uložení dokumentu do systému MapleCloud a kliknutím 
na ni se vyvolá dialog, kde se nepřipojený uživatel, viz obr. 3.46,  musí nejprve nalogovat 
pomocí svého uživatelského jména a hesla a stisknutím „Log in“. 

 

Obrázek 3.46: Okno pro připojení k Maplesoftu 

Po nalogování se otevře další okno, viz obr. 3.47, 

Obrázek 3.47: Okno pro zaslání dokumentu do MapleCloud. 

kde je možné zvolit skupinu a název dokumentu, který se chce uložit do systému MapleCloud. 

Nastavení komunikace s systémem MapleCloud 
Kliknutím na ikonu nastavení   se vyvolá dialog nastavení se systémem MapleCloud, ve kterém 



je nejprve nutné se přihlásit ke svému uživatelskému účtu, viz obr. 3.48.  

 

Obrázek 3.48: Okno nastavení po přihlášení do MapleCloud. 

V dialogu nastavení po kliknutí na záložku Manage Groups možné vytvářet, sdílet, mazat skupiny, 
upravovat přístup uživatelů do skupin apod., viz obr. 3.49 a 3.50. 

 

Obrázek 3.49: Okno nastavení Manage Groups 

Ikona nastavení v PALETĚ MapleCloud se může měnit. Standardně je bez zobrazeného zeleného křížku 
(+). V případě, že je v ní zobrazen zelený křížek  znamená to, že nějaký uživatel čeká na povolení 
pro vstup do Vaší skupiny (na obr. 3.49 HrebicekExamples269691 Approve pending 
member). Kliknutím na záložku Members… se otevře dialogové okno, kde můžete čekajícího uživatele 
potvrdit nebo ne. 

 

Obrázek 3.50: Okno nastavení Manage Groups 



Je možné také nastavit „proxy server“ pro připojení, když je uživatel za tzv. proxy serverem. To se 
udělá kliknutím na záložku Proxy Server, viz obr. 3.48, kterou se otevře okno 

 

Obrázek 3.51: Nastavení Proxy Serveru 

Pokud je proxy server nastaven ve vašem defaultním připojení uživatelova počítače k internetu (proxy 
server nadefinován ve Windows), pak se většinou podaří připojit k MapleCloud bez nutnosti 
explicitního nastavení proxy server přímo v Maple. 

Vyhledávání dokumentů 
Pro vyhledávání dokumentů ze systému MapleCloud přímo v PALETĚ MapleCloud je nejprve nutné 
zvolit správnou sekci či skupinu (public, MathApps, …), a dále je nutné přepnout záložku Popular na 
New případně Favorites (zde je zase nutné být přihlášen, neboť se vyhledává mezi dokumenty 
označenými jak oblíbené), neboť záložka Popular reprezentuje pouze dokumenty v pořadí daném 
jejich popularitou. Pak následně do vyhledávacího pole (obr. 3.39) zadat hledaný text. Pokud nějaký 
dokument odpovídá dotazu je následně zobrazen v seznamu dostupných dokumentů v PALETĚ 
MapleCloud. Na obr. 3.44 je výsledek po vyhledání klíčového slova „stat“ v sekci public, kde byly 
nalezeny tři dokumenty. 

 
Obrázek 3.44: Vyhledání klíčového slova „stat” v sekci public 

 
V případě, že není nic nalezeno, je seznam prázdný případně s textem o nenalezení žádného 
dokumentu. 



Nastavení oblíbených dokumentů v MapleCloud 
Maple umožňuje označit některé dokumenty přístupné v PALETĚ MapleCloud jako oblíbené (tj. přidat 
dokument do oblíbených). V tomto případě je však nutné se nejprve přihlásit do systému MapleCloud, 
neboť tento označený seznam je navázán na daného uživatele. 

Pro přidání dokumentu mezi oblíbené stačí kliknout na ikonu hvězdičky v pravém horním rohu u názvu 
dokumentu. Následující obrázek ukazuje jednotlivé možnosti označování oblíbených dokumentů. 

 
Obrázek 3.45: Oblíbené dokumenty a práce s nimi PALETĚ MapleCloud 

  



Úlohy k procvičení 
V následujících cvičeních vytvořte matematický model systému a implementujte jej v Maple a 
nalezněte možné typy řešení modelu s využitím komponet z PALETY Componet. 

Cvičení 2.1: 
Mějme populaci P, kde P(t) je počet jedinců v čase t, která má konstantní specifickou míru růstu 
populace r (viz popsaný Malthusovský model) a v čase t=0 bude mít populace P0 jedinců. Uvažujme 
modifikovaný model, kde zahrneme vliv vnitrodruhové konkurence, tj. populace musí bojovat o 
omezené zdroje potravy a specifická míra růstu r bude funkcí r(P) velikosti populace P a bude klesat 
s její velikostí. Verhust navrhl tuto funkci r(P) jako lineární klesající funkci ve tvaru r(P) = r(1-P/K), kde 
kladný koeficient K se nazývá kapacita prostředí. Pokud velikost populace dosáhne kapacity prostředí 
K, přírůstek populace r(P) bude nulový, tj. je to tedy horní hranice velikosti populace P(t), kterou je 
prostředí schopno uživit. Dále budeme předpokládat, že specifická míra růstu r(0) = r >0, tj. je kladná. 
Tento model se v literatuře nazývá logistický model. 

Vytvořte spojitý a diskrétní matematický model (logistický model), implementujte jej v Maple 
s využitím komponent z PALETY Components s interaktivními grafy, kde se budou měnit parametry r a 
K. 

Cvičení 2.2: 
Vytvořte pomocí palet MapleCloud dokument, který nahrajete do systému MapleCloud jako public a 
ověříte jeho funkčnost ze zvoleného prohlížeče. 
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