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1 ARCCATALOG 
 

Aplikace ArcCatalog, která je součástí ArcGISu, slouží 
- k rychlému a snadnému prohlížení geografických dat (náhled, metadata, aj.) 
- ke správě geografických dat (snadné kopírování, mazání souborů formátu Shapefile) 
- ke správě metadat 
- k definování pracovních adresářů 
- ... 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Obr. 1.1 Obrazovka ArcCatalogu 
 



 

1.1 Prohlížení geografických dat 
 
K prohlížení geografických dat je dobré mít zobrazený Catalog Tree, viz obr. 1 

(Window > Catalog Tree). V okně Catalog Tree je mj. klasická adresářová struktura, kterou 
můžete procházet. Při procházení adresářové struktury ArcCatalog zobrazuje soubory 
geografických dat. Ikony u souborů indikují, o jaký formát geografických dat se jedná: 

 bodový Shalefile 

 liniový Shapefile 

 polygonový Shapefile 

 samotná atributová tabulka bez geometrie (pouze soubor nazev.dbf) 
 rastr (např. formát TIFF) 

 vrstva (layer) 
 projekt vytvořený v ArcMap 

 
Poznámka: Tento výčet není kompletní. Jsou v něm uvedeny formáty, se kterými se setkáte nejčastěji. 

 
 
Když v Catalog Tree kliknete na libovolný soubor, zobrazí se v hlavním okně 

ArcCatalogu informace o tomto souboru. Typ zobrazené informace závisí na tom, jaká z 
přepínacích karet hlavního okna (viz obr. 1.1) je aktivní. Zřejmě nejpoužívanější je karta 
Preview, která ukáže náhled geometrie geografických dat (v případě atributové tabulky ukáže 
její obsah). 

 
Karta Metadata zobrazí dostupná metadata, např. nadefinovaný souřadný systém (podkarta Spatial) nebo 

informace o jednotlivých sloupcích atributové tabulky (podkarta Attributes). 
Karta Contents se nejvíce používá k zobrazení obsahu adresáře aktivního v Catalog Tree. 

 
 
 
Úkol 
Projděte si geografická data v adresáři P:/_Home/Kurz GIS, především pomocí 

přepínací karty Preview. 
 
 



 

1.2 Nadefinování pracovního adresáře 
 
Na začátku každého projektu je dobré si nadefinovat pracovní adresář, tj. adresář, 

v němž budete pracovat ☺ (např. ukládat do něj vytvořené mapy, vrstvy, atd.). Nadefinování 
pracovního adresáře není nutností, nicméně urychlí práci. 

 
Upozornění: Pracovní adresář musí existovat už před jeho nadefinováním. 
Tzn. je nutné ho nejprve vytvořit. Je úplně jedno jak, např. pomocí Catalog Tree (klikněte pravým 

tlačítkem na adresář, v němž chcete vytvořit nový adresář, a New > Folder; vzniklý adresář pak přejmenujete 
tak, že na něj kliknete a zmáčknete F2). 

 
K nadefinování pracovního adresáře slouží ikona Connect to Folder    (File > 

Connect to Folder). Po spuštění Connect to Folder se otevře nové okno s klasickou 
adresářovou strukturou, v níž najdete pracovní adresář a potvrdíte (pracovní adresář už musí být 
vytvořen – viz výše). Vybraný pracovní adresář by se měl nyní objevit v okně Catalog Tree. 
Pracovních adresářů lze definovat libovolné množství. 

 
Odstranění pracovního adresáře z Catalog Tree se provede označením pracovního 

adresáře v Catalog Tree a ikonou Disconnect Folder   (File > Disconnect Folder nebo 
kliknutím pravým tlačítkem na pracovní adresář v Catalog Tree a Disconnect Folder). 

 
 
 
Úkol 
Vytvořte a nadefinujte si vlastní pracovní adresář ve vašem adresáři. 



 

1.3 Kopírování a mazání souborů geografických dat 
 
Některé formáty geografických dat jsou tvořeny více fyzickými soubory. Například 

Shapefile je tvořen soubory: 
nazev.shp  geometrie 
nazev.shx  vazba mezi geometrií a atributovou tabulkou 
nazev.dbf  atributová tabulka 

a některými dalšími, např. 
nazev.prj  definice souřadného systému 
nazev.sbn  prostorové indexy pro rychlejší prostorové vyhledávání 
nazev.sbx  prostorové indexy pro rychlejší prostorové vyhledávání 

Více soubory je také tvořen např. formát TIFF (nazev.tiff a nazev.tfw). 
 
 
Pří kopírování Shapefilů klasickou cestou tedy musíte dávat pozor na to, abyste 

zkopírovali všechny tyto soubory (nestačí zkopírovat jen nazev.shp). 
 
ArcCatalog umožňuje zkopírovat/přemístit/smazat všechny tyto soubory najednou tak, 

jako byste kopírovali/přesouvali/mazali pouze jediný soubor. Bohužel už neumožňuje 
kopírování/přemísťování/mazání více Shapefilů zaráz. 

Zkopírování Shapefilu se provede tak, že stisknete klávesu Ctrl a v Catalog Tree 
přetáhneme myší soubor do požadovaného adresáře. Obdobně se provede přemístění, s tím 
rozdílem, že nedržíte klávesu Ctrl. 

Smazání Shapefilu se provede jeho označením v Catalog Tree a stiskem klávesy Delete 
(nebo kliknutím pravým tlačítkem na Shapefile a Delete). 

 
 
 
Úkol 
Zkopírujte všechny Shapefily z adresáře P:/_Home/Kurz GIS do vašeho 

pracovního adresáře. 



 

1.4 Nadefinování souřadného systému u formátu Shapefile 
 
Velmi pravděpodobně se setkáte se soubory formátu Shapefile, o kterých sice budete 

vědět, jaký souřadný systém je v nich použit, ale tento souřadný systém u nich není explicitně 
nadefinován (tzn. neexistuje soubor nazev.prj – viz výše). Z mnoha důvodů je lepší před 
započetím práce v ArcMapu tento souřadný systém pomocí ArcCatalogu explicitně 
nadefinovat. 

 
Upozornění: Předpokladem nadefinování souřadného systému je fakt, že víte, jaký 

souřadný systém je v souborech formátu Shapefile použit. Pokud to nevíte, je definování 
souřadného systému k ničemu a je lepší jej nedefinovat vůbec. 

ArcČR používá souřadný systém S-JTSK_Krovak_East_North, což je zdaleka 
nejčastější elektronické podoba souřadného systému S-JTSK. 

 
Pro nadefinování souřadného systému nejprve dvojitě kliknete na Shapefile, u nějž 

chcete explicitně nadefinovat souřadný systém. Otevře se okno Shapefile Properties. Přepnete 
se na kartu Fields, ve sloupci Data Type kliknete na záznam Geometry a ve spodní tabulce u 
řádku Spatial Reference kliknete na tlačítko se třemi tečkami (poslední sloupec). Otevře se 
okno Spatial Reference. Nyní máte dvě možnosti, jak souřadný systém explicitně nadefinovat: 

 
A. Vyberete souřadný systém z nabídky ArcGIS 
Při tomto způsobu kliknete na Select, v poli Look in vyberete Coordinate Systems a v 
adresářích naleznete souřadný systém. Souřadný systém S-JTSK_Krovak_East_North se 
nachází v adresáři ProjectedCoordinateSystems > NationalGrids v souboru 
S-JTSK Krovak EastNorth.prj . Vše potvrdíte. 
 
B. Importujete již nadefinovaný systém z jiného Shapefilu 
Při tomto způsobu kliknete na Import a vyberete Shapefile, který už má daný souřadný 
systém explicitně nadefinován. Vše potvrdíte. 
 

O tom, zda jste souřadný systém nastavili, se přesvědčíte v přepínací kartě Metadata v podkartě Spatial. 
Možná budete muset nejdříve obnovit obsah adresáře (v Catalog Tree kliknete pravým tlačítkem na adresář a 
Refresh). 

 
Nadefinováním souřadného systému se vytvoří soubor nazev.prj . 
 
 
 
Úkol 
Shapefilům zkopírovaným do vašeho pracovního adresáře explicitně nadefinujte 

souřadný systém S-JTSK_Krovak_East_North. Vyzkoušejte si způsob A i B. 
 
 
 
 
 
 
 



2 ZÁKLADNÍ OVLÁDÁNÍ ARCMAPU 
 

Aplikace ArcMap, která je součástí ArcGIS Desktop, slouží 
- k vytváření map 
- k editaci geografických dat 
- k prostorové analýze 
- ... 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Obr. 2.1 Obrazovka ArcMap 

 



 

2.1 Spouštění ArcMapu a načtení vrstev 
 
ArcMap se spustí buď klasickou cestou nebo – pokud už máte spuštěný ArcCatalog – 

lze jej spustit ikonou Launch ArcMap   (Tools > ArcMap). Podobně lze z ArcMap spustit 
ArcCatalog. 

 
Obrazovka ArcMap se skládá ze čtyř základních částí (obr. 2.1): 

mapové okno je zobrazeno standardně, nelze je vypnout 
obsahová tabulka Window > Table of Contents 
ArcToolbox Show/Hide ArcToolbox Window  nebo Window > ArcToolbox 
příkazová řádka Show/Hide Command Line Window  nebo Window > Command Line 

 
Pro nás jsou zatím důležité dvě z nich: obsahová tabulka a mapové okno. Obsahová 

tabulka udržuje seznam načtených vrstev, umožňuje skrýt nedůležité vrstvy, měnit z-pořadí 
vrstev, aj. Mapové okno zobrazuje geometrii samotných vrstev, umožňuje je zvětšovat, 
zmenšovat, posouvat, ručně vybírat objekty, aj. 

 
 
Načtení vrstev je nutným krokem k zahájení jakéhokoliv projektu. Vrstvou v tomto 

případě rozumíme libovolný formát geografických dat. 
Načtení vrstvy se provede ikonou Add Data  (File > Add Data...). Otevře se známé 

okno pro otevření souboru. V poli Look in: budou kromě adresářové struktury zobrazené i 
pracovní adresáře dříve nadefinované v ArcCatalogu, takže se do nich lze snadno a rychle 
přepnout. U jednotlivých souborů jsou opět ikony indikující jejich formát. Označením 
jednoho či více souborů a potvrzením se vrstvy načtou. 

 
Pokud by načítané vrstvy neměly explicitně nadefinovaný souřadný systém, bylo by potřeba po načtení 

vrstev nadefinovat použité jednotky (kvůli měřítku). Toto by se provedlo příkazem View > Data Frame 
Properties, karta General, skupina Units, pole Map. V našich středoevropských podmínkách jsou těmito 
jednotkami většinou metry. 

 
 
Uložení projektu 
Uložení projektu se provede klasickým způsobem File > Save. V souboru projektu 

(nazev.mxd) je uložen mj. seznam načtených vrstev, jejich z-pořadí, zda jsou skryté či 
zobrazené, způsob klasifikace objektů jednotlivých vrstev, aj. 

 
 
Úkol 
Spusťte si ArcMap :-) 
Pokud není zobrazena obsahová tabulka, zobrazte si ji, pokud je zobrazen 

ArcToolbox nebo příkazová řádka, skryjte je. 
Načtěte si všechny Shapefily z vašeho pracovního adresáře. 
Uložte si projekt do Vašeho pracovního adresáře. 
 
 



 

2.2 Základní ovládání obsahové tabulky a mapového okna 
 
Zobrazení/skrytí vrstvy se provede v obsahové tabulce, přičemž musí být aktivní karta 

Display nebo Source (ve spodní části obsahové tabulky). Vrstva se zobrazí/skryje 
zaškrtnutím/odškrtnutím políčka u názvu vrstvy. 

 
Změna z-pořadí se provede v obsahové tabulce, přičemž musí být aktivní karta 

Display. Označením vrstvy, jejíž z-pořadí chcete změnit, a táhnutím myši ji přemístíte 
nad/pod libovolnou jinou vrstvu. 

 
Změna názvu vrstvy se provede v obsahové tabulce, přičemž musí být aktivní karta 

Display nebo Source. Dvojitým kliknutím na název vrstvy (nebo pravým kliknutím a 
Properties) se otevře okno Layer Properties, v kartě General je pole Layer Name (název 
vrstvy). Bez problému lze používat českou diakritiku. Název vrstvy se později objeví např. v 
legendě. 

 
 
Ovládání mapového okna 
Mapové okno se ovládá nástrojovou lištou Tools (View > Toolbars > Tools), viz 

obr. 2.2. Ovládání je velmi intuitivní a podobá se ovládání grafických editorů. 
 

  
Obr. 2.2 Nástrojová lišta Tools. 

 
Ikony Zoom In , Zoom Out , Fixed Zoom In , Fixed Zoom Out  slouží ke 

zvětšování/zmenšování obsahu mapového okna. Ikona Full Extent  zobrazí celý obsah. 
Ikona Pan  slouží k posouvání obsahu mapového okna. 
Ikona Select features  slouží k ručnímu vybírání objektů (vybírání objektů lze 

provést mnoha způsoby, toto je jeden z nich). Vícenásobný ruční výběr se provádí se 
stisknutou klávesou Shift. Práce s výběrem objektů bude popsána později. Odznačení 
vybraných objektů se provede příkazem Selection > Clear Selected Features nebo vybráním 
prázdného místa. 

Ikona Identify  slouží k zobrazení informací o konkrétním objektu. Těmito 
informacemi jsou data z atributové tabulky. 

Ikona Find  slouží k vyhledávání objektů podle dat z atributové tabulky, ikona Measure  k měření 
vzdálenosti v mapovém okně. 

 
V nástrojové liště Standard (View > Toolbars > Standard), viz obr. 2.3, je pole, které 

vám ukazuje aktuální měřítko obsahu mapového okna. Přepsáním měřítkového čísla v poli a 
stisknutím klávesy Enter lze měřítko měnit "manuálně". 

 

 
Obr. 2.3 Nástrojová lišta Standard, zcela vlevo je pole s aktuálním měřítkem obashu mapového okna. 

 
 
 



Úkol 
Vyzkoušejte si ovládání obsahové tabulky a mapového okna. 
Pojmenujte si všechny načtené vrstvy. 
Průběžně si ukládejte projekt :-) 

 

2.3 Atributová tabulka 
 
Atributová tabulka je nedílnou součástí vektorových geografických dat, bez ní by se 

jednalo pouze o data grafická. Práce s atributovu tabulkou se vzdáleně podobá práci s 
Excelovskými tabulkami. 

 
Zobrazení atributové tabulky se provede v obsahové tabulce, přičemž musí být 

aktivní karta Display nebo Source. Pravým tlačítkem kliknete na název vrstvy, jejíž 
atributovou tabulku chcete zobrazit, a Open Attribute Table. Otevře se nové okno Attributes of 
názevvrstvy. 

 
Sloupec FID je interním primárním klíčem programu ArcGIS (označení sloupce 

primární klíč znamená, že každý objekt má v daném sloupci svoji unikátní hodnotu, tzn. že 
pomocí této hodnoty jej lze vždy bezpečně identifikovat). 

Sloupec Shape je interním sloupcem programu ArcGIS a označuje typ geometrie 
daného objektu. 

Další sloupce jsou již závislé na atributové tabulce Shapefilu – každá atributová tabulka 
má libovolný počet sloupců s libovolnými názvy. 

 
Ve sloupcích můžeme mít uloženy různé typy dat, nejčastěji používanými typy jsou 

číselné typy a text. Na rozdíl od Excelu má každý sloupec atributové tabulky Shapefilu 
povinně definován právě jeden typ dat (tzn. v jednom sloupci jsou uložena buď data textová nebo data 
číselná, nikdy nemůže nastat situace, že část objektů má v jednom sloupci data číselná a zbylá část data textová). 
Následuje výčet nejpoužívanějších datových typů: 

 
   Rozsah     Poznámka 
Short integer -32 768 až 32 767   celá čísla 
Long integer -2 147 483 648 až 2 147 483 647 celá čísla 
Float  -3,4*1038 až 1,2*1038   reálná čísla 
Double  -2,2*10308 až 1,8*10308  reálná čísla 
Text  do 64 000 znaků   text 
 
 
Data v atributové tabulce lze řadit podle hodnot ve sloupcích kliknutím pravým 

tlačítkem na název sloupce a Sort Ascending / Sort Descending. 
 
V atributové tabulce lze provádět také ruční výběr objektů kliknutím na daný řádek v 

šedém sloupci zcela nalevo (ještě před sloupcem FID). Vícenásobný výběr se provádí se 
stisknutou klávesou Ctrl. Odznačení objektů lze provést stejně jako při ručním výběru objektů 
v mapovém poli nebo v atributové tabulce tlačítkem Options > Clear Selection. 

 
 
Úkol 
Vyzkoušejte si základní ovládání atributové tabulky.  



3 VÝBĚR, EDITACE ATRIBUTOVÉ TABULKY A OŘEZ 

3.1 Výběr 
 
Výběr objektů je jedním z nejpoužívanějších nástrojů geografických informačních 

systémů. Existují tři způsoby výběru dat: ruční výběr, výběr podle atributů a výběr podle 
lokace. 

 
Ruční výběr lze provádět buď přímo v mapovém okně pomocí ikony Select Features   

nebo v atributové tabulce (viz výše). 
 
Výběr podle atributů  (Selection > Select By Attributes) umožňuje vybrat objekty, 

jejichž atributy splňují zadané podmínky (tyto atributy musí být samozřejmě přítomny 
v atributové tabulce). Typickým příkladem je např. z vrstvy obcí vybrat obce nad 10000 
obyvatel nebo z vrstvy silnic vybrat všechny silnice první třídy, rychlostní komunikace a 
dálnice. 

V okně Select By Attibutes (viz obr. 3.1) je na výběr několik voleb. V poli Layer se zvolí 
vrstva, z níž se budou objekty vybírat, v poli Method se případně upřesní způsob výběru. 
V poli Fields je seznam sloupců atributové tabulky, podle kterých můžete objekty vybírat. 

Hlavním polem je SELECT * FROM nazevVrstvy WHERE: (viz obr. x.1). Do něj se 
zapisují podmínky výběru podobně jako v jazyce SQL (Structured Query Language – 
nejznámější jazyk pro manipulaci s daty navržený tak, aby se podobal anglickému jazyku). 
Nejlepší bude ukázat si zápis podmínky na konkrétních příkladech. 

 

 
Obr. 3.1 Okno Select by Attributes. 

 



Mějme vrstvu obcí, v níž je sloupec "OBYV" (celočíselného typu) s počtem obyvatel v 
jednotlivých obcích. Zápis podmínky pro výběr obcí nad 10000 obyvatel by vypadal 
následovně: 

"OBYV" > 10000 
(název sloupce se vždy zapisuje do dvojitých uvozovek). 
Podmínka pro výběr obcí nad 10000 obyvatel včetně: 
"OBYV" >= 10000 
Podmínky mohou být složitější, např. 
"OBYV" > 10000 AND "OBYV" <= 100000 
vybere obce s počtem obyvatel od 10000 do 100000 včetně. Klíčové slovo AND 

odpovídá českému "a zároveň". 
 
Mějme vrstvu silnic, v níž je sloupec "TRIDA_SIL" typu text označující třídu sinice. 

Hodnota 'D' označuje dálnici, hodnota 'R' rychlostní komunikaci, hodnota '1' silnici první 
třídy, hodnota '2' silnici druhé třídy a hodnota 'o' okresku. Zápis podmínky pro výběr dálnic, 
rychlostních komunikací a silnic první třídy by vypadal následovně: 

"TRIDA_SIL" = 'D' OR "TRIDA_SIL" = 'R' OR "TRIDA_SIL" = '1' 
Klíčové slovo OR odpovídá českému "a nebo". Hodnoty typu text se vždy zapisují do 

jednoduchých uvozovek. 
 
V okně Select By Attributes však nejste odkázáni na ruční psaní, stačí klikat myší ☺. 

Dvojitým kliknutím na název sloupce v poli Fields se vám název sloupce vepíše do hlavního 
pole, to samé platí pro klíčové znaky a slova uprostřed okna (=, <>, >, <, >=, <=, AND, OR, 
…). Znak <> odpovídá českému "nerovná se". 

Zajímavým tlačítkem je tlačítko Get Uniques Values. Jeho stisknutím se do pole Unique 
Values nahrají všechny unikátní hodnoty ze sloupce aktivního v poli Fields. Pokud by byl 
např. aktivní sloupec Fields, do pole Unique Values se vloží hodnoty 'D', 'R', '1', '2' a 'o'. 
Dvojitým linutím na nějakou hodnotu se tato hodnota vepíše do hlavního pole. 

 
Výběr podle lokace je posledním ze tří typů výběru (Selecion > Select By Location). Jedná se o 

poměrně silný nástroj, kterým se dají např. vybrat sídla ležící uvnitř okresu nebo sídla ležící do vzdálenosti 5 km 
od železnice. Jeho popis je nad rámec kurzu, přesto alespoň drobné základy: 

V poli the following layers se zatrhnou vrstvy, jejichž objekty chcete vybírat. 
V poli that zvolíte druh prostorové interakce mezi vybíranými objekty a jinou vrstvou (kterou 

specifikujete v poli the features in this layer). Druhem prostorové interakce je např. "má průnik s", "leží do 
vzdálenosti", "obsahuje", "je uvnitř", … 

 
 
Export vybraných objektů do nového Shapefilu 
Export vybraných objektů do nového Shapefilu se provede pravým kliknutím na název 

vrstvy v obsahové tabulce a Data > Export Data…. V poli Export musí být vybrána volba 
Selected Features. V poli Output shapefile or feature class je název a umístění výsledného 
Shapefilu, který lze samozřejmě změnit (buď ručním přepsáním nebo kliknutím 

na ikonu ). Stisknutím tlačítka OK se vygeneruje nový Shapefile, ArcGIS se pak ještě 
zeptá, zda jej chcete načíst do aktuálního projektu. 

 
 
Ať už objekty vyberete ručně, podle atributu nebo podle lokace, vždy je odznačíte 

příkazem Selection > Clear Selected Features. 
 
 



 
Úkol 
Zvolte si libovolný okres z okresy.shp, vyberte jej ručním výběrem a 

vyexportujte ho do nového Shapefilu. 
Výběrem podle atributů vyberte obce z obce.shp, které spadají do daného 

okresu (název okresu, do kterého obec spadá, je ve sloupci NAZEV_1, který je typu 
text). Vybrané obce vyexportujte do nového Shapefilu. 

Oba nové Shapefily načtěte do vašeho projektu. 
 

3.2 Editace atributové tabulky 
 
ArcGIS implicitně pracuje v režimu, který neumožňuje editaci načtených vrstev (ať už 

editaci atributové tabulky nebo geometrie). Před zahájením jakékoliv editace je tedy nutné  
aktivovat editační režim. Ten se edituje v nástrojové liště Editor (View > Toolbars > Editor) 
stisknutím tlačítka Editor > Start Editing. V případě, že všechny načtené vrstvy jsou v 
jednom adresáři, editační režim se ihned aktivuje. V případě, že načtené vrstvy jsou v různých 
adresářích, otevře se okno, v němž vyberete adresář s vrstvou, kterou chcete editovat, a 
potvrdíte. 

 
V editačním režimu lze editovat jak geometrii (to už je nad rámec kurzu), tak 

atributovou tabulku. Hodnoty v atributové tabulce se editují buď ručně podobně jako v Excelu 
(kliknete na buňku, jejíž hodnotu chcete změnit, a přepíšete ji) nebo hromadně. 

Hromadná editace se spustí kliknutím pravého tlačítka na název sloupce, jehož hodnoty 
chcete editovat, a Calculate Values. Otevře se okno Field Calculator. Popis všech funkcí 
nástroje Field Calculator by zabral několik stran, proto si rovnou ukážeme dva vzorové 
příklady. 

 
Chcete-li nastavit hodnoty všech objektů v daném sloupci na nějakou hodnotu, tuto 

hodnotu prostě a jednoduše vepíšete do pole NAZEVSLOUPCE = (pozor na to, že hodnoty 
typu text se zapisují do jednoduchých uvozovek). Stisknutím tlačítka OK se provede 
hromadná editace. Zajímavou a často využívanou vlastností je, že pokud jsou nějaké 
objekty vybrané, Field Calculator změní pouze hodnoty těchto vybraných objektů. 

 
Mějme polygonovou vrstvu okresů a v ní sloupec "PLOCHA" (double) s plochami 

okresů, "POC_OBYV" (long integer) s počtem obyvatel v okresech a "HUSTOTA" (double), 
který je zatím prázdný. Hustotu zalidnění pro všechny okresy spočítáte třeba tak, že spustíte 
Field Calculator na sloupci "HUSTOTA" a do pole HUSTOTA = vepíšete vzorec: 

[POC_OBYV] / [PLOCHA] * 100 
Field Calculator tedy vezme pro každý okres hodnotu ze sloupce "POC_OBYV", vydělí 

ji hodnotou ze sloupce "PLOCHA" a vynásobí stem. Výsledek pak zapíše do sloupce 
"HUSTOTA". Pozor na to, že názvy sloupců se v nástroji Field Calculator musí zapisovat do 
[hranatých závorek]. Podobně jako u výběru podle atributů nejste odkázáni pouze na ruční 
psaní, např, názvy sloupců můžete naklikat myší z pole Fields. 

Vzorce mohou nabývat libovolné složitosti, mimo základní matematické operátory jsou k dispozici i 
složitější funkce (pole Functions), které jsou různé pro různé typy sloupců (pole Type). 

 
 
K uložení změn v atributové tabulce dojde až v okamžiku přepnutí se zpět do 

needitačního režimu (tlačítko Editor > Stop Editing), kdy jste dotázáni, zda chcete změny 



opravdu uložit. Pokud ne, ArcGIS vrátí tabulku do stavu před přepnutím do editačního 
režimu. 

 
 
Přidání nového sloupce do atributové tabulky 
Přidání nového sloupce do atributové tabulky lze provést pouze v needitačním režimu. 

V atributové tabulce kliknete na tlačítko Options > Add Field…. V okně Add Field se vyplní 
pole Name (název sloupce, maximálně 8 znaků, bez mezer a diakritiky) a Type (datový typ 
sloupce). V poli Field Properties lze upřesnit vlastnosti datových typů (Precision = počet uložených cifer bez 
ohledu na počet desetinných míst, Scale = počet desetinných míst, Length = maximální dálka textu). 
Stisknutím tlačítka OK se vytvoří nový sloupec. 

 
 
 
Úkol 
V Shapefilu obce.shp vytvořte nový sloupec "HUSTOTA" typu double a pomocí 

nástroje Field Calculator do něj vložte průměrnou hustotu zalidnění pro každou obec. 
 

3.3 Ořez 
 
Ořez (Clip) slouží k ořezání objektů libovolné vrstvy podle objektů polygonové vrstvy, 

viz obr. 3.2. 
Ořez je jedním z nástrojů ArcToolbox, viz obr. 2.1 (Show/Hide ArcToolbox Window  

nebo Window > ArcToolbox). Pokud je v ArcToolbox aktivní karta Favorites, najdete ořez v 
Analysis Tools > Extract. Dvojitým kliknutím na Clip se otevře okno nástroje. 

 
 

l
o
F

Do pole Input Features přijde ořezávaná vrstva. 
Vrstvu lze do pole dostat dvěma způsoby: buď ji máte 
načtenou, pak ji naleznete po kliknutí na vysouvací 
šipku  na pravém konci pole, nebo ji nemáte načtenou, 
pak ji musíte nalézt v adresářové struktuře kliknutím na 

ikonu otevření souboru . 
 
Do pole Clip Features přijde polygonová vrstva, 

podle které se bude ořezávaná vrstva ořezávat. 
 
V poli Output Feature Class lze specifikovat název 

a umístění výsledné vrstvy (buď ručním přepsáním nebo 

kliknutím na ikonu ). 
 
Pole Cluster Tolerance nás nezajímá :-) 
 
Stisknutím tlačítka OK se spustí ořezávání. Otevře 

se okno informující o průběhu ořezávání. Pokud vše 
proběhne úspěšně, na předposledním řádku výpisu bude 
  
Obr. 3.2 Ořezání objektů 

ibovolné vrstvy (INPUT) podle 
bjektů polygonové vrstvy (CLIP 
EATURE). 



něco jako Executed (Clip_1) successfully. Pokud nastane chyba, objeví se ve výpisu červené 
chybové hlášení. 

Po skončení ořezávání zavřete okno informující o průběhu ořezávání. Ořezaná vrstva se 
automaticky načte do projektu. 

 
 
 
Úkol 
Pomocí nástroje Clip ořízněte shapefily sidlap.shp a silnice.shp podle vrstvy s 

vaším vybraným okresem. 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



4 KLASIFIKACE DAT 
 

4.1 Změna symbolu 
 

 Změna vyjádření symboliky může být provedena dvěma 
možnostmi.  
 
A. Kliknutím pravého tlačítka myši na název vrstvy. Zobrazí se vám 
následující volby. Z nich vyberete tu poslední, tj. Properties (Obr. 4.1). 
Objeví se vám následující dialogové okno. V něm kliknete na záložku 
Symbology (viz. Obr. 4.3). V horní polovině tohoto dialogového okna je 
(pod názvem Symbol) obdélník, který vám ukazuje, jaký symbol je 
právě používán. Pro jeho změnu je zapotřebí na něj kliknout – objeví 
se vám dialogové okno jako v Obr. 4.4. Toto okno bude odlišné 
v závislosti na tom, zda měníte symbol bodové, liniové nebo plošné 
vrstvy. V Obr. 4.4 máte také popsáno, jak změníte barvu výplně, barvu 
hraniční čáry a šířku hraniční čáry. Vnitřní výplň může být 100% 
průhledná – k tomu slouží volba Hollow v levé části dialogového 
okna. 
 
 
 
 
Obr. 4.1 Volby po kliknutí pravého tlačítka myši na název vrstvy. 
 
B. Kliknutím na symbol, který se nachází pod názvem vrstvy (Obr. 
4.2). Jedná se o rychlejší možnost, jak se dostat přímo k výběru změny 
symbolu. Otevře se vám stejné dialogové okno, jako je ukázáno v Obr. 
4.3. Způsob nastavování parametrů symbolu je tedy stejný. 

 
 
 
 
 
Obr. 4.2. Druhá (rychlejší) možnost změny symbolu. 

 
 
Úkol č.1 
 Zkuste si postupně nastavovat tyto vlastnosti symbolu u vrstvy okresy: 

� Okresy jsou průhledné a mají černou hraniční linii o šířce 1 bodu 
� Okresy mají světle žlutou barvu, hraniční linie je červená a má šířku 0,2 bodu 



 
Obr. 4.2. Záložka Symbology, která umožňuje definovat vlastnosti symbolu a klasifikace. 

 
 
 Dosud byla řeč jenom o plošných vrstvách. Dialogové okno nastavení základních parametrů symbolů je 
v těchto případech odlišné od toho, jež známe z Obr. 4.3. Pro liniové vrstvy vypadá tak, jak je ukázáno v Obr. 
4.4. Liniové vrstvy mají symbologii nejjednodušší ; nastavuje se pouze barva čáry a její šířka. Všimněte si také 
tzv. přednastavených stylů. Např. když v levé části dialogového okna kliknete na položku Highways (hlavní 
silnice), automaticky se vykreslí červenou barvou o šířce 3,4 bodu. Tyto přednastavené styly jsou zvláště vhodné 
např. pro vodní toky (River). Pro bodové vrstvy vypadá tak, jak je ukázáno v Obr. 4.5. Body mohou být buď 
jednobarevné nebo mohou mít obrysovou a vnitřní barvu. Pro obě varianty můžete nastavovat barvu a velikost 
symbolu v bodech. 
 
 
Úkol č.2 
  
 Zkuste si postupně nastavovat tyto vlastnosti symbolů: 
 

� U vrstvy VOD_TOK (vodní toky) si vyzkoušejte přednastavený styl River     

� U vrstvy ZELEZ (železniční síť) si vyzkoušejte přednastavený styl Railroad  
� U vrstvy silnice nastavit hnědou barvu a šířku čáry 2 body 
� U vrstvy SIDLAB (bodová sídla) nastavit symbol jako červený kruh s černým obrysem o velikosti 8 bodů 

 



 
Obr. 4.3. Nastavení základních parametrů symbolu (u plošných vrstev). 



 
Obr. 4.4. Nastavení základních parametrů symbolu (u liniových vrstev). 

 
 
 
 
 



 
Obr. 4.5. Nastavení základních parametrů symbolu (u bodových vrstev). 

 
 
 

4.2 Chorochromatická mapa 
 
 Ve většině případů vám nestačí, aby např. všechny kraje České republiky měly stejnou barvu. Chcete, aby 
každý kraj měl jinou (odlišnou) barvu. Tato mapa se pak nazývá chorochromatická. Její tvorba je velmi 

jednoduchá. Stačí kliknout pravým tlačítkem myši na název vrstvy, zvolit poslední 
volbu Properties a v nově otevřeném okně se přepnout do záložky Symbology 
(tento postup je naprosto shodný s tím, který je uveden v podkapitole 4.1).  
V levé části dialogového okna kliknete na volbu Unique values (Obr. 4.6). 

br. 4.6. Unique values – volba pro chorochromatickou mapu. 

Dialogové okno se vám změní na stejné, jako je v Obr. 4.7. V prvé řadě si musíte 
vybrat, podle kterého atributu se budou prvky odlišovat. Např. když u vrstvy kraje 
vyberete název, každý kraj, který má jiný název, než jiný, bude odlišnou barvou 
(tj. každý kraj bude mít svoji vlastní barvu). 
 
O
 
 
 



 
Obr. 4.7. Možnosti nastavení u chorochromatické mapy. 

 
 
 Poté, co si vyberete atribut, podle kterého se bude rozlišovat, musíte si zvolit, jaké prvky budou v mapě 
zobrazeny. Máte dvě možnosti: 

A. Přidáte všechny hodnoty 
To provedete stisknutím tlačítka Add All Values. Např. u vrstvy kraje vloží všechny kraje. 

B. Sami si vyberete, jaké hodnoty chcete přidat 
Po stisknutí tlačítka Add Values si zvolíte, které prvky chcete vybrat a které ne. V tomto případě 
má svůj smysl i volba all other values (najdete ji také v Obr. 4.7 pod roztahovacím okénkem, ve 
kterém volíte atributy). Tato volba vám umožňuje vyznačit stejnou barvou všechny prvky, které 
jste nevybrali. 
 

 Ještě před tím, než stisknete tlačítko OK, máte možnost dvojitým kliknutím na symbol dané kategorie 
tento symbol změnit.  
 
 
Úkol č.3 
 
 Zkuste si udělat politickou mapu České republiky. Za atributové pole zvolte NAZEV a zvolte volbu Add 
All Values.  
 
 
 

4.3 Tvorba kartogramu 
 
 Kartogram je jedním z nejčastějších typů map. Ve své podstatě rozlišujeme jeho dvě varianty: pravý 
kartogram (hodnoty jsou přepočteny na stejnou jednotku; typickým příkladem může být mapa hustoty 



obyvatelstva – jednotkou jsou obyv. na km2) a pseudokartogram (jednotky nejsou přepočteny na stejnou 
apa, kde je barvou zobrazován rok založení obce). plochu; příkladem může být m
 Pro kartogramy slouží v aplikaci ArcGIS volba Quantities. K ní se 
dostanete stejně, jak je pospáno v podkapitolách 4.1 a 4.2 (tj. v záložce 
Symbology). V levé části dialogového okna musíte kliknout na volbu Graduated 
colors (viz. Obr. 4.8). Zobrazí se vám dialogové okno, které je také v Obr. 4.9. 
Zde si v prvé řadě musíte vybrat, jaký atribut bude klasifikován – roztahovací 
okénko Value. Teprve poté se vám zobrazí, do kolika tříd chcete mapu 
klasifikovat (volba Classes).  
 
 
 
  ←  Obr. 4.8. Graduated colors – volba pro tvorbu kartogramů. 
 
 

 
 

Obr. 4.9. Možnosti nastavení pravého kartogramu a pseudokartogramu. 
 
 
 
 
 
 
 
 
 
 
 



4.4 Klasifikace bodů 
 
 Na poměrně velké části map je zapotřebí klasifikovat body. Typickým příkladem může být klasifikace 
sídel podle velikosti. Pro klasifikaci bodů v ArcGISu slouží volba Graduated Symbols (záložka Symbology ve 
vlastnostech vrstvy – Properties) – viz. Obr. 4.10.  

Zde naleznete následující možnosti nastavení – Obr. 4.11. Obdobně jako u 
tvorby kartogramu musíme v prvé řadě specifikovat, který atribut chceme 
klasifikovat. Další charakteristiky, které můžeme oproti výchozímu nastavení 
změnit, jsou: počet tříd klasifikace (Classes:) a velikost symbolu. Tato velikost se 
uvádí ve dvou hodnotách: 
 

  velikost největšího symbolu 
 
Velikost nejmenšího symbolu  

Obr. 4.10. Graduated symbols – volba pro klasifikaci bodových symbolů. 
 

 
Obr. 4.11. Možnosti nastavení parametrů u klasifikace bodových symbolů. 

 
 
 
 
 
 
 



4.5 Kartodiagramy 
 
 Kartodiagramem rozumíme spojení mapy a grafu. V tuzemské kartografické praxi patří tyto mapy 
(společně s kartogramy) mezi jedny z nejčastěji publikovaných. Abyste mohli vytvářet grafy, je zapotřebí 

 Obr. 4.12.  stisknout volbu Charts – viz.
Na rozdíl od předchozích druhů map zde naleznete tři volby. Rozlišujete tak, jaký 
typ grafu budete chtít sestrojit: 
   Pie  Bar/Column      Stacked  
    koláčový    sloupcový      skládaný 

 
 
 
 
 
 

 Pro všechny tři výše uvedené je zapotřebí specifikovat, jaká data budou 
v grafu zobrazena. To se nastavuje v pravé části dialogového okna – viz. Obr. 4.13.  
Obr. 4.12. Charts – volba pro tvorbu kartodiagramů. 
 

 
Obr. 4.13. Možnosti nastavení grafů. 

 
 Stejně jako u předchozích specifikujeme, jaké atributy mají být v grafu zobrazeny. Ve poli Field Selection 
vidíme všechny atributy dané vrstvy. Pomocí tlačítek střední části dialogového okna přiřazujeme, které atributy 
budeme zobrazovat v grafu: 

 přiřadí atribut do seznamu atributů grafu 
 

 odebere atribut ze seznamu atributů grafu 
 



 odebere všechny atributy  
 

 Další pomůckou při tvorbě grafu je volba , ta zamezuje překrývání jednotlivých 
grafů. Graf bývá standardně umístěn do středu území, ke kterému náleží. To však často vede ke kolizním 
situacím – překrývání a nečitelnosti jednotlivých grafů. Proto existuje volba Prevent chart overlap, která posune 
grafy v území tak, aby se vzájemně nepřekrývaly. 
 

 Zcela samostatné je nastavení velikosti u grafů. Děje se tak stisknutím na tlačítko . 
V případě sloupcových a skládaných grafů se vám objeví jednoduché dialogové okno, kde na jeho dolní části 
určíte „pouze“ maximální velikost grafu (Maximum Length).  Ovšem v případě koláčového grafu se vám otevře 
následující dialogové okno – viz. Obr. 4.14; s podstatně více volbami. 
 
 Výchozí hodnotou zde je volba 
Fixed size, která definuje, že všechny 
grafy budou mít stejnou velikost (tj. 
všechny koláče budou mít stejný 
průměr). Mnohdy je ale výhodnější, 
aby velikost grafu odpovídala další 
proměnné – např. znázorňujeme 
strukturu průmyslu sídla grafem a 
chceme, aby velikost odpovídala 
počtu obyvatel či počtu pracovních 
míst. K tomu slouží volba Vary size 
using a field a specifikace daného 
atributu. 
Mimo to můžete také specifikovat 
velikost grafu. 
 
 
 
 
 

Obr. 4.14. Nastavení velikosti a její 
závislosti na dalším atributu u 

koláčového grafu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



5 POPISKY 

 

5.1 Umísťování popisků 
 
Dvojitým kliknutím na název vrstvy v obsahové tabulce se otevře okno Layer 

Properties, v němž je karta Labels (popisky), viz obr 5.1. 
 

  
Obr. 5.1 Okno Layer Properties, karta Labels. 

 
Zatržení políčka Label features in this layer indikuje, zda se popisky zobrazují či 

nikoliv. 
 
Pole Method určuje dva způsoby popisování objektů: buď je pro všechny objekty vrstvy 

použit jeden formát popisku (Label all the features the same way) nebo jsou objekty vrstvy 
rozděleny do skupin, přičemž každá skupina má svůj vlastní styl popisku (Define classes of 
features and label each class differently). 

 
V případě druhého způsobu Define classes of features and label each class differently musíte nadefinovat 

jednotlivé třídy (třídu přidáte/smažete/přejmenujete tlačítkem Add.../Delete/Rename...). Kliknutím na tlačítko 
SQL Query... se otevře okno SQL Query, které funguje podobně jako výběr podle atributů (viz 3.1). Objekty, 
které vyhovují nadefinovaným podmínkám, spadají do dané skupiny. 

U tohoto způsobu musíte také všechny následující volby definovat pro každou třídu zvlášť. 
 
V poli Label Field se určí sloupec atributové tabulky, který obsahuje texty pro popisek 

(typicky např. názvy obcí). Ke specifikaci složitějšího popisku, např. kombinace textů z více sloupců apod., 
slouží karta Expression. 

 
 
Ve skupině Text Symbol se nastavuje grafický styl popisku, základními volbami jsou 

font, velikost v tiskových bodech, barva, tučné, kurzíva a podtržené. Kliknutím na tlačítko 



Symbol... se otevře okno Symbol Selector, v němž jsou předdefinované styly popisků. 
Kliknutím na tlačítko Properties v okně Symbol Selector se lze dostat do specializovaných voleb grafického 
stylu popisků. 

 
Ve skupině Other Options se definují způsoby umístění a zobrazení popisků. 
Kliknutím na tlačítko Placement Properties...  se otevře stejnojmenné okno se dvěma 

kartami: Placement a Conflict Detection. 
Volby v kartě Placement se liší v závislosti na typu geometrie: 
 

Bodová geometrie 
K dispozici jsou čtyři základní způsoby umístění popisků, nejdůležitější jsou první dva: 

Offset label horizontally around the point a Place label on top of the point. Offset label 
horizontally around the point definuje 8 polí v okolí bodového objektu a každému bodu dá 
číslo 0-3. 1 znamená, že dané pole je pro umístění popisku nejlepší, 3 naopak nejhorší. 
0 znamená, že popisek se v daném poli nikdy neumístí. Hodnoty v jednotlivých polích se dají 
změnit kliknutím na tlačítko Change Location. Druhý způsob – Place label on top of the point – 
určuje, že popisky se budou umísťovat přes bodový objekt. 

Liniová geometrie 
Čtyři základní způsoby orientace popisků: horizontal = horizontální umístění,  paralell = rovnoběžné s 

průměrným směrem objektu, curved = kopíruje linii (ideální pro popis vodních toků), perpendicular = kolmý na 
směr linie. Position (pozice) určuje, zda jsou popisky umístěny nad, pod nebo přes linii (oriantation system = 
page) nebo vpravo, vlevo nebo přes linii (oriantation system = line). 

Plošná geometrie 
K dispozici jsou volby umístění popisku Always horizontal (vždy vodorovně), Always 

stright (vždy ve směru protažení plošného objektu) a jejich kombinace. 
 

Volby v kartě Conflict Detection už jsou stejné pro všechny typy geometrie. Volby 
umožňují nastavit popiskům váhu/důležitost při jejich vykreslování (pole Label Weight), nastavit objektům jejich 
důležitost proto, aby nemohly být překryty méě důležitými popisky jiných vrstev, aj. Zatržením políčka 
Place overlapping labels se do mapy umístí i překrývající se popisky. Pokud je toto políčko 
nezaškrtnuté, překrývající se popisky se do mapy nevykreslí vůbec! 

 
Tlačítkem Scale Range (skupina Other Options v kartě Labels) umožňuje nadefinovat rozsah měřítek, ve 

kterých se popisky budou zobrazovat. Mimo rozsah se popisky nezobrazí. 
 
 
 
Úkol 
Zkuste si umístit názvy k bodovým sídlům s různými způsoby umístění. Pak je 

vypněte a umístěte názvy k jednotlivým obcím tak, aby se zobrazily i překrývající se 
popisky. 

 
 



 

5.2 Ruční úprava popisků 
 
Umístění popisků na mapách samozřejmě není dokonalé, vždy je potřeba je doladit 

ručně. Na to, aby bylo možné s popisky manipulovat, je potřeba je převést na grafické 
objekty. 

To se provede kliknutím pravým tlačítkem na název vrstvy v obsahové tabulce a 
Convert Labels to Annotation. Otevře se stejnojmenné okno. Ve skupině Store Annotation je 
třeba zvolit In the map, ve skupině Create Annotation For většinou All features. Stisknutím 
tlačítka Convert se popisky převedou na grafické objekty. 

Vizuálně sice vypadá vše stejně, ale není tomu tak. S popisky lze nyní totiž posouvat, 
přepisovat je, mazat je, kopírovat, aj. bez toho, aniž by se nějak změnila data v atributové 
tabulce vrstvy, jíž popisky náleží. 

K úpravám grafických objektů slouží nástrojová lišta Draw (View > Tools > Draw), viz 
obr. 5.2. 

 
  

Obr. 5.2 Nástrojová lišta Draw. 
 
K vybírání a přesouvání objektů slouží ikona Select elements  . 
Dvojitým kliknutím na konkrétní popisek se otevře okno Properties, v němž můžete 

změnit text popisku, aj. 
 
 
 
Úkol 
Převeďte popisky na grafické objekty a upravte je podle svých představ :-) 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



6 LAYOUT 
 

6.1 Základní ovládání Layoutu 
 
 Layout představuje prostor pro vytvoření finální mapy. Dosud jsme pracovali v tzv. View – to umožňuje 
připravit mapové pole. V Layoutu naopak přidáváme další prvky mapy, přinejmenším ty základní: název, 
měřítko, legenda, tiráž a (naše již připravené) mapové pole. Layout nám také umožňuje exportovat výslednou 
mapu do běžného formátu, který si můžeme prohlížet prakticky kdekoli (např. GIF, JPEG, TIFF,…). Přepínání 
mezi View a Layoutem ukazuje Obr. 6.1. 
 

  
Obr. 6.1. Přepínání mezi View a Layoutem. 

 
 V Layoutu je jiné ovládání, než znáte dosud z View. Používají se ikony s podobným vzhledem, jejich 
funkcionalita je však odlišná. Na první pohled je poznáte tak, že jsou v samostatném okně, které má nadpis 
Layout – viz. Obr. 10.2.  
 

 
 

Obr. 6.2. Ovládání mapy v módu Layout. 
 
 



6.2 Základní nastavení Layoutu 
 Jako první krok je nejvhodnější abyste si nastavili velikost 
pracovního prostoru – formát (papíru), na kterém budete pracovat a také 
některé další věci – jako např. orientace papíru. K tomu stačí kliknout 
kdekoli mimo ohraničený výkres pravým tlačítkem myši – zobrazí se vám 
nabídka jako na Obr. 6.3.  
 Zde vás budou zajímat zejména tyto dvě možnosti: 

� Page and Print Setup 
  (nastavují se zde rozměry papíru, tiskárny, orientace,  
  papíru…) 

� Guides 
  (můžete si vytvořit záložky – viz. dále) 
 
  ←  Obr. 6.3. Nastavení vlastností pro layout.  
 
Page and Print Setup 
 Po kliknutí na tuto volbu se vám objeví dialogové okno jako v Obr. 6.4. 
Zde si volíte následující parametry (viz. Obr.). 

 
 
 
 

Obr. 6.4. Nastavení papíru a tisku 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Guides 
jich nastavení není povinné, ulehčuje však práci. Pro práci se záložkami nastavujeme dva parametry – 

z. O
(zda vůbec chcete záložky zobrazovat) 

 
 

  Obr. 6.6. Ukázka nastavení záložek při tvorbě 

6.3 Přidání základních kompozičních prvků mapy 

Naše mapa dosud postrádala základní kompoziční prvky (mimo mapové pole). 
řidán

ěně fontu písma, velikosti a 
arovnání. 

 
Obr. 6.7. Položka Insert hlavního menu. 

 položkou Insert v hlavním menu). 
Legenda se vytváří v několika krocích. Prvním krokem je Obr. 6.8. 

 Je
vi br. 6.5: 

� Guides 
� Snap to Guides (jestliže umisťujete nějaký 

objekt poblíž záložky, automaticky si tento 
objekt „přitáhne“ a umístí přesně na záložku. 
Ukázku „snapování“ přináší Obr. 6.6) 

 
 
 
 
 
 
 
 
←

Obr. 6.5. Nastavení záložek. 

legendy mapy. 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
P í základních kompozičních prvků mapy (názvu, měřítka, legendy a tiráže) se 
provádí pomocí příslušných voleb v hlavním menu aplikace ArcMap – kliknutím na 
položku Insert – viz. Obr. 6.7.  
 
Název mapy 
 Pro přidání názvu mapy slouží volba Title. Při kliknutí se v horní části layoutu 
zobrazí místo, kam můžete vepsat název mapy. Při dvojitém kliknutí na tento název jej 
můžete změnit. Tlačítko Properties zde slouží ke zm
z

Legenda 
 Přidává se kliknutím na volbu Legend (pod



 
Obr. 6.8. Nastavení položek legendy, jejich pořadí a počtu sloupců. 

 
 Jakmile jsme specifikovali tyto parametry, stiskněte tlačítko Další. Další dialogové okno se vás ptá na 
nastavení názvu legendy. Česká kartografie striktně zakazuje označovat legendu nápisem „legenda“. Proto 
v tomto dialogovém okně vymažte původní nastavení Legend – jaké je v Obr. 6.9.   

 
Obr. 6.9. Zrušení názvu Legend. 

 Po kliknutí na tlačítko Další můžete nastavit ohraničení, barvu pozadí a stínování legendy (Obr. 6.10). 



 
Obr. 6.10. Nastavení ohraničení, barvu pozadí a stínování legendy. 

 
 Po kliknutí na tlačítko Další v následujícím dialogovém okně charakterizujete, jak budou prvky vaší 
legendy vypadat. Automaticky se generuje stejný vzhled prvků legendy podle jejich vzhledu v mapovém poli. 
Pokud by bylo třeba, můžete tyto parametry změnit.  

 
Obr. 6.11. Nastavení barvy a síly čáry jednotlivých prvků. 

 Poslední dialogové okno (Obr. 6.12) umožňuje nastavení mezer mezi jednotlivými částmi legendy. 
Vhodnější však většinou bývá nechat toto výchozí nastavení, legendu tzv. „rozbít“ (viz. dále) a uspořádat si ji 
podle svých představ a volného místa v layoutu.  



 
Obr. 6.12. Nastavení mezer mezi jednotlivými částmi legendy. 

 
 
Měřítko 
 Aplikace ArcGIS umožňuje zpracovat měřítko podle vlastních představ. Kliknutím na Insert > Scale Bar 
se dostanete do dialogového okna pro měřítko. Toto dialogové okno naleznete také v Obr. 6.13.  
 Hlavní nevýhoda přednastavených stylů spočívá v tom, že jsou uzpůsobeny anglosaské kartografii. Jinými 
slovy měřítko mapy je v mílích a číslice nejsou na správných pozicích. Proto vždy při tvorbě měřítka budete 
muset nastavovat další vlastnosti – tlačítko Properties. Teprve zde můžete zadat parametry, které budou korektní 
z hlediska české kartografie – viz. Obr. 6.14. V tomto nastavení byste měli měnit pouze počet hlavních a 
vedlejších dílků měřítka. 
 

 
 



 
Obr. 6.13. Výběr měřítka z přednastavených stylů. 

 
 
 
 
 
 
Úkol č.1 
 
 Zkuste si vytvořit měřítko, které bude vypadat následovně: 
 

 
 
Tip: menší písmo u vedlejších dílků vytvoříte za pomoci „rozbíjení“ – viz. podkapitola 6.4. 



 
Obr. 6.14. Nastavení parametrů měřítka korektně vůči české kartografii. 

 
Tiráž 
 Obsahuje údaje o autorovi, případně další informace, které chce autor mapy předat uživateli. Tiráž 
vložíme pomocí Insert > Text. Hlavní nevýhodou je, že se tiráž automaticky umístí do poměrně malého prostoru 

át.   
 Při dvojitém kliknutí 

uprostřed právě zobrazené části layoutu. Do tiráže je možné ihned ps
na tiráž se 

nge Symbol… 

Stejně jako tiráž se nastavuje i 
kýk

  Obr. 6.15. Nastavení tiráže. 

objeví další možnosti (Obr. 6.15): změna 
napsaného textu, formát,… 
Kliknutím na tlačítko Cha
můžete změnit styl písma a jeho velikost. 
 
 
ja oli text, který chcete umístit mimo 
mapové pole. 
 
 
 
 
←

 

 

 



 

6.4 „Rozbití“ základních kompozičních prvků (mimo mapové pole) 
 
 Vytvořené základní kompoziční prvky, popsané v předchozí podkapitole, nevyhovují vždy představám 
tvůrce mapy. Například legenda malou částí zasahuje do mapového pole a posunem není možné se tomuto 
konfliktu vyhnout. Proto existuje tzv. „rozbíjení“, které má za následek oddělení např. jednotlivých položek 
legendy. S legendou pak nepracujeme jako s celkem, ale měníme naprosto libovolně jakoukoli její část. 
„Rozbíjení“ se provádí následovně: 
 

1.  klikneme pravým tlačítkem myši na prvek, který chceme „rozbít“ 
2.  zvolíme položku Convert To Graphics (převede prvek na grafiku) – Obr. 6.16 
3.  klikneme pravým tlačítkem myši znovu na tento prvek 
4.  zvolíme položku Ungroup (rozdělí prvky) – Obr. 6.17 

 

 
Obr. 6.16. Převedení na grafiku. 

 
Obr. 6.17. Rozdělení prvku.



 
Možné je také prvky spojovat – vybereme prvky, které chceme spojit, stiskneme pravé tlačítko myši a vybereme 
volbu Group (seskupit).  
 
Upozornění ! 
 Převedení na grafiku (Convert To Graphics) je nevratnou funkcí. Po jejím spuštění není např. 
měřítko propojeno s původními daty – při změně měřítka se měřítko v layoutu nezmění ! 
 

6.5 Export mapy 
 
 Konečnou fází tvorby mapy obvykle bývá export do (přinejmenším) jednoho z běžných grafických 
formátů. Export se provádí v hlavním menu File > Export Map. Jestliže budete vkládat výslednou mapu jako 
obrázek do Wordu je nejvhodnějším formátem GIF. Pokud chcete mapu jako samostatný obrázek je vhodnější 
PDF nebo TIFF. Zkuste se vyvarovat formátu JPEG – ořezává hrany, které jsou u map velmi důležité. 
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